PDA

View Full Version : [ubuntu] Mouse and/or keyboard stops responding in Ubuntu 11.10



bryanray
January 1st, 2012, 10:40 PM
Hi,

I've been having some trouble with Ubuntu 11.10 recently, relating to the mouse and keyboard stopping responding. If anyone has any thoughts on what the problem may be I'd be grateful to hear them?

Thanks,
Bryan


Symptoms

Mouse stops responding:
I can crtl-alt-del out of current session, back to login prompt, where the mouse and keyboard work fine.

OR

Keyboard stops responding:
The mouse continues to move, but the mouse clicks don't respond and keyboard does not respond. I have to hard reset to restore the system.


The Hardware

Dell Invoice extract:

210-35184 XPS L702x : 2nd generation Intel Core i7-2630QM processor 2.00 GHz with Turbo Boost
2.0 up to 2.90 GHz
200-90883 N08X7M07
230-11879 Display : 17.3in FHD 3D WLED TL (1920X1080) 1080p with 2.0 Mega Pixel Integrated Camera
340-24595 Resource DVD : XPS L702x
370-15261 Memory : 8192MB (2x4096) 1333MHz DDR3 Dual Channel
400-21857 Hard Drive : 1TB (2x500GB) Serial ATA (7200RPM) Dual HDD
429-15549 Optical Drive : Tray Load Blu-ray Disc BD-Combo (Reads BD and Writes to DVD/CD)
450-15039 Power Cord : UK 250V
450-16096 Power Supply : XPS 150W AC Adapter
451-11543 Battery : Primary 9-cell 90W/HR LI-ION
490-12665 Graphics : 3GB NVIDIA GeForce GT 555M Graphics Card - 3D Capable
555-13613 Wireless : Europe Intel Centrino Wireless-N 1030 (1x2 b/g/n+ Bluetooth Combo Card)
583-14529 Keyboard : Internal Backlit UK/Irish Qwerty Keyboard
799-17065 XPS L702x Order - UK

The Software

root@bryans-laptop:~# uname -a
Linux bryans-laptop 3.0.0-14-server #23-Ubuntu SMP Mon Nov 21 20:49:05 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

root@bryans-laptop:~# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.10
Release: 11.10
Codename: oneiric

Customization

I have made the following changes to the system:
1/ Removed the unity desktop and replaced it with Gnome 3
2/ Replaced lightDM with GDM.

I think these were the instructions that I followed for replacing these components:

http://linux-software-news-tutorials.blogspot.com/2011/10/ubuntu-1110-oneiric-remove-unity-and.html

Syslog

Dec 29 13:29:06 bryans-laptop kernel: [ 21.961643] Synaptics Touchpad, model: 1, fw: 7.4, id: 0x1e0b1, caps: 0xd04773/0xa40000/0x8a0400
Dec 29 13:29:06 bryans-laptop kernel: [ 22.005098] input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio1/input/input10

xorg.conf

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 280.13 (buildd@yellow) Fri Aug 5 12:31:28 UTC 2011

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "LGD"
HorizSync 67.5 - 137.2
VertRefresh 60.0 - 120.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce GT 555M"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection


Xorg.0.log

[ 131.110]
X.Org X Server 1.10.4
Release Date: 2011-08-19
[ 131.110] X Protocol Version 11, Revision 0
[ 131.110] Build Operating System: Linux 2.6.24-29-server x86_64 Ubuntu
[ 131.110] Current Operating System: Linux bryans-laptop 3.0.0-14-server #23-Ubuntu SMP Mon Nov 21 20:49:05 UTC 2011 x86_64
[ 131.110] Kernel command line: BOOT_IMAGE=/vmlinuz-3.0.0-14-server root=/dev/mapper/raid--group-root--volume ro vga=769
[ 131.110] Build Date: 19 October 2011 05:21:26AM
[ 131.111] xorg-server 2:1.10.4-1ubuntu4.2 (For technical support please see http://www.ubuntu.com/support)
[ 131.111] Current version of pixman: 0.22.2
[ 131.111] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 131.111] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 131.111] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Dec 31 17:03:24 2011
[ 131.111] (==) Using config file: "/etc/X11/xorg.conf"
[ 131.111] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 131.112] (==) ServerLayout "Layout0"
[ 131.112] (**) |-->Screen "Screen0" (0)
[ 131.112] (**) | |-->Monitor "Monitor0"
[ 131.112] (**) | |-->Device "Device0"
[ 131.112] (**) |-->Input Device "Keyboard0"
[ 131.112] (**) |-->Input Device "Mouse0"
[ 131.112] (**) Option "Xinerama" "0"
[ 131.112] (==) Automatically adding devices
[ 131.113] (==) Automatically enabling devices
[ 131.113] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[ 131.113] Entry deleted from font path.
[ 131.113] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[ 131.113] Entry deleted from font path.
[ 131.113] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[ 131.113] Entry deleted from font path.
[ 131.113] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[ 131.113] Entry deleted from font path.
[ 131.113] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[ 131.113] Entry deleted from font path.
[ 131.113] (==) FontPath set to:
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/Type1,
/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
built-ins
[ 131.113] (==) ModulePath set to "/usr/lib/x86_64-linux-gnu/xorg/extra-modules,/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[ 131.113] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[ 131.113] (WW) Disabling Keyboard0
[ 131.113] (WW) Disabling Mouse0
[ 131.113] (II) Loader magic: 0x7e0220
[ 131.113] (II) Module ABI versions:
[ 131.113] X.Org ANSI C Emulation: 0.4
[ 131.113] X.Org Video Driver: 10.0
[ 131.113] X.Org XInput driver : 12.3
[ 131.113] X.Org Server Extension : 5.0
[ 131.115] (--) PCI:*(0:1:0:0) 10de:0dcd:1028:04b7 rev 161, Mem @ 0xd4000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x00004000/128, BIOS @ 0x????????/524288
[ 131.115] (II) Open ACPI successful (/var/run/acpid.socket)
[ 131.115] (II) LoadModule: "extmod"
[ 131.116] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[ 131.116] (II) Module extmod: vendor="X.Org Foundation"
[ 131.116] compiled for 1.10.4, module version = 1.0.0
[ 131.116] Module class: X.Org Server Extension
[ 131.116] ABI class: X.Org Server Extension, version 5.0
[ 131.116] (II) Loading extension MIT-SCREEN-SAVER
[ 131.116] (II) Loading extension XFree86-VidModeExtension
[ 131.116] (II) Loading extension XFree86-DGA
[ 131.116] (II) Loading extension DPMS
[ 131.116] (II) Loading extension XVideo
[ 131.116] (II) Loading extension XVideo-MotionCompensation
[ 131.116] (II) Loading extension X-Resource
[ 131.116] (II) LoadModule: "dbe"
[ 131.117] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[ 131.117] (II) Module dbe: vendor="X.Org Foundation"
[ 131.117] compiled for 1.10.4, module version = 1.0.0
[ 131.117] Module class: X.Org Server Extension
[ 131.117] ABI class: X.Org Server Extension, version 5.0
[ 131.117] (II) Loading extension DOUBLE-BUFFER
[ 131.117] (II) LoadModule: "glx"
[ 131.117] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/libglx.so
[ 131.127] (II) Module glx: vendor="NVIDIA Corporation"
[ 131.127] compiled for 4.0.2, module version = 1.0.0
[ 131.127] Module class: X.Org Server Extension
[ 131.127] (II) NVIDIA GLX Module 280.13 Wed Jul 27 17:12:07 PDT 2011
[ 131.127] (II) Loading extension GLX
[ 131.127] (II) LoadModule: "record"
[ 131.127] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[ 131.127] (II) Module record: vendor="X.Org Foundation"
[ 131.127] compiled for 1.10.4, module version = 1.13.0
[ 131.127] Module class: X.Org Server Extension
[ 131.127] ABI class: X.Org Server Extension, version 5.0
[ 131.127] (II) Loading extension RECORD
[ 131.127] (II) LoadModule: "dri"
[ 131.127] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[ 131.127] (II) Module dri: vendor="X.Org Foundation"
[ 131.127] compiled for 1.10.4, module version = 1.0.0
[ 131.127] ABI class: X.Org Server Extension, version 5.0
[ 131.127] (II) Loading extension XFree86-DRI
[ 131.127] (II) LoadModule: "dri2"
[ 131.127] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[ 131.127] (II) Module dri2: vendor="X.Org Foundation"
[ 131.127] compiled for 1.10.4, module version = 1.2.0
[ 131.127] ABI class: X.Org Server Extension, version 5.0
[ 131.127] (II) Loading extension DRI2
[ 131.127] (II) LoadModule: "nvidia"
[ 131.127] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/nvidia_drv.so
[ 131.128] (II) Module nvidia: vendor="NVIDIA Corporation"
[ 131.128] compiled for 4.0.2, module version = 1.0.0
[ 131.128] Module class: X.Org Video Driver
[ 131.128] (II) NVIDIA dlloader X Driver 280.13 Wed Jul 27 16:55:26 PDT 2011
[ 131.128] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[ 131.128] (--) using VT number 8

[ 131.129] (II) Loading sub module "fb"
[ 131.130] (II) LoadModule: "fb"
[ 131.130] (II) Loading /usr/lib/xorg/modules/libfb.so
[ 131.130] (II) Module fb: vendor="X.Org Foundation"
[ 131.130] compiled for 1.10.4, module version = 1.0.0
[ 131.130] ABI class: X.Org ANSI C Emulation, version 0.4
[ 131.130] (II) Loading sub module "wfb"
[ 131.130] (II) LoadModule: "wfb"
[ 131.131] (II) Loading /usr/lib/xorg/modules/libwfb.so
[ 131.131] (II) Module wfb: vendor="X.Org Foundation"
[ 131.131] compiled for 1.10.4, module version = 1.0.0
[ 131.131] ABI class: X.Org ANSI C Emulation, version 0.4
[ 131.131] (II) Loading sub module "ramdac"
[ 131.131] (II) LoadModule: "ramdac"
[ 131.131] (II) Module "ramdac" already built-in
[ 131.131] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/nvidia_drv.so
[ 131.131] (II) Loading /usr/lib/xorg/modules/libwfb.so
[ 131.131] (II) Loading /usr/lib/xorg/modules/libfb.so
[ 131.131] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[ 131.131] (==) NVIDIA(0): RGB weight 888
[ 131.131] (==) NVIDIA(0): Default visual is TrueColor
[ 131.131] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[ 131.132] (**) NVIDIA(0): Option "TwinView" "0"
[ 131.132] (**) NVIDIA(0): Option "MetaModes" "nvidia-auto-select +0+0"
[ 131.533] (II) NVIDIA(0): NVIDIA GPU GeForce GT 555M (GF106) at PCI:1:0:0 (GPU-0)
[ 131.533] (--) NVIDIA(0): Memory: 3145728 kBytes
[ 131.533] (--) NVIDIA(0): VideoBIOS: 70.06.32.00.03
[ 131.533] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[ 131.533] (--) NVIDIA(0): Interlaced video modes are supported on this GPU
[ 131.533] (--) NVIDIA(0): Connected display device(s) on GeForce GT 555M at PCI:1:0:0
[ 131.533] (--) NVIDIA(0): LGD (DFP-2)
[ 131.533] (--) NVIDIA(0): LGD (DFP-2): 480.0 MHz maximum pixel clock
[ 131.533] (--) NVIDIA(0): LGD (DFP-2): Internal DisplayPort
[ 131.535] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID has been
[ 131.535] (**) NVIDIA(0): enabled on all display devices.
[ 131.554] (II) NVIDIA(0): Assigned Display Device: DFP-2
[ 131.555] (II) NVIDIA(0): Validated modes:
[ 131.555] (II) NVIDIA(0): "nvidia-auto-select+0+0"
[ 131.555] (II) NVIDIA(0): Virtual screen size determined to be 1920 x 1080
[ 131.790] (--) NVIDIA(0): DPI set to (128, 130); computed from "UseEdidDpi" X config
[ 131.790] (--) NVIDIA(0): option
[ 131.790] (--) Depth 24 pixmap format is 32 bpp
[ 131.791] (II) NVIDIA: Using 3072.00 MB of virtual memory for indirect memory
[ 131.791] (II) NVIDIA: access.
[ 131.901] (II) NVIDIA(0): Setting mode "nvidia-auto-select+0+0"
[ 131.991] (II) Loading extension NV-GLX
[ 132.045] (==) NVIDIA(0): Disabling shared memory pixmaps
[ 132.045] (==) NVIDIA(0): Backing store disabled
[ 132.045] (==) NVIDIA(0): Silken mouse enabled
[ 132.045] (**) NVIDIA(0): DPMS enabled
[ 132.045] (II) Loading extension NV-CONTROL
[ 132.045] (II) Loading extension XINERAMA
[ 132.045] (II) Loading sub module "dri2"
[ 132.045] (II) LoadModule: "dri2"
[ 132.046] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[ 132.046] (II) Module dri2: vendor="X.Org Foundation"
[ 132.046] compiled for 1.10.4, module version = 1.2.0
[ 132.046] ABI class: X.Org Server Extension, version 5.0
[ 132.046] (II) NVIDIA(0): [DRI2] Setup complete
[ 132.046] (==) RandR enabled
[ 132.046] (II) Initializing built-in extension Generic Event Extension
[ 132.046] (II) Initializing built-in extension SHAPE
[ 132.046] (II) Initializing built-in extension MIT-SHM
[ 132.046] (II) Initializing built-in extension XInputExtension
[ 132.046] (II) Initializing built-in extension XTEST
[ 132.046] (II) Initializing built-in extension BIG-REQUESTS
[ 132.046] (II) Initializing built-in extension SYNC
[ 132.046] (II) Initializing built-in extension XKEYBOARD
[ 132.046] (II) Initializing built-in extension XC-MISC
[ 132.046] (II) Initializing built-in extension SECURITY
[ 132.046] (II) Initializing built-in extension XINERAMA
[ 132.046] (II) Initializing built-in extension XFIXES
[ 132.046] (II) Initializing built-in extension RENDER
[ 132.046] (II) Initializing built-in extension RANDR
[ 132.046] (II) Initializing built-in extension COMPOSITE
[ 132.046] (II) Initializing built-in extension DAMAGE
[ 132.046] (II) Initializing built-in extension GESTURE
[ 132.047] (II) Initializing extension GLX
[ 132.060] (II) XKB: reuse xkmfile /var/lib/xkb/server-B20D7FC79C7F597315E3E501AEF10E0D866E8E92.xkm
[ 132.065] (II) config/udev: Adding input device Power Button (/dev/input/event3)
[ 132.065] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[ 132.065] (II) LoadModule: "evdev"
[ 132.065] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[ 132.065] (II) Module evdev: vendor="X.Org Foundation"
[ 132.065] compiled for 1.10.2, module version = 2.6.0
[ 132.065] Module class: X.Org XInput Driver
[ 132.065] ABI class: X.Org XInput driver, version 12.3
[ 132.065] (II) Using input driver 'evdev' for 'Power Button'
[ 132.065] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[ 132.065] (**) Power Button: always reports core events
[ 132.065] (**) Power Button: Device: "/dev/input/event3"
[ 132.065] (--) Power Button: Found keys
[ 132.065] (II) Power Button: Configuring as keyboard
[ 132.065] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input3/event3"
[ 132.065] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
[ 132.065] (**) Option "xkb_rules" "evdev"
[ 132.065] (**) Option "xkb_model" "pc105"
[ 132.065] (**) Option "xkb_layout" "gb"
[ 132.067] (II) XKB: reuse xkmfile /var/lib/xkb/server-2B4266AA55228AE7D9557A18F1965DBA19850816.xkm
[ 132.169] (II) config/udev: Adding input device Video Bus (/dev/input/event5)
[ 132.169] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[ 132.169] (II) Using input driver 'evdev' for 'Video Bus'
[ 132.169] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[ 132.169] (**) Video Bus: always reports core events
[ 132.169] (**) Video Bus: Device: "/dev/input/event5"
[ 132.169] (--) Video Bus: Found keys
[ 132.169] (II) Video Bus: Configuring as keyboard
[ 132.169] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0A08:00/device:2c/LNXVIDEO:00/input/input5/event5"
[ 132.169] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD)
[ 132.169] (**) Option "xkb_rules" "evdev"
[ 132.169] (**) Option "xkb_model" "pc105"
[ 132.169] (**) Option "xkb_layout" "gb"
[ 132.176] (II) config/udev: Adding input device Power Button (/dev/input/event0)
[ 132.177] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[ 132.177] (II) Using input driver 'evdev' for 'Power Button'
[ 132.177] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[ 132.177] (**) Power Button: always reports core events
[ 132.177] (**) Power Button: Device: "/dev/input/event0"
[ 132.177] (--) Power Button: Found keys
[ 132.177] (II) Power Button: Configuring as keyboard
[ 132.177] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input0/event0"
[ 132.177] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
[ 132.177] (**) Option "xkb_rules" "evdev"
[ 132.177] (**) Option "xkb_model" "pc105"
[ 132.177] (**) Option "xkb_layout" "gb"
[ 132.178] (II) config/udev: Adding input device Lid Switch (/dev/input/event2)
[ 132.178] (II) No input driver/identifier specified (ignoring)
[ 132.179] (II) config/udev: Adding input device Sleep Button (/dev/input/event1)
[ 132.179] (**) Sleep Button: Applying InputClass "evdev keyboard catchall"
[ 132.179] (II) Using input driver 'evdev' for 'Sleep Button'
[ 132.179] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[ 132.179] (**) Sleep Button: always reports core events
[ 132.179] (**) Sleep Button: Device: "/dev/input/event1"
[ 132.179] (--) Sleep Button: Found keys
[ 132.179] (II) Sleep Button: Configuring as keyboard
[ 132.179] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0C0E:00/input/input1/event1"
[ 132.179] (II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD)
[ 132.179] (**) Option "xkb_rules" "evdev"
[ 132.179] (**) Option "xkb_model" "pc105"
[ 132.179] (**) Option "xkb_layout" "gb"
[ 132.183] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=9 (/dev/input/event11)
[ 132.183] (II) No input driver/identifier specified (ignoring)
[ 132.183] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=8 (/dev/input/event12)
[ 132.183] (II) No input driver/identifier specified (ignoring)
[ 132.184] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=7 (/dev/input/event13)
[ 132.184] (II) No input driver/identifier specified (ignoring)
[ 132.184] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=3 (/dev/input/event14)
[ 132.185] (II) No input driver/identifier specified (ignoring)
[ 132.187] (II) config/udev: Adding input device Laptop_Integrated_Webcam_2HDM (/dev/input/event9)
[ 132.187] (**) Laptop_Integrated_Webcam_2HDM: Applying InputClass "evdev keyboard catchall"
[ 132.187] (II) Using input driver 'evdev' for 'Laptop_Integrated_Webcam_2HDM'
[ 132.187] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[ 132.187] (**) Laptop_Integrated_Webcam_2HDM: always reports core events
[ 132.187] (**) Laptop_Integrated_Webcam_2HDM: Device: "/dev/input/event9"
[ 132.187] (--) Laptop_Integrated_Webcam_2HDM: Found keys
[ 132.187] (II) Laptop_Integrated_Webcam_2HDM: Configuring as keyboard
[ 132.187] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.4/1-1.4:1.0/input/input9/event9"
[ 132.187] (II) XINPUT: Adding extended input device "Laptop_Integrated_Webcam_2HDM" (type: KEYBOARD)
[ 132.187] (**) Option "xkb_rules" "evdev"
[ 132.187] (**) Option "xkb_model" "pc105"
[ 132.187] (**) Option "xkb_layout" "gb"
[ 132.188] (II) config/udev: Adding input device HDA Intel PCH Mic (/dev/input/event7)
[ 132.188] (II) No input driver/identifier specified (ignoring)
[ 132.188] (II) config/udev: Adding input device HDA Intel PCH Headphone (/dev/input/event8)
[ 132.188] (II) No input driver/identifier specified (ignoring)
[ 132.192] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event4)
[ 132.192] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[ 132.192] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
[ 132.192] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[ 132.192] (**) AT Translated Set 2 keyboard: always reports core events
[ 132.192] (**) AT Translated Set 2 keyboard: Device: "/dev/input/event4"
[ 132.192] (--) AT Translated Set 2 keyboard: Found keys
[ 132.192] (II) AT Translated Set 2 keyboard: Configuring as keyboard
[ 132.192] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input4/event4"
[ 132.192] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
[ 132.192] (**) Option "xkb_rules" "evdev"
[ 132.192] (**) Option "xkb_model" "pc105"
[ 132.192] (**) Option "xkb_layout" "gb"
[ 132.192] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event10)
[ 132.192] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "evdev touchpad catchall"
[ 132.192] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
[ 132.192] (II) LoadModule: "synaptics"
[ 132.192] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
[ 132.192] (II) Module synaptics: vendor="X.Org Foundation"
[ 132.192] compiled for 1.10.4, module version = 1.4.1
[ 132.192] Module class: X.Org XInput Driver
[ 132.192] ABI class: X.Org XInput driver, version 12.3
[ 132.192] (II) Using input driver 'synaptics' for 'SynPS/2 Synaptics TouchPad'
[ 132.192] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
[ 132.192] (**) SynPS/2 Synaptics TouchPad: always reports core events
[ 132.192] (**) Option "Device" "/dev/input/event10"
[ 132.232] (--) SynPS/2 Synaptics TouchPad: x-axis range 1472 - 5398
[ 132.232] (--) SynPS/2 Synaptics TouchPad: y-axis range 1408 - 4728
[ 132.232] (--) SynPS/2 Synaptics TouchPad: pressure range 0 - 255
[ 132.232] (--) SynPS/2 Synaptics TouchPad: finger width range 0 - 15
[ 132.232] (--) SynPS/2 Synaptics TouchPad: buttons: left right double triple
[ 132.232] (--) SynPS/2 Synaptics TouchPad: touchpad found
[ 132.232] (**) SynPS/2 Synaptics TouchPad: always reports core events
[ 132.233] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input10/event10"
[ 132.233] (II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD)
[ 132.233] (**) SynPS/2 Synaptics TouchPad: (accel) MinSpeed is now constant deceleration 2.5
[ 132.233] (**) SynPS/2 Synaptics TouchPad: MaxSpeed is now 1.75
[ 132.233] (**) SynPS/2 Synaptics TouchPad: AccelFactor is now 0.039
[ 132.233] (**) SynPS/2 Synaptics TouchPad: (accel) keeping acceleration scheme 1
[ 132.233] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration profile 1
[ 132.233] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration factor: 2.000
[ 132.233] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration threshold: 4
[ 132.235] (--) SynPS/2 Synaptics TouchPad: touchpad found
[ 132.235] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/mouse0)
[ 132.235] (II) No input driver/identifier specified (ignoring)
[ 132.245] (II) config/udev: Adding input device Dell WMI hotkeys (/dev/input/event6)
[ 132.245] (**) Dell WMI hotkeys: Applying InputClass "evdev keyboard catchall"
[ 132.245] (II) Using input driver 'evdev' for 'Dell WMI hotkeys'
[ 132.246] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[ 132.246] (**) Dell WMI hotkeys: always reports core events
[ 132.246] (**) Dell WMI hotkeys: Device: "/dev/input/event6"
[ 132.246] (--) Dell WMI hotkeys: Found keys
[ 132.246] (II) Dell WMI hotkeys: Configuring as keyboard
[ 132.246] (**) Option "config_info" "udev:/sys/devices/virtual/input/input6/event6"
[ 132.246] (II) XINPUT: Adding extended input device "Dell WMI hotkeys" (type: KEYBOARD)
[ 132.246] (**) Option "xkb_rules" "evdev"
[ 132.246] (**) Option "xkb_model" "pc105"
[ 132.246] (**) Option "xkb_layout" "gb"
[ 144.256] (II) XKB: reuse xkmfile /var/lib/xkb/server-5550814D3DE81657FB75A6E398FC443242E652DD.xkm

bryanray
January 8th, 2012, 11:46 AM
Still no solution here...

JazzPotato
January 8th, 2012, 03:24 PM
Check that everything looks good in /etc/acpi

bryanray
January 8th, 2012, 09:29 PM
Check that everything looks good in /etc/acpi

I've had a quick look in the folder, which contains a whole load of shell scripts which react to different events. However, what should "good" look like?

It may well be something event related as the problem occurs either once, soon after login/boot, or not at all.

virx
January 12th, 2012, 04:40 PM
I have the some problem for about a week or so. It must be some update that has messed up something or ... something else :P

Today I noticed, that it worked, but when I started pidgin and on the background was ubuntu backup tool working and at the moment I cannot see windows close, minimize, maximize buttons nor unity panel. ALT-TAB programs switching does not work also. Sorry that I am not able to give any technical info (logs, etc)...

PS: I have one Logitech wireless and one wired mouse connected. I also use startup script xmodmap for setting up mouse keys as I wish...

PS2: I have COM port smartcardreader powersource connected between PC and keyboard.

Do we have any simlarities on our systems?

bryanray
January 14th, 2012, 12:52 PM
I would like to say yes and help identify a cause of the problem - but no... My laptop is one of these: http://www.dell.com/us/dfh/p/xps-l702x/pd

No xmodmap
A single Synaptics mouse (at least as far as the driver is concerned)
I do have a card reader (I don't think that it is connected via a COM port, however it is internal)

If you suspect any of the items you list, then you could simply try removing them?

Finally my problems started soon after installation, probably when I customized the desktop environment...

plexi50
January 14th, 2012, 04:35 PM
Uncheck disable touch pad while typing in the Mouse and Touch pad settings. I had the same problem, and that seemed to make them stop.

virx
January 20th, 2012, 07:49 PM
In my Desktop there is no such an option, but the problem seems to be dissapeared mysteriously like it appeared. Probably it was some update...

doublem99
January 20th, 2012, 10:29 PM
I believe an update fixed this. With my initial fresh install of 11.10 it happened to me twice on 2 separate installs. After system update I can't duplicate the problem anymore.

bryanray
February 5th, 2012, 10:50 AM
Uncheck disable touch pad while typing in the Mouse and Touch pad settings. I had the same problem, and that seemed to make them stop.

After a week of usage this appears to be fixed. The turning point seemed to be enabling the touch pad when typing. It is quite possible that it was coincidentally an update...

Thanks for the help peeps!

nicolagiacobbe
March 6th, 2012, 01:13 PM
Hello,
same thing happened to me one week ago: Ubuntu 11.10 on an old desktop PC with 1.5GByte RAM and both Keyboard and Mouse on USB.
Being unable to find the: "Uncheck disable touch pad while typing" option in the Mouse and Touch pad settings, I had to dig around, and what seemed to solve the issue was to: "Enable USB legacy devices" in the BIOS.