View Full Version : [ubuntu] Can't install: (initramfs) mount failed

December 24th, 2011, 08:42 PM
I'm at my wits end after much Googling I haven't been able to come up with a solution to this problem. I've tried booting from USB and CD, and each time Ubuntu fails to install on my Dell Inspiron 1525 laptop, which already has an old version of Ubuntu on it. I get the following error message:

(initramfs) mount: mounting /dev/loop0 on //filesystem.squashfs failed: Invalid argument
Can not mount /dev/loop/0 (/cdrom/casper/filesystem.squashfs) on //filesystem.squashfs.

Sometimes it only gets as far as the (initramfs) prompt. I've tried all sorts of fixes, and none have worked. I have confirmed that the USB install works just fine on another laptop,so the .iso is not corrupt. Can anyone help, please?

December 31st, 2011, 12:38 AM
Can anyone help? Nothing is working... how can I install Ubuntu on this laptop?

January 11th, 2012, 02:15 PM
I have the same error message from the CD, I just burned using the
infrarecorder program, {I burned the cdrom at 16x slow speed.}

First try for ubuntu. :(

you have to download an image, and can not burn it direct, what is up with that??
Then download another program to burn the cd, and then it will not work. :(

I have tried poopylinux before, and could not get any .exe files to work, when trying to
do a virus scan on a computer.

I think I need a bigger hammer.
Darn computer schtuff.