PDA

View Full Version : [ubuntu] Automatically skip problem files when copying in gnome file manager



MorayJ
December 22nd, 2011, 10:13 PM
Quite often, when I'm copying large amounts of files with the file manager, I want to leave the copy unattended. When I come back, I often find a prompt asking me what to do with a certain file.

For instance a message saying couldn't copy file - skip, retry, skip all.

How do I set it to skip all from the beginning and, ideally, to tell me at the end what the problems were?

Thanks for reading!

MorayJ

searchfgold6789
December 22nd, 2011, 11:00 PM
There should be an "Apply to all" check box.

saneearth
December 23rd, 2011, 12:45 AM
If you are doing back up or transferring files and folders there are two types of messages. The first will ask you if you want to merge the folder and there is a check box to do this for all. If you don't check that it will ask again. Afterwards you will be asked about files: Do you want to replace or skip. There is again a checkbox asking if you want to do this for all (skip or replace). If you check those boxes for folders first and files secondly, you should then be able to leave it unattended.

MorayJ
December 23rd, 2011, 07:31 PM
I'm thinking about file errors that may occur later. So, the last one I did contained a 'socket' file that couldn't be copied...so it doesn't happen at the beginning. It happens when it comes across a problem.

If I'm thinking about the same thing, to apply your decision to all requires you waiting for the first problem.

Is there a way to pre-empt this and just ignore any errors?