View Full Version : [all variants] Unable to switch workspace without WINE game following me?

December 13th, 2011, 12:50 PM
Wine 1.3.15
Xubuntu 11.04 (xfce)
HD Radeon 4650

I have just installed a new video card and I am unable to switch between my virtual workspaces while World of Warcraft is running.

With my old card Nvidia 7300 LE I was able to do this if I wanted to check something on the internet and then go straight back into the game etc.

I have emulated a virtual desktop of size 1280x1024 (the size of my display) and I also have tried with WoW's internal options 'run in windowed mode' and 'maximize'.

The game appears to flicker for a split second and then jump with me to the different workspace.

If I keep Windowed mode checked, but uncheck maximize I can play it and navigate workspaces but I'm stuck with my xfce top panel visible, and a border too.

Please see screenshot 1.

When I run it in windowed mode without being maximized and right click the titlebar and select fullscreen everything works properly, but I would like this to be automatic.

Using gDevilspie with a rule to fullscreen the WoW window, and with windowed mode activated but maximized checked in WoW's internal options I can now run it full screen and switch workspaces without it following me but there is a slight graphics corruption down the bottom of the screen showing my the bottom of my irssi client running terminal on the workspace I moved from.

Please see screenshot 2.

Please also note I am testing the game on on a private server until I can confirm the game will run as it used to a few months ago before re-activating my official subscription at a cost.

Is there a workaround?