View Full Version : [ubuntu] Gnome 3 shell not working properly

vat with tux
December 8th, 2011, 05:30 AM
I have intalled gnome 3 shell on my ubuntu 11.10 system. It work working perfect but since last two days whenever i logs into gnome 3 it looks like classic gnome environment and not Gnome 3. Same thing happens in case of unity means when i logs into unity it behaves like unity 2D. Means effects are not working properly. I'm not getting that exactly what is missing. Help me out.... thanking in advance...

vat with tux
December 8th, 2011, 08:34 AM

December 8th, 2011, 08:48 AM
Its probably to do with your graphic driver ..... what graphics card do you use .... ?

vat with tux
December 8th, 2011, 08:55 AM
I'm not having any additional graphic card. I'm having intel core 2 duo cpu.... and I as i said that before 2 days it was working perfect without any problems......

December 8th, 2011, 09:07 AM
If you logoff, can you logon on Unity (3d)?

December 8th, 2011, 09:17 AM
As I see you have problems with your Compiz which is crashing.

Try to reset Compiz:

gconftool-2 --recursive-unset /apps/compiz-1 && gconftool-2 --type=list --list-type=string --set /apps/compiz-1/general/screen0/options/active_plugins [core,bailer,detection,composite,opengl,compiztoolb ox,decor,grid,move,resize,mousepoll,regex,snap,gno mecompat,place,imgpng,vpswitch,animation,wall,work arounds,fade,session,expo,ezoom,unityshell] && compiz --replace & disown

December 8th, 2011, 04:59 PM
As my Dad always used to say to me ...... when my car stopped working ..... and it was ok
before I messed with it ......

Look at the last thing you did with it before it stopped working .... and often you will find
the cause ....

It takes 30 minutes to re-install ..... consider that ...... also try running it from a live CD .....

if it works ok from the live CD ..... then it may just be that by altering plymouth and your
boot up that somehow ...... you managed to disable the graphic acceleration needed to
run both UNITY 3D and GNOME SHELL

If you had said one works and the other does not ....... it would not lead me to believe its
a graphics driver related problem ...... but my guess is a clean install would solve your problems as you said it worked perfectly 2 days ago .....

What changed :confused: reading your previous posts ..... maybe somehow you altered something to cause this ...... I would either try retracing my steps ..... or start afresh .....

Your call though .....

I have seen people waste a week .... and not get sorted properly - and then re-install ... but
you will learn something along the way if you choose the path of greater enlightenment.

Which computer do you have ?

vat with tux
December 9th, 2011, 04:08 PM
@23dornot23d yeah dude ... i was playing with plymouth and this happened......

December 9th, 2011, 04:17 PM
You could try typing in

gnome-shell --replace

in a terminal window and see what the output is .....

cut and paste it back in here ...... it may give someone a clue ...... just in case it is simple to fix.

vat with tux
December 12th, 2011, 03:58 AM
here is the output of gnome-shell --replace

abcl@ubuntu:~$ gnome-shell --replace
gnome-shell: error while loading shared libraries: libclutter-1.0.so.0: cannot open shared object file: No such file or directory

December 12th, 2011, 09:56 AM
It doesn't have anything to do with Plymouth, that is animation while boot is happening.
It looks like your Clutter libraries aren't installed. Try reinstalling gnome-shell.

December 13th, 2011, 04:02 PM
I agree .... that from that error .... you have things missing ..... but we have yet
to see if you have the graphics capability to run it yet ..... plymouth is not the cause
but in trying to set it up .... you may have inadvertently altered something else
that is yet to be seen ......... as Unity should run in 3D mode as it did before you
altered things.

To install Gnome-Shell

Here is the long way of doing it ..... but it should check for dependencies and makes
sure you get the full install of gnome-shell and the advanced tweak tool too.
*(gnome-tweak-tool alone pulls in everything .... but just to be sure - belts and braces ...... )

In a terminal do this .....

sudo apt-get update
sudo apt-get install aptitude
sudo aptitude update
sudo aptitude install gnome-tweak-tool
sudo aptitude install gnome-shell

gnome-shell --replace

and post the output again please ..... hopefully it will run ..... ;)

Frogs Hair
December 13th, 2011, 04:24 PM
I'm not sure why libclutter is missing or not being found but it is a place to start as stated .

vat with tux
December 14th, 2011, 11:12 AM
Thanks to all for trying hard....:) But finally I reinstalled system because many things were messed up ...:D So now every things working cool.... :D

December 15th, 2011, 07:53 PM
Nice to hear you are up and running again .... :D

Best of luck setting it up as you want it too .

December 15th, 2011, 11:49 PM
You must've uninstalled the GNOME Shell libraries. Simple fix (so far as I know)

sudo apt-get install libclutter-1.0-0
Just for future reference

Hope this comes in handy to the wandering forums viewer with this problem!


December 24th, 2011, 07:05 AM
It might be local (only proper to the user). If so, that would necessarily that the issue is in the gnome 3 configuration files.

To verify if it's the case, run a guest session ; it's easy, lightGDM let you do that. If gnome 3 runs well in a guest session, then everything is fine your issue is only local to your user session. Otherwise, good luck my friend !

Solving bad config files is quite easy, you just have to delete them. They are hidden and probably in ./config

I have better stuff to do that looking in that, so I'll let you do so. Otherwise, if you're a lazy *** like me, just get the rid of ~/config and ~/local/share/gnome-shell, restart your session, let that big boy write back its stuff and enjoy !

EDIT : Just saw you've reinstalled your system.. lmao
By design, YOU CAN'T alter the libs and the executables as a normal user. Reinstalling the stuff is quite dumb as the chances you've messed them up is nearly 0. Most of my bad behiavior issues where related to the local config files and I believe it's the first place to look for when you're getting troubles... Anyway enjoy your day ! And also if you really want to dive into gnome 3, get Fedora ! Unity's getting anywhere :P