View Full Version : [SOLVED] Defining default browser

November 13th, 2011, 12:58 PM

I just uninstalled Firefox and installed the latest version of Google chrome on my 11.10 xubuntu system. I didn't remove the webbrowser link in the system menu but instead i redirected it to the application file google chrome. But for some reason, it doesn't seem to save that this is the file i want to run by default. Everytime i click the link i have to tell the system which browser to use.

How can i make it so google chrome runs by default when i click the link?

November 13th, 2011, 01:06 PM
To change the default application you click the up right corner and check first option System Settings. Then choose on System, System Settings and the tab Default Applications. From there change Firefox to Chrome.

November 13th, 2011, 01:22 PM

I followed your instruction, and it worked awesome. Thank you! :D

November 13th, 2011, 01:28 PM
Please mark the thread as solved from Thread tools on the top

November 22nd, 2011, 12:55 AM
Well, I am glad that procedure worked for you, DeceptiveHornet, but I have the same problem and it didn't work for me. I have also run

sudo update-alternatives --config x-www-browser

and set the default browser that way -- also didn't work.

Also, setting Chrome as default through Chrome itself doesn't work

So, it appears to me that this is a true bug. I also notice that it is a problem that has occurred in earlier versions of Xubuntu. (See this earlier thread: http://ubuntuforums.org/showthread.php?t=775613&highlight=Xubuntu+default+browser).

Consequently, I would ask that this question be reopened.



March 15th, 2012, 08:20 AM
I just had exactly the same problem today from a fresh install of Xubuntu 11.10 and google-chrome-stable.

I am also requesting that this question be reopened.