View Full Version : [ubuntu] dpkg --configure -a freezes

November 7th, 2011, 03:10 PM
I upgraded from 11.04 to 11.10 today. During upgrade, the system freezed when configuring/installing software center. Unfortunately I had to give it cold reboot. After that I am able to log in to new 11.10 but when I try to install anything, I get the message to run
sudo dpkg --configure -aI run that and again it hangs at configuring software-center. I do not know what to do! Browsing other posts,
I learned that using
sudo dpkg -D2000 --configure -a will give more information. But the only message that is displayed is

Setting up software center ( I do not know how can I debug this, since when I run this command system hangs.

Please help me fix this issue.


November 7th, 2011, 04:16 PM
You need to run those commands with root permissions.
sudo dpkg --configure -a

Try again and you may get it to work that way.

November 7th, 2011, 05:23 PM
Hi ajgreeny

Thanks for your reply. Actually I ran with root permissions. Sorry my initial post is not clear. I will modify it.

November 7th, 2011, 05:45 PM

Try purging and reinstalling the software center.

sudo apt-get remove --purge software-center

Reconfigure again.

sudo dkpg --configure -a

sudo apt-get install software-centerUpgrades can always be problematic. Consider backing up your files and installing a fresh 11.10 .

Kind regards