View Full Version : [SOLVED] 11.10 x64 Server hangs at boot after BIOS update

November 6th, 2011, 02:01 PM
Hi guys,

Today I updated my BIOS, because Ubuntu 11.10 x64 Server didn't correctly shut down after a sudo poweroff (it rebooted instead).

While I've solved this issue after the BIOS update, I now have a new problem at boot.

The boot proces waits infinite. But when I insert an USB thumb drive into a USB port, the boot proces continues :confused:

dmesg lists:

[ 0.550847] system 00:01: [io 0x04d0-0x04d1] has been reserved
[ 0.550855] system 00:01: [io 0x0220-0x0225] has been reserved
[ 0.550860] system 00:01: [io 0x0290-0x0294] has been reserved
[ 0.550865] system 00:01: Plug and Play ACPI device, IDs PNP0c02 (active)
[ 130.684414] INFO: rcu_sched_state detected stalls on CPUs/tasks: { 0} (detected by 2, t=32534 jiffies)
[ 130.717712] pnp 00:02: [io 0x4100-0x411f]
[ 130.717715] pnp 00:02: [io 0x0228-0x022f]
[ 130.717717] pnp 00:02: [io 0x0238-0x023f]

So it seems to me the boot proces hangs or waits at PNP device PNP0c02.

Can someone please help?

Frogs Hair
November 6th, 2011, 03:45 PM
Hello and Welcome

If you enter the bios (key bindings vary) during the boot process you can check the primary boot device and see if is set to boot from the hard drive .

Bois update methods and screens vary for different mother boards so , I can't supply any one procedure that will correct this. Checking the boot priority is a good place to start .

November 8th, 2011, 02:24 PM
Well, the boot sequence wasn't the problem. I solved via a kernel reinstall and an update-initramfs...