PDA

View Full Version : [ubuntu_studio] 11.04 Network



Risingfate
November 5th, 2011, 03:10 AM
Okay so i finally (after about 5 different .iso's and 2 different usb creation programs) got ubuntu studio 11.04 running on my computer dual booted with 11.10. But i'm really disappointed in how frustrating it has been to get it set up since that's one of my favorite perks about linux is easy set-up/re-installation.

Anyway, venting aside, I cannot get my wireless network to work. I don't have access to the actual router so i cannot plug my computer in for a wired connection and the wireless will not pick up. It says "firmware not ready" (or something like that) and then when i tried putting (3 different builds) network-manger on a usb and installing it. It comes up with "intltool needs to be at least version .40" so I went out and got a lower version of network manager. And it says "28pre9" not installed while trying to configure it. So I downloaded and installed libiw30_30-pre9-3ubuntu6_i386.deb and installed that and it still doesn't work. NOTHING will allow me to get wireless networking working on my ubuntu studio setup. And i'm about to throw my computer out the window. I thought that it would be nice to have a stripped down lean kernal for audio processing/recording. But nothing could be worth this trouble.

Please someone save me from doing serious harm to this laptop before the night is over. :popcorn:

jejeman
November 5th, 2011, 10:01 AM
I don't know where you got idea to change network manager because of firmware.
Give us output from

sudo lshw -C network

Risingfate
November 14th, 2011, 11:39 PM
*-network
description: Ethernet interface
product: 88E8040 PCI-E Fast Ethernet Controller
vendor: Marvell Technology Group Ltd.
physical id: 0
bus info: pci@0000:09:00.0
logical name: eth0
version: 12
serial: 00:1d:09:48:33:ed
capacity: 100Mbit/s
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=sky2 driverversion=1.28 firmware=N/A latency=0 link=no multicast=yes port=twisted pair
resources: irq:43 memory:fe8fc000-fe8fffff ioport:de00(size=256)
*-network
description: Network controller
product: BCM4312 802.11b/g LP-PHY
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:0b:00.0
version: 01
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list
configuration: driver=b43-pci-bridge latency=0
resources: irq:17 memory:fe7fc000-fe7fffff
*-network DISABLED
description: Wireless interface
physical id: 2
logical name: wlan0
serial: 00:1f:3a:87:47:4b
capabilities: ethernet physical wireless
configuration: broadcast=yes driver=b43 driverversion=2.6.38-8-generic firmware=N/A link=no multicast=yes wireless=IEEE 802.11bg


I switched to 10.04 (I think) like you had suggested in the other thread.

Sorry it took me so long to get back to you on this thread. Life has been crazy. BUT I'm really excited to get cracking at some new songs! So I hope you guys can help!

jejeman
November 15th, 2011, 03:05 PM
You are missing firmware for wireless card
Look here, and check section about instaling it withouth network access
https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx
Also if you are really running ubuntu studio 10.04, you need to mannualy setup your netwok.
To find out issue command

lsb_release -a

Risingfate
November 19th, 2011, 04:21 AM
Flipping top notch! That worked excellently. Took a little bit of doing and some steps were unnessary/didn't work. But it is working now and I am sending this message to my fully funtional copy of Ubuntu Studio 11.04! Thanks so much jeje!

mathia
November 19th, 2011, 04:01 PM
Hi,
if your wired network did not work properly, install it from here:

- Installing Marvell Yukon driver on Ubuntu, e.g. 8040:

Please install the following driver as follows:
http://www.marvell.com/support.html -> "88E8040 Search" -> Kernel 2.6.x Linux Driver Install Package for Yukon Devices Linux 2.6 - Fedora v10.91.2.3

$ sudo tar xvfj install_v10.91.2.3.tar .bz2
$ cd DriverInstall
$ sudo bash ./install.sh

and let me know if it works.

Have a lot of fun ...:razz: