View Full Version : Network printer: Processing - Not connected?

November 2nd, 2011, 11:40 PM
I have a Brother DCP7065DN attached to the network. Previously I was able to print to it with no problem from my 10.04 desktop. Suddenly this week everytime I go to print something I get the following message in the print queue: Processing - Not connected? I've also noticed that when I send a print job to the printer a little blue circle with an "i" in it appears over the printer icon in the System>Administration>Printing window. I've deleted and added the printer a few times and cycled the power to both devices. I've tried managing it through localhost:631 but nothing seems to fix the problem. I seem to remember CUPS being updated in the last week but I'm not sure. Can anyone help me?

November 3rd, 2011, 12:03 AM
Try pinging your print server from another computer.

November 4th, 2011, 05:02 PM
How do I do that? I have just tried printing from my laptop running 11.04 and have the same problem. Printing is not a problem from windoze so it's not a hardware problem.

November 4th, 2011, 05:30 PM
I seem to have found a solution. Previously I was installing the driver via the 'Find Network Printer' option in the 'Select Device' window. Now I selected the 'Internet Printing Protocol' option and put in the IP address of the printer and cleared the 'Queue' field then clicked verify and selected the driver that I had installed earlier and now everything seems to be working. It's working in both 10.04 and 11.04.

November 9th, 2011, 06:37 PM
This problem seems to have returned. I've installed 11.04 on a new machine and installed the printer the way I installed it on the other machines, through the IPP option, and now I'm getting the same message. The problem has also returned on the other Ubuntu machines on the network. Windoze machines on the network are still printing fine.

November 9th, 2011, 08:08 PM
So I've reinstalled the printer several different ways again. This time I went through the "Find Network Printer" option. I provided the IP of the printer and at first it returned a JetDirect printer and then about 10 seconds later it returned the Brother printer. I tried both of these options. The second one seems to be working. This is exactly the way that I had installed the printer when this whole problem started, so I'm going to give it a few days and see if the problem recurs.

November 17th, 2011, 06:42 PM
This problem has returned. I haven't made any changes to the printer configuration. Any ideas?

November 17th, 2011, 07:46 PM
Are you using static IP or DHCP to get your IP addresses on your network?.
If using DHCP then your print server is possibly going to get a different IP every boot up. It could be something as simple as that.

Test with ping command ( run terminal )


If 198.168.02 is your print server. Use ifconfig ( in terminal ) on the print server to get it's IP or right click on network icon ( on the panel )and select connection information.
Then ping it from another computer.

Also if using a firewall make sure you allow traffic ( in and out ) on port 631 on all machines. Try disabling Firewall on all machines to test.

Also make sure your print server is set to broadcast it's presence on the network. Run print manager on Print Server and select Server from menu and tick publish shared printers. If you do this you will be able to use the Find Network Printer option on the other computers to find your printer.

Hope this helps

November 17th, 2011, 07:49 PM
It's actually static IP. That much I am sure of. The problem must be with CUPS somewhere because the window$ machines have no problem printing.

Both Ubuntu machines can ping each other.

Do the machines with the print servers need to have static IPs? Rebooting and reinstalling the printer would fix the issue then, wouldn't it? I just ask because I have tried that and it didn't resolve anything.

November 17th, 2011, 08:01 PM
Did you select publish shared printers on the Server menu?

November 17th, 2011, 08:13 PM
Other than that try to get the cups screen up in your browser

Run Firefox and type in the URL Bar
If is your IP of the print server

That's about the limit of my vast knowlede on cups ;-)

November 17th, 2011, 08:27 PM
Yes the printer seems to be shared by default. The "Shared" box is checked when I check the properties of the printer.

Just reinstalled the printer and it's working again. I checked the router device list and it turns out that the printer was assigned a static IP but the other machines were not, although I'm pretty sure they've been getting the same IP addresses for quite a while. Now everything has a static IP. Thanks for your help SparTacux.

November 17th, 2011, 08:33 PM
Is your printer attached to an Ubuntu computer or to the router?

November 17th, 2011, 08:55 PM
To the router through a switch.

September 13th, 2012, 08:35 AM
I have the same problem with my Brother MFC-425CN, attached to the router.
The router DHCP is configured to always assign the same ip address to the printer.
Suddenly I can't print from either my desktop or netbook -"processing - not connected" being the status in the print queue.
Odd thing is that I can initiate and print a test page no problem.

I have deleted and recreated the printer definitions but nothing works.

Help, please ...

September 13th, 2012, 12:50 PM
I have found that sometimes it helps to disable and re-enable the printer. Also, printing from the browser seems to be more problematic than printing from other applications.

September 13th, 2012, 01:28 PM
I've disabled, deleted, disconnected, rebooted, and anything else I can think of to no effect.

I'm having probs from all applications inc browser and LibreOffice.

September 13th, 2012, 01:41 PM
Which version of Ubuntu are you using?

September 13th, 2012, 02:06 PM
I've had very good luck with networked brother printers using the following procedure. YMMV as usual.

I get to the printing applet. I'm using gnome-shell which uses a 'dumbed-down' printer app but the command <system-config-printer> in terminal brings it up. Right-click on the printer icon and select "properties". One of the lines should be "Device URI". I put the following: socket://xxx.xxx.xxx.xxx:9100 where x=i.p. address of the printer. You may want to restart though I don't know if a restart is necessary. This has been pretty successful for me. Other printer network connection protocols have been hit-and-miss for me.

September 13th, 2012, 03:56 PM
Which version of Ubuntu are you using?

Using 12.04

Re the solution from kurt18947 - I was set up like that anyway. Tried a reboot (again) and sent a doc to print.

Same problem as before.

Easy Limits
September 13th, 2012, 04:48 PM
Have you tried "system-config-printer" at the terminal?

September 13th, 2012, 04:56 PM
Have you tried "system-config-printer" at the terminal?

yep, and played about with the properties in various configurations.

Peter Maunder
September 13th, 2012, 05:50 PM
I am not certain whether my experience is directly relevant, but I too have a Brother network attached.

My Brother HL-5250DN is attached as an USB printer to my desktop and as a network printer to the Desktop and Laptop running 12.04 and a Netbook with Linux-Mint (Mate) 13.
I used to have a problem when the printer was directly addressed ( or if I turned the printer on after the computers, because the router added addresses dynamically. I defined the printer in the Laptop and Netbook twice with different addresses to get around this problem. USB connection was no problem.

Since 12.04 the printer was redefined in the properties Device URI: as
dnssd://Brother%20HL-5250DN%20series._pdl-datastream._t after upgrading the systems from Ubuntu 11.04. Now the order for turning on the printer is not important.

September 13th, 2012, 08:00 PM
My device is now dnssd://Brother%20MFC-425CN._pdl-datastream._tcp.local/
still the same error.

What a complete bugger - was printing fine until today and can't identify any changes which would have affected this.

Peter Maunder
September 14th, 2012, 04:14 PM
Just a thought, but have you checked the cables and they are correctly seated? Running a test print is a short message compared with activating and downloading print job with its associated fonts.

September 14th, 2012, 04:36 PM
Hi - yes disconnected and reconnected both ethernet and power cables at both ends, and still had the problem.

Curiously though, I have managed to print today with no further changes made. I'm going to leave it a while to monitor. Maybe 12.10 will fix it completely, or screw it completely. Maybe the printer's on the way out. Who knows.

September 15th, 2012, 09:43 PM
My device is now dnssd://Brother%20MFC-425CN._pdl-datastream._tcp.local/
still the same error.

What a complete bugger - was printing fine until today and cahttp://www.pclinuxos.com/forum/n't identify any changes which would have affected this.

I had that type address and like your subsequent post, my connection was intermittent. When I assigned a static IP address to the printer and used HP JetDirect protcol (Socket://i.p.address) my network printer connection has been rock solid. Brother printers seem to hew very closely to HP standards. In fact if I use the Ubuntu install for the MFC-7820N, it shows up as an HP laser printer.

September 16th, 2012, 06:45 AM
Like yours, my printer was reliable until this problem occurred.

My router assigns the same ip address to it each time of asking, and it was set up as socket://ip.address.

Hey ho!