View Full Version : [ubuntu] Java

November 2nd, 2011, 10:41 PM

I know that there was talking about Java on many forums, but i didnt find any useful things on the google.

So I am writing my post here.
I am new to ubuntu. Some time ago I wanted to install java on Ubuntu, which i have on my notebook (Oneiric Oncelot). So i went to the software center and tryied the easiest way: OpenJDK. It tells me error, that there are no files on internet and that he cant download them. Then I turned my attention on original java Environment. I downloaded .bin file and succeded on "installing" it. It extracted me some files in folder, that it created in my "Downloaded" folder, its name was something about "jre-6-...".
So i found no useful file in this folder, java wasnt working (tried in firefox..), so i typed the command in terminal: sudo apt-get install java6-jre, something like this, i found it on google. It looked like it understood me, but it said that there were no files on the web. It looks like somebody tried to disable every way to install java on ubuntu, or am i wrong.

Pls, if there is anyone, who would like to help, great thanks forward.:(

November 2nd, 2011, 10:48 PM
Hi akso3, go here (http://java.com/en/download/manual.jsp?locale=en) to get the latest java. Then here (http://sites.google.com/site/easylinuxtipsproject/java) to manually install it. There is other ways of doing it but this is what I prefer. :)

November 2nd, 2011, 10:50 PM
Hi and welcome to the forum.

Try the instructions here (http://www.webupd8.org/2011/09/how-to-install-oracle-java-7-jdk-in.html). They may help.

November 2nd, 2011, 11:00 PM
Doesn't ubuntu-restricted-extras include Java?

November 2nd, 2011, 11:11 PM
Hello again. The installation now worked well. Thanks all for help:) I dont know what really restricted extras is, but i have found on google that since oracle bought sun microsystems, java can be no longer part of ubuntu, at least for some time.