PDA

View Full Version : [ubuntu] 11.10 Session killed after resume



erny
November 2nd, 2011, 05:30 PM
Hi.

Dell XPS M1330, Ubuntu 11.10 with Unity / amd64, Intel GM 965.

Problem:

When resuming after suspend with Unity System Menu, the user session is restarted. I get the login screen.

I don't know how to debug this. I don't know what is done when the unity Suspend menu option is run.

Some ideas:

When running "pm-suspend", nearly anything works fine. After resuming, mouse may disapper, but I can get it with:
sudo rmmod psmouse; sudo modprobe psmouse

Regards.

brunoferreira
November 2nd, 2011, 07:21 PM
I have an issue like this with HP Pavillion DM13250.
After suspend or hibernate, the system back with black screen forcing me to reboot:(

erny
November 3rd, 2011, 01:10 PM
Ok, I'm trying to track this down. It seems that some applications crash after resume, especially compiz.

The first time I suspended and resumed somehow successfully:


Nov 3 12:36:37 ganso kernel: [ 163.994533] PM: Syncing filesystems ... done.
Nov 3 12:36:37 ganso kernel: [ 164.002035] PM: Preparing system for mem sleep
Nov 3 12:36:56 ganso kernel: [ 164.345526] Freezing user space processes ... (elapsed 0.01 seconds) done.
Nov 3 12:36:56 ganso kernel: [ 164.360282] Freezing remaining freezable tasks ... (elapsed 0.01 seconds) done.
Nov 3 12:36:56 ganso kernel: [ 164.376286] PM: Entering mem sleep
...
PM: Restoring platform NVS memory
...
Nov 3 12:36:56 ganso kernel: [ 167.981225] PM: Finishing wakeup.
Nov 3 12:36:56 ganso kernel: [ 167.981227] Restarting tasks ...
...
Nov 3 12:36:56 ganso kernel: [ 168.297295] show_signal_msg: 33 callbacks suppressed
Nov 3 12:36:56 ganso kernel: [ 168.297300] compiz[2372]: segfault at 10 ip 00007fea2ffe4a23 sp 00007fffd0f56340 error 4 in libgdk-3.so.0.200.0[7fea2ffa7000+77000]
Nov 3 12:36:56 ganso kernel: [ 168.305176] gnome-settings-[2360]: segfault at 10 ip 00007fcec334da23 sp 00007fff17294e60 error 4 in libgdk-3.so.0.200.0[7fcec3310000+77000]
Nov 3 12:36:56 ganso kernel: [ 168.312162] usb 3-2.3: USB disconnect, device number 5
Nov 3 12:36:56 ganso kernel: [ 168.360435] usb 2-6: USB disconnect, device number 3
Nov 3 12:36:57 ganso kernel: [ 168.601245] usb 2-6: new high speed USB device number 4 using ehci_hcd
Nov 3 12:36:57 ganso gnome-session[2290]: WARNING: Application 'gnome-settings-daemon.desktop' killed by signal
Nov 3 12:36:57 ganso gnome-session[2290]: WARNING: Application 'compiz.desktop' killed by signal
Nov 3 12:36:57 ganso gnome-session[2290]: WARNING: App 'compiz.desktop' respawning too quickly
Nov 3 12:36:57 ganso gnome-session[2290]: CRITICAL: We failed, but the fail whale is dead. Sorry....


The second time I suspended and failed to resume the session, I got:


...
Nov 3 12:37:58 ganso kernel: [ 214.807874] bamfdaemon[2516]: segfault at 10 ip 00007fde3097ea23 sp 00007fffbb30f890 error 4 in libgdk-3.so.0.200.0[7fde30941000+77000]
Nov 3 12:37:58 ganso gnome-session[2290]: Gdk-WARNING: The program 'gnome-session' received an X Window System error.#012This probably reflects a bug in the program.#012The error was 'XI_BadDevice (invalid Device parameter)'.#012 (Details: serial 248 error_code 149 request_code 141 minor_code 48)#012 (Note to programmers: normally, X errors are reported asynchronously;#012 that is, you will receive the error a while after causing it.#012 To debug your program, run it with the --sync command line#012 option to change this behavior. You can then get a meaningful#012 backtrace from your debugger if you break on the gdk_x_error() function.)#012
...
Nov 3 12:37:58 ganso kernel: [ 214.888916] compiz[3576]: segfault at 10 ip 00007f43acf66a23 sp 00007fff50bba1e0 error 4 in libgdk-3.so.0.200.0[7f43acf29000+77000]
...


So it seems that some applications crash after resume.

Edit: it seems that it's already reported, but I didn't find it before:
https://bugs.launchpad.net/ubuntu/+source/gnome-session/+bug/882956




Hi.

Dell XPS M1330, Ubuntu 11.10 with Unity / amd64, Intel GM 965.

Problem:

When resuming after suspend with Unity System Menu, the user session is restarted. I get the login screen.

I don't know how to debug this. I don't know what is done when the unity Suspend menu option is run.

Some ideas:

When running "pm-suspend", nearly anything works fine. After resuming, mouse may disapper, but I can get it with:
sudo rmmod psmouse; sudo modprobe psmouse

Regards.

Copper Bezel
December 3rd, 2011, 11:15 PM
Old thread, but I'm having the same issue, also on integrated Intel graphics. Same segfault in gnome-settings-daemon, from "libgdk-3.so.0.200.0", whatever that means. It used to be occasional X crashes and occasional Gnome Settings Daemon crashes, then it more or less went away, or seemed to, with an update, and now I'm getting Gnome Settings Daemon crashes more often than not on resume.

Copper Bezel
December 7th, 2011, 11:46 PM
Update: for whatever reason (after an update), whenever gnome-settings-daemon crashes, it reloads immediately, which adds several seconds to the (the already rather long) resume from suspend. I'm assuming, then, that this bug has had some attention? Is anyone else still experiencing this?

brejoc
January 30th, 2012, 08:36 PM
My Dell Inspiron 1525 is also showing this behaviour. Somtimes the wake up works flawlessly and the next time I get logged out. Syslog shows the same segfault messages. It's a little but frustrating, because I don't know what to do about it.