PDA

View Full Version : [ubuntu] 11.10 x64, Geetek Janus II wireless USB



zeusalmighty
November 2nd, 2011, 07:29 AM
Hey,

I recently bought a Geetek Janus II Wireless USB module for my laptop. Upon connection, the device is recognized and drivers are loaded, specifically rt2800usb. The device works BUT


I can't get any signal data for any of the networks.
My connection keeps dropping (every 2 minutes or so).


I've tried blacklisting other drivers so that I can get only that one to work but it didn't do anything.

I've searched the forum for other solutions but it seems that most of the other posts are running 11.04 or older, not 11.10 and as I understand this chipset wasn't supported in older versions.

Any ideas?

zeusalmighty
November 2nd, 2011, 09:24 PM
bump!

pdkta
November 13th, 2011, 08:33 PM
same problem here. Running wavemon shows no link quality info..

zeusalmighty
December 15th, 2011, 11:06 PM
Still no solution here!

zeusalmighty
December 19th, 2011, 09:17 PM
Another bump! No actual solution yet!

pdkta
March 14th, 2012, 01:07 PM
Solution!!!!!!! Installed compat wireless 3.2 and the no signal info problem seems to be solved!!!!