PDA

View Full Version : [SOLVED] 11.10 upgraded can't connect to backend



jim.hitch
October 31st, 2011, 03:25 PM
Hi

I have a separate front and backend and have just done a clean cinstall of 11.10 on the frontend. All the settings appear correct, but can't connect to the backend database.

I figure I've forgotten something simple since I last did this 9 months ago. Any suggestions?

this is the output if I run 'mythfrontend' in a terminal:


jim@lounge:~$ mythfrontend
QGtkStyle was unable to detect the current GTK+ theme.
2011-10-31 14:11:51.262 mythfrontend version: fixes/0.24 [v0.24.1-80-g1de0431] www.mythtv.org
2011-10-31 14:11:51.262 Using runtime prefix = /usr
2011-10-31 14:11:51.263 Using configuration directory = /home/jim/.mythtv
2011-10-31 14:11:51.264 ThreadPool:HTTP: Initial 1, Max 25, Timeout 60000
2011-10-31 14:11:52.212 Empty LocalHostName.
2011-10-31 14:11:52.212 Using localhost value of lounge
2011-10-31 14:11:52.213 Testing network connectivity to '192.168.0.215'
2011-10-31 14:11:52.357 New DB connection, total: 1
2011-10-31 14:11:57.370 Unable to connect to database!
2011-10-31 14:11:57.371 Driver error was [1/1045]:
QMYSQL: Unable to connect
Database error was:
Access denied for user 'mythtv'@'192.168.0.5' (using password: YES)

Thanks.

uteck
November 1st, 2011, 05:37 PM
The last line there makes me think the frontend is not passing the right password to the backend.
I think you can check the password on the backend by running myth-setup and see what it has. Or you have the wrong IP set for the backend?

jim.hitch
November 2nd, 2011, 10:11 AM
Hi. Thanks for getting back to me.

I've checked the password and IP address a thousand times, it's not that.

I have an X-server on the backend with an old monitor connected so I can check it easily. I have a frontend on the backend server too, so it's easy to check the password. In the settings of the backend's frontend I have copied all the settings (except the IP address, which is of course 'localhost' on that machine) and still no joy. The backend's frontend is working without any problems, so there's no issue with the database.

The backend is still happily waking itself up and recording, I haven't changed any settings on that.

I have also installed a frontend on a new laptop and I appear to be having exactly the same problem, which is what makes me think I've missed something simple.

I have set up the mediashares to the backend so I can use mythmusic and mythgallery when I can get the database connected, and that was no problem.

I have done a lot of searching, but can find anything online. I thought it might be this - Why am I getting QMYSQL3 errors? (http://www.mythtv.org/wiki/Frequently_Asked_Questions#Why_am_I_getting_QMYSQL 3_errors.3F) - but that didn't work either.

Is it a permissions issue perhaps? Should I give user 'mythtv' greater privileges on the frontends?

Please help!

Jim

jim.hitch
November 2nd, 2011, 12:41 PM
Ho Ho.

The oldest mistake in the book. Please put me against a wall and shoot me:

The DB password contains a 'l', but of course the font is sans serif. I thought it was a capital 'I', and had diligently checked that it wasn't a '1' or a 'L', but for some unknown reason didn't think of 'l'.

Well, that was about 6 hours of my life wasted.

Jim