View Full Version : [ubuntu] Lexmark X2670 drivers

October 30th, 2011, 06:48 PM
Hello all

One of my ubuntu 11.10 machines has a Lexmark X2670 but no drivers it seems. I've tried to find the drivers or use generic drivers through ubuntu's own features but had no positive results. I went to the Lexmark website and downloaded the Linux drivers but they won't install. Any ideas?


October 30th, 2011, 07:44 PM
Did you follow the directions for the Debian Based Package Manager (http://support.lexmark.com/index?locale=en&page=product&productCode=LEXMARK_X2670&segment=SUPPORT&userlocale=EN_US&frompage=null#1)?

October 30th, 2011, 08:09 PM
Did you follow the directions for the Debian Based Package Manager (http://support.lexmark.com/index?locale=en&page=product&productCode=LEXMARK_X2670&segment=SUPPORT&userlocale=EN_US&frompage=null#1)?

Yeah that's where I got the Linux drivers from. I went to earlier but when following the instructions I get a prompt for the admin/root password but it doesn't accept the valid password and won't install the driver.

I took the Ubuntu drivers. Should I try a different one?

October 30th, 2011, 08:23 PM
My lexmark had the same problem. Run the package as sudo from the terminal and it will ask for your password up front and then it will install.

October 30th, 2011, 09:02 PM
My lexmark had the same problem. Run the package as sudo from the terminal and it will ask for your password up front and then it will install.

Hey there

I tried doing:


Do not attach the printer via USB to the Linux machine.
Extract the zip file.
Run the installer script file by double-clicking on the file icon and then click the "Run in Terminal" button or run the script file via command-line.
Follow the instructions in the installer screen.

But it didn't work. So I just tried the terminal way:


Open up your favorite terminal (xterm, konsole, gnome-terminal, etc)
Extract the zip file
Use the following command to install the driver
Follow the instruction in the installation screen.

...but this didn't work either.

What is the sudo way? The file I have is named:


Is it something like sudo install lexmark-inkjet-08-driver-1.0-1.i386.deb.sh ?

October 31st, 2011, 12:44 AM
It would be

sudo lexmark-inkjet-08-driver-1.0-1.i386.deb.sh

October 31st, 2011, 01:43 PM
It would be

sudo lexmark-inkjet-08-driver-1.0-1.i386.deb.sh

Hmm ok, does the driver need to be placed into any specific location before I try the sudo way?

I'll give it a go tonight and let you know how I get on.

October 31st, 2011, 06:42 PM
It would be

sudo lexmark-inkjet-08-driver-1.0-1.i386.deb.sh

Tried that and got:

sudo: lexmark-inkjet-08-driver-1.0-1.i386.deb.sh: command not found

October 31st, 2011, 10:02 PM
Anyone know if I'm missing something here?

November 1st, 2011, 06:16 AM
You need to cd to the directory it's in. :P

November 1st, 2011, 08:01 PM
You need to cd to the directory it's in. :P

Yeah it's in my default directory. I typed "ls" and can see the driver, but I still get the command not found error.

November 2nd, 2011, 01:05 AM
It should be executable try:

sudo ./*sh

November 5th, 2011, 03:13 AM
It should be executable try:

sudo ./*sh

Ok it seemed to install the driver, but the term showed a load of errors when installing. It seemed to install fine regardless. It asked me to connect the printer via usb, which I did, and it detected the printer and everything however the installer wouldn't finish.

So I killed the installer and it seemed to be working. I attempted to print something and it went into the print queue but will not print.

I'm using the ubuntu drivers. Are there better ones? Or is there a different command to try?

November 8th, 2011, 07:20 PM
I think I'm about ready to explode D:

Are the ubuntu drivers the ones I should use or should I perhaps use a debian linux driver?

November 9th, 2011, 08:52 PM
I am having the same problems, i get a bunch of errors while installing and then I get failed to install....any help would be great so that I do not have to keep jumping to windows to print

November 9th, 2011, 08:59 PM
Real frustrated, real beginner. I am barely knowledgeable on Linux machines. I can get to terminal and that's about it.

Upgraded to Ubuntu 11.10 and now the Lexmark printer fails.

The error I get after the automatic install is "cups-insecure-filter"
I deleted it and tried installing the Debian Based Package Manager (http://support.lexmark.com/index?locale=en&page=product&productCode=LEXMARK_X2670&segment=SUPPORT&userlocale=EN_US&frompage=null#1) using the terminal AND just running it. It installs until it asks for me to "plug in the printer". I plug in the printer and the (bad?) driver automatically installs itself ALSO when I click on OK to keep running the terminal based install, nothing happens. I keep clicking and the install keeps asking for me to plug in the printer.

The printer works fine when I plug it into a Windows based system.

Real noob:confused: here so please be gentle and thorough with steps to fix this.

November 11th, 2011, 11:29 PM
I had the similar issues during installation. I'm guessing it's an 11.10 bug then with the volume of people having the same issue?

Can't seem to find any suggestions or acknowledgement of this bug though.

November 15th, 2011, 12:00 AM
It'd be great to know if someone knows if the debian, ubuntu or other driver was needed or what the differences are between them. It'd sure be a good starting point for me anyway.

November 19th, 2011, 01:06 AM
Are there any generic drivers that may work for Lexmark or anything? Just want basic printing functionality, nothing fancy.

Maybe something I can run through wine with the windows drivers or something?

December 19th, 2011, 07:40 PM
Ok, so printing on Linux seems fruitless. Even with a very common printer :/

Are there any known to work printers on Linux? Although I dislike it I may just have to buy a new printer.

January 2nd, 2012, 08:26 PM
Re-did the steps. It showed exactly what printer it was when I connected the printer. It said it was ready for printing and all sorts.. but won't get past this step:


So I ignored it and tried to print something anyway but I get these errors:


To be honest, I'd be happy just buying a new printer and scanner combo machine that works at this rate though :/