PDA

View Full Version : [ubuntu] b43 broadcom driver not able to load/find



RonnieJ
October 29th, 2011, 08:51 PM
Hey guys... I have now for 7 days tried getting this wireless card working. Its able to run with the STA drivers but since I need monitor mode I need the b43 drivers...

I have been trying to follow this guide: http://wireless.kernel.org/en/users/Drivers/b43 but without luck... im not able to install the: "firmware-b43-installer". I get this message from synaptic:

Package firmware-b43-installer has no available version, but exists in the database.
This typically means that the package was mentioned in a dependency and never uploaded, has been obsoleted or is not available with the contents of sources.list

running: lspci -vnn | grep 14e4 gives me
05:00.0 Network controller [0280]: Broadcom Corporation BCM43225 802.11b/g/n [14e4:4357] (rev 01)
and as I can read it should be supported...

I havent been able to get the b43 drivers showing in the additional drivers list... what to doooo?! Please help...

I am running ubuntu 11.04

hansdown
October 29th, 2011, 09:14 PM
Hi, RonnieJ.

Can you paste this into a terminal?


sudo apt-get update
sudo apt-get install bcmwl-kernel-source

RonnieJ
October 29th, 2011, 09:15 PM
It says its already installed

hansdown
October 29th, 2011, 09:26 PM
Before I suggest reinstalling, could you restart your computer?

RonnieJ
October 29th, 2011, 09:30 PM
Sure... I have now restarted... not sure what I should be looking for... I still cant install the package and under additional drivers only the STA is visible...

trundlenut
October 29th, 2011, 10:01 PM
you also need a package called b43-fwcutter installed as well.

RonnieJ
October 29th, 2011, 10:17 PM
I have b43-fwcutter installed...

hansdown
October 29th, 2011, 10:36 PM
Glad you fixed it, RonnieJ.

RonnieJ
October 29th, 2011, 10:37 PM
No no hehe... its not fixed... I have installed the fwcutter but that haven't changed anything... Im not sure what to do? :S

trundlenut
October 29th, 2011, 10:46 PM
It won't show up under additional drivers. What I got on my machine was that network manager said that the hardware wasn't ready as firmware is missing.

What server are you using for updates etc, it may be worth getting it to look for the best server for you.

RonnieJ
October 29th, 2011, 10:54 PM
How can I see what server it is using?

trundlenut
October 29th, 2011, 11:16 PM
How can I see what server it is using?

In the update manager go to settings and in one of the tabs it will show you what mirror you are using and offer to find the best one.

Unfortunately my Ubuntu is rather borked at the moment so I'm having to use XP and I can't remember exactly where the option is.

RonnieJ
October 29th, 2011, 11:23 PM
Hmm theres alot of links in there... but the main server seems to be (under other software)

http://dk.archive.ubuntu.com/ubuntu/

trundlenut
October 29th, 2011, 11:51 PM
right rebooted into Ubuntu. Once you click on settings, on the Ubuntu Software tab click on the drop down next to Download From and choose other then hit the "select best server" button in the top right corner and let it work its magic.

hansdown
October 30th, 2011, 12:18 AM
I've been trying to help someone in another thread.

It seems, that the B43 works in 11.04, but the STA, works best for 11.10.

RonnieJ
October 30th, 2011, 01:09 AM
I have just upgraded to 11.10 to see if that helped and now the wireless is working out of the box.. im still having some issues putting the wireless in monitor mode but im trying som things as we speak..

hansdown
October 30th, 2011, 01:51 AM
I have just upgraded to 11.10 to see if that helped and now the wireless is working out of the box.. im still having some issues putting the wireless in monitor mode but im trying som things as we speak..

Good work, RonnieJ.

I'm back up, and running, now.