PDA

View Full Version : [SOLVED] Boot Error With Dual Boot Windows 7



m47h3us
October 26th, 2011, 03:09 PM
I have a strange issues not sure if it's my motherboard with some settings it does not like but it will only boot into grub when it tries to boot cd first.

At the moment as a temporary fix I've set CDROM as first boot but it makes post a lot slower.

I have had one issue where it was not booting at all into grub but this was due to a Flexnet thing in the MBR.

System is following:
Motherboard: Gigabyte GA-Z68A-D3-B3
CPU: i5 2500K @ 4.2Ghz
RAM: 4GB
Graphics: ATI HD4870X2
OS: Windows 7 x64 & Ubutnu 11.10 x64

IF you need any more info just ask and all hope would be appreciated.

oldfred
October 26th, 2011, 04:58 PM
Tis strange.

I would check some BIOS/UEFI settings. I assume you are booting with BIOS but new motherboards also have a UEFI mode.

Some have turned off fastboot or quickboot, changed from auto to LBA, removed a boot from a device (foppy, firewire) that does not exist, Udated BIOS, changed to 3GB/s ports from 6GB/s, or AHCI mode settings. May be others with the newest systems.

m47h3us
October 26th, 2011, 06:03 PM
Ah yes I fixed it was on AHCI and now its on raid and boots fine, well Linux is but windows is not happy woops

oldfred
October 26th, 2011, 06:44 PM
RAID is not a good setting unless you really are running RAID. It also writes metadata to the drive that then interferes with standard installs.

I turned on AHCI on my system and Ubuntu still worked but my old XP stopped working - no loss. Windows 7 already has the AHCI drivers.

m47h3us
October 26th, 2011, 06:53 PM
Do you think its a problem with grub not liking AHCI

m47h3us
October 26th, 2011, 07:21 PM
OK, now I've set it back to AHCI and turned quick boot off and it works fine not sure why that is, must have been missing some checks or something.

oldfred
October 26th, 2011, 07:22 PM
Glad that worked & good to know what does work.:)