View Full Version : [ubuntu] Package system issue

October 25th, 2011, 11:52 PM
When I try to update, I get this error. I am completely lost on what to do.

imgur [dot] com/8aLUL

Frogs Hair
October 26th, 2011, 12:29 AM
The screen-shot link doesn't work . ;)

October 26th, 2011, 12:44 AM
Here you go: http://imgur.com/8aLUL

October 26th, 2011, 01:17 AM
Have you tried running apt-get install -f in a terminal window? or sudo apt-get install -f

to try to fix the broken packages?

October 26th, 2011, 01:29 AM
Yep. It gave me this:

E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

October 26th, 2011, 01:35 AM
Is Software Center running by any chance?

October 26th, 2011, 01:38 AM
I'm having similar problems as well. What I ran was sudo dpkg --configure -a
But do not do that right away, it could be wrong (I was prompted by the system to use it after a reboot)

October 26th, 2011, 01:38 AM
Yeah, make sure you don't have a package manager (Update Manager, Software Center, Synaptic) open while you are running that command in the Terminal....

October 26th, 2011, 02:10 AM
Got it to work. I ran the command Utew suggested as root and did what it needed to do.