View Full Version : [SOLVED] 10.04 won't install on a PATA drive via RAID (/target/bin "read only")

October 24th, 2011, 10:14 PM
I've used Ubuntu on my desktop since 2008. The only major change I made was upgrading (via internet) to 9.10. The PC contains 2 PATA drives connected to a new mobo by a RAID controller. The 200 GB drive contains Windows, the 20 GB contained my Ubuntu.

Today I wanted to upgrade to 10.04 by formatting the smaller 20 GB drive. I used the 10.04.3 LTS CD. Unfortunately, right after copying files started I got the error that "/target/bin is read only" (Errno 30, I think). I tried a few times, the error is in the same place always.

Now the grub is corrupted and I cannot boot into Windows, too - my desktop is useless, hopefully only temporarily.

I don't see any BIOS setting I could change. When I tell the CD to "try Ubuntu", I can see both of my drives. I mounted the smaller one without any problems. Then I tried to install again, and got a similar error. I checked /var/log/syslog and found some complaint regarding activate-dmraid , then, following some suggestions from the net, I removed the dmraid package. This time the installer managed to write a few files but ended with a similar error again. Now /var/log/syslog says "couldn't open temporary file /target/etc/apt/sed3Jq5eU: Read-only file system".

What should I do? My trusty PC doesn't work at all now and I ran out of all options I could find myself...

To reiterate, the 10.04 live CD can see the drive and write to it; the problems begin when I try to install the system.

Oh, and it's 64 bit.

October 24th, 2011, 10:53 PM

- booting from Live CD
- choosing "Try ubuntu"
- using the Disk Utility to format the drive as ext2 as opposed to ext4
- installing WITHOUT REBOOTING, specifying the partition manually

...seems to have fixed my issue! I now seem to have a functional system and grub is fixed.