View Full Version : [ubuntu] 11.10 mplayer cannot open smb mounted files

October 23rd, 2011, 02:38 PM
After upgrading from 11.04 to 11.10 i get the following error when try to play smb mounted video files using mplayer.

matt@asus-1201N:~$ mplayer smb://stora/mylibrary/MyVideos/VID-008.mkv
mplayer: Symbol `ff_codec_bmp_tags' has different size in shared object, consider re-linking
MPlayer SVN-r33713-4.6.1 (C) 2000-2011 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing smb://stora/mylibrary/MyVideos/VID-008.mkv.
params.c:OpenConfFile() - Unable to open configuration file "/home/matt/.smb/smb.conf":
No such file or directory
params.c:OpenConfFile() - Unable to open configuration file "/home/matt/.smb/smb.conf.append":
No such file or directory
Using netbios name ASUS-1201N.
Using workgroup WORKGROUP.
Could not open from LAN: 'smb://stora/mylibrary/MyVideos/VID-008.mkv'
Failed to open smb://stora/mylibrary/MyVideos/VID-008.mkv.

Exiting... (End of file)

I can open jpg's text files etc and the same video files using vlc or movie player although these players are useless to me as i have to use mplayer to use the vdpau acceleration on most of my files.

I have tried uninstalling mplayer and reinstalling - and also tried mplayer2 all to no effect.

Any suggestions ?


October 23rd, 2011, 04:42 PM
I much prefer NFS (https://help.ubuntu.com/community/SettingUpNFSHowTo) to SMB mounting with mplayer. Mplayer will copy an SMB-mounted file over to local storage before playing it but plays NFS-mounted files directly.

Another alternative is to mount the share into the filesystem with smbmount, part of the smbfs package. With that installed, you can mount the remote directory like this:

sudo smbmount //stora/mylibrary/MyVideos/ /media/MyVideos -o credentials=/root/smbcreds

where /root/smbcreds contains a username and password to mount the remote share. (Give it 0600 permissions for security.) See "man smbmount" for details.

November 1st, 2011, 12:38 AM
I have the same issue in Xubuntu 11.10. Using smbmount works, but I never had to use that before. I can live with that workaround for now, but I would prefer to be able to just browse and play it.

I think there may be an issue in the latest gvfs package, does anyone have a fix for this?

November 2nd, 2011, 04:42 AM

November 4th, 2011, 08:43 PM
Bump... no one else plays videos over a samba share, or is this just an issue for me and the OP?