View Full Version : [ubuntu] HP All in one 200 - Can't install Ubuntu

October 22nd, 2011, 02:58 AM
I am new to Ubuntu, and have a question pertaining to 11.04 and 11.10 install. I am unable to install either onto my new HP All in one 200 pc. Has anyone installed, or does anyone know of a way to install Ubuntu onto this pc? I have tried both the USB and CD install, and under both options, my screen turns black. I have checked both options on my laptop and they both work fine. The screen turns black during the loading portion when you would normally see the Ubuntu 11.04/11.10 and then the four dots underneath. I was able to install 10.10, but was not able to successfully acquire a wireless signal.

Any help would be appreciated.

October 22nd, 2011, 04:27 AM
I suggest you do a google search on

"Install Ubuntu on HP <whatever model number>"

October 22nd, 2011, 06:51 AM
Already tried that with no luck. Thanks though.

October 22nd, 2011, 09:50 PM

I'm also trying to do that.

Se that post:

That's my final findings.

Bumped, also :(

If you select the "nomodeset" in the F6 options on the boot menu, it will work, but with non-accelerated video drivers.

With the accelerated video drivers, is a no-show.

If anybody have some clue, please.


October 22nd, 2011, 09:57 PM
Try disabling APIC on startup. Some motherboards, like ASUS - suffer from firmware bugs that can be bypassed by disabling APIC.

When you boot the ubuntu CD, hit ESC to get the menu, then F6 for boot options. Check "apic=off" and "noapic" then simply run the installer from the menu.

After you install, you might be required to add them to your boot parameters, but we can cross that bridge later if that's the problem.

Best Wishes!

October 24th, 2011, 05:35 PM
That didn't work, either.

Anyway, I had already tried ALL the options from the F6 menu.

Still looking for a solution.


October 24th, 2011, 05:39 PM
Just for the record: That is not a specific Ubuntu problem. I've already tried many distros, and not a single one of them worked out correctly.

I'm already looking into upstream (freedesktop.org's Bugzilla xorg section) to see what else I can find out.


November 24th, 2011, 07:37 PM
This worked great for me, use the NOMODESET


works with 11.10 also.

February 9th, 2012, 01:59 AM
Hi, guys.

I think I found the solution.

Please, test it.
For me (I have an HP Omni 200-5320br All-in-one Series) it worked perfectly.
I describe the solution with more detail at https://bugs.freedesktop.org/show_bug.cgi?id=43171

Below is a link to debian packages, using the latest kernel tree (3.3.0-rc2):

Use it at your own risk ;)


March 1st, 2012, 07:29 PM
i think this might work for me, but i don't even know where to start with the patch

March 27th, 2012, 08:35 AM
Thanks a lot, I proved the kernel from
and it worked,
but then I choosed to compile only the single module i915 with the patch and to replace the original
module in my kernel

If someone is interested in compile only the module, when I have time I would make a tutorial.

(sorry if I have some mistakes, I'm learning English)

March 29th, 2012, 08:08 PM
Wow, this worked on my touchsmart 610 (i5 clarkdale w/ironlake graphics)

This is the first time i've been able to come up in anything but VESA mode using nomodeset. It came up in 1920x1080. Of course I have other issues now like the touch screen not working.

Any help on applying the patch from https://bugs.freedesktop.org/attachment.cgi?id=56796

I could apply it to the stock kernel, i just don't know how.

March 30th, 2012, 04:53 AM
* First you have to download the kernel source and some tools

bash:$ sudo apt-get install build-essential kernel-package
bash:$ sudo apt-get install linux-source

* then in /usr/src

bash:/usr/src$ sudo tar jxvf linux-source-X.X.X.X.tar.bz2

* now you can copy the source to your desktop, it is useful

bash:$ cp /usr/src/linux-source-3.0.0 /home/user1/Desktop

*put in a txt file , the patch from https://bugs.freedesktop.org/attachment.cgi?id=56796
*only you have to copy the next part :

diff --git a/drivers/gpu/drm/i915/intel_display.c b/drivers/gpu/drm/i915/intel_display.c index f02f86a..62bcbfd 100644 --- a/drivers/gpu/drm/i915/intel_display.c +++ b/drivers/gpu/drm/i915/intel_display.c

+ if (!intel_lvds_supported(dev)) + return false; + /* Skip init on machines we know falsely report LVDS */ if (dmi_check_system(intel_no_lvds)) return false;

*I suppose you put the patch on "patch.txt"

*now go to /home/user1/Desktop/linux-source

bash:$ cd /home/user1/Desktop/linux-source-3.0.0

*now , apply the patch
bash:/home/user1/Desktop/linux-source-3.0.0:$ patch -p1 < /home/user1/Desktop/patch.txt

*then go to cd linux-source-3.0.0/drivers/gpu/drm/i915/

bash:$ cd /home/user1/Desktop/linux-source-3.0.0/drivers/gpu/drm/i915/

*and add at the end of the file Makefile the next lines, but before
* {tab} is the space->be careful with the copy paste-> it is useful the program vi-> vi Makefile -> you can see the errors ( apt-get install vim)
* now add the next lines at the end of the file Makefile:

obj-m += i915.o

{tab}make -C /lib/modules/$(shell uname -r)/build M=$(PWD) modules

{tab}make -C /lib/modules/$(shell uname -r)/build M=$(PWD) clean

*( the next steps, you have to do them, with your system in the kernel version that you will use, use "nomodeset" to init your system if it is necessary, you can probe the "uname -r" command , you will understand the reason)

*then in /i915 execute "make clean" , and "make"
bash: /home/user1/Desktop/linux-source-3.0.0/drivers/gpu/drm/i915/ $: make clean

bash: /home/user1/Desktop/linux-source-3.0.0/drivers/gpu/drm/i915/ $: make

*now , if it is all rigth , you would have the file "i915.ko"
*that it is de new module

*finally , you have to copy i915.ko to the place where it is the original module of your kernel in use
*in my case , was the next dir : /lib/modules/3.0.0-12-generic/kernel/drivers/gpu/drm/i915$

(first do a backup)
bash:$ sudo cp /lib/modules/3.0.0-X-generic/kernel/drivers/gpu/drm/i915/i915.ko /lib/modules/3.0.0-X-generic/kernel/drivers/gpu/drm/i915/i915.ko.old

bash:$sudo cp /home/user1/Desktop/linux-source-3.0.0/drivers/gpu/drm/i915/i915.ko /lib/modules/3.0.0-X-generic/kernel/drivers/gpu/drm/i915/

*the X is the version of your kernel in use.

*restart your system

good luck

March 30th, 2012, 03:56 PM
I added these lines to the Makefile

obj-m += i915.o

make -C /lib/modules/$(shell uname -r)/build M=$(PWD) modules

make -C /lib/modules/$(shell uname -r)/build M=$(PWD) clean

When I run make clean I get:

make: Nothing to be done for `clean'.

When I run make I get:

make: Nothing to be done for `all'.

March 30th, 2012, 05:49 PM
I figured it out with the help of another forum.

I had to add tabs to the commands

obj-m += i915.o

{tab}make -C /lib/modules/$(shell uname -r)/build M=$(PWD) modules

{tab}make -C /lib/modules/$(shell uname -r)/build M=$(PWD) clean

March 30th, 2012, 07:16 PM
Sorry, you are right, I lost the "tab" with the "copy paste"

its always useful use vi

vi Makefile

it shows the errors