PDA

View Full Version : [ubuntu] password asked after upgrade to 11.10



pagheca
October 19th, 2011, 08:35 PM
Hi,

I updated to Ubuntu 11.10 today a Dell 9400 Inspiron (dual boot with Windows XP). After the installation was completed and a system restart (without any major error message), I got a screen asking for my password. If I type the right password, I can see some graphic format changes for a fraction of a second (no error messages displayed) and then the password is still requested. I can't go ahead of this. All I can get is a login screen with my username and a password request. I tried to restart again but nothing change.

Note that the password is RIGHT. I'm sure about this because if I type a wrong password the text "Invalid password, please try again" appears in red under my username. If I type the right password this text is not displayed.

thanks for any help

pagheca
October 19th, 2011, 08:40 PM
One more:

The only option I have is to try to shut down by clicking on the "switch" icon on the right upper corner, but if I try this, the system first asks to choose from restart, cancel and shut dow, then, after I type the password, the login screen appears again.

The only way to restart is to press the power button for a few seconds but after reboot the same login screen appears again.

youngunix
October 19th, 2011, 11:27 PM
at the log in screen, click the gear icon and select "Ubuntu 2D" then try to log in.

pagheca
October 19th, 2011, 11:42 PM
Thanks - I actually tried all the different options. No differences found.

bock42
October 19th, 2011, 11:51 PM
Sorry I don't have a solution, but I wanted to add that I am having the same problem.

pagheca
October 19th, 2011, 11:54 PM
you are never alone... Can you please specify your platform details?

bock42
October 20th, 2011, 12:07 AM
Ubuntu 11.10
Linux 3.0.0-12-generic
x86_64

Running on:
ASUS G53SW laptop
nVIDIA GEFORCE GTX 460
Intel core i7

alphacrucis2
October 20th, 2011, 12:20 AM
Maybe this:

http://ubuntuforums.org/showpost.php?p=11359168&postcount=11

bock42
October 20th, 2011, 12:51 AM
Maybe this:

http://ubuntuforums.org/showpost.php?p=11359168&postcount=11

I tried that, and received the following:

chown: cannot access `/home/andrew/.gvfs': Permission denied

noelc
October 20th, 2011, 01:37 AM
I have exactly the same problem. Cant get passed the user logon screen after upgrade.

Very frustrateing as I dont operate a dual boot (Only Ubuntu). I have tried everything

pagheca
October 20th, 2011, 01:26 PM
this (http://ubuntuforums.org/showpost.php?p=11359168&postcount=11) solution worked for me:

Note that I just used a few lines:

sudo chown $USER:$USER /home/$USER -R
sudo apt-get update && sudo apt-get install --reinstall dpkg
sudo apt-get install --reinstall lightdm unity-greeter
sudo service lightdm stop
sudo service lightdm start

I can't tell if they are all required.

Note that you can switch to a text terminal by pressing Alt-Ctrl-F1, and return back to the graphic login with Alt-Ctrl-F7.

There are very many other solutions online that seem to work for different users. Search "ubuntu login loop" if this doesn't work for you, and please post the solution you found for the others...

cheers

RitterSport
October 21st, 2011, 02:17 PM
I can't get past the login screen either. And, when I go to the console, I can't login. How can I try those steps if I can't get past the login screen? Is there any way to have lubuntu display the available user IDs? I know for sure what the password is, but maybe I have the user ID wrong.

Anyway, I'm on an eeepc 701 and I just upgraded to 11.10.

pagheca
October 21st, 2011, 02:55 PM
Can you tell us why you can't login? You get any error message? Any message at all?

23dornot23d
October 21st, 2011, 03:24 PM
Check Xauthority in the link at the bottom for failed upgrades there are some solutions .......

RitterSport
October 21st, 2011, 03:26 PM
Login Incorrect, when trying from the console. From the windows environment, no message.

23dornot23d
October 21st, 2011, 03:29 PM
Also the link to solution for failed password .... in my footer .... may help


also this one .... http://ubuntuforums.org/showthread.php?t=1863430

RitterSport
October 21st, 2011, 11:25 PM
The problem I'm having is that I can't log in at all, in order to try those other solutions. Until the upgrade, I never had lubuntu ask me for my user ID, so I'll admit that I'm not sure what it is. I know what the password is, though, since I enter than when doing any sudo stuff.

I'm not all that fantastic at linux, so if these are newbie questions, I apologize. I just can't figure out how to get past the login.

23dornot23d
October 21st, 2011, 11:49 PM
When it starts up with Lightdm .... the username should be shown ....

Which system are you Running Ubuntu 11.10 or something else ?

RitterSport
October 22nd, 2011, 09:03 PM
I'm running Lubuntu 11.10. I don't see any user ids when I reboot, though. I guess I'm not sure what lightdm is.

RitterSport
October 22nd, 2011, 09:05 PM
For what it's worth, when I was upgrading, it asked whether to overwrite 2 or 3 configuration files. I said OK, and maybe that's why it's asking for a user ID and password on restart.

RitterSport
October 22nd, 2011, 09:27 PM
I figured it out. I booted the eeepc off of an old ubuntu live CD (actually, a USB stick) and used that to figure out my user ID. Thanks, everyone, for the help, and sorry for the rookie mistake!

RS