View Full Version : [ubuntu] Synaptic crashes, Ubuntu 11.10

October 18th, 2011, 11:28 PM

I updated to Ubuntu 11.10 a couple of days back and ever since my synaptic package manager has stopped working.
If I try to run synaptic from the terminal, I get the following error:

manish@manish-HP-Pavilion-dv5-Notebook-PC:~$ sudo synaptic
terminate called after throwing an instance of 'std::out_of_range'
what(): vector::_M_range_check

I know that ubuntu 11.10 does not install synaptic by default but that shouldn't make my original installation to crash, right?

I also tried to reinstall synaptic by using
sudo apt-get purge synaptic
sudo apt-get install synaptic
but I still get the same error.

Please advice

October 19th, 2011, 01:43 AM
Another thread with the same problem:


Unfortunately, no solution found yet.

October 20th, 2011, 01:52 AM
This apparently is a bug that has been reported. This thread has a solution in post #10:


October 20th, 2011, 02:39 AM
The answer in the bug is this

If I toggle the screen reader on & off again (System Settings->Universal Access->Screen Reader), it stops crashing. If I enable the screenreader again, it starts crashing again.

November 8th, 2011, 03:24 PM
Toggeling screen reader on and off makes no difference om my system. Synaptic still crash every time, just flashing for a second at launch.

November 8th, 2011, 03:50 PM
I had this problem while I was trying 11.10 beta.
Then it disappeared and I feel that the bug was solved.
So if you update your system it should correct the bug.