PDA

View Full Version : [ubuntu] 11.10 > How to set up Dual Monitor with ATI Rage 128 graphic card



OfUni
October 18th, 2011, 09:55 AM
I've following

Ubuntu : 11.10

Monitor:
Acer 18.5" LCD Monitor G195HQV
AOC 931SN 18.5 inch LCD Monitor

Graphic Card :
ATI Rage 128


I want to set up Dual Monitor (split screen) on my desktop system (not laptop).

I've tried lots of things (crashing my Ubuntu 3 times already), hence finally I'm asking for help through this forum.

I've just started using Ubuntu but I can follow instructions well.

Your time will be appreciated.

Thank you

OfUni
October 18th, 2011, 10:37 AM
Found this



Wow, what a bunch of crap that was! Somehow, messing with all of this xorg.conf stuff woke up Compiz?! How in the heck THAT can happen, I have no idea. I do remember a large compiz update coming up yesterday, but I have all visual effects turned off...at all times. Compiz somehow got switched on and gave me a blank white screen...which took my friend and I an hour to fix before I could get back to this dual monitor situation.

(BTW, to fix that, I went through Gnome failsafe mode, ran
sudo apt-get remove compiz then restarted Gnome, and if you can believe this, had to go into SYNAPTIC to kill off about 6 or so Compiz related programs that somehow got turned on! コンピズのバカヤロー!)

On the dual monitor problem, I tried a couple different dual monitor tutorials (with all sorts of unnecessary added code in them) and though none of them worked for me, a friend found the following: first,
gksudo gedit /etc/X11/xorg.confand add the red text.


Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
DefaultDepth 24
SubSection "Display"
Depth 24
Virtual 2560 1024
EndSubSection
EndSection then I restarted X, went into system/preferences/screen resolution and unchecked the clone screens, pulled the monitor (white square) marked "Electronics" off to the left, selected the resolution, 1280x1024 at a refresh rate of 60hz and on the monitor to the right (another white square) marked "BenQ 19in" I selected the same resolution and refresh rate. Apply, close.

Now I have dual monitors on Ubuntu Hardy.

The dumbass thing is, I restarted X and my right monitor was dead again, and I had to go back into system/preferences/screen resolution and redo my changes. Apparently, this is another issue, and a friend has this to add, "It sounds like the unchecked box getting rechecked is a bug that involves a file in your home directory called ~/.gnome2/monitors.xml, which sometimes doesn't get overwitten properly. That's one reason deleting all the .g stuff worked. If the problem comes back, try deleting that file, resetting the stuff in that dialog, and restarting". So, with that in mind, I am off to enjoy my dual monitors.

Note: If you are just trying to get the dual monitors going, my white screen/compiz b.s. can just be ignored.

Note 2: Anyone who has trouble with finding what the Virtual numbers should be → add the widths of your 2 monitors (for me, 1280+1280=2560) to get the first number, and the 2nd number is the greater height of the 2 monitors (for me, both are the same, so the number remains 1024) hence my virtual number was 2560 1024


Still seeking help because the post have not mentioned any support for ATI Rage 128 Graphic Adapter

need help

rohanin8
November 20th, 2011, 04:21 AM
thanks alot this worked for me, all i had to do set the virtual to 3840 1080 and reboot it viola...tried to restart X without rebooting (with Ctrl+Alt+Backspace and a command line too) didnt work but manually doing it worked for me
Thanks again for great help