PDA

View Full Version : [SOLVED] 11.10 Autologin of user doesn't work



MonocleMike2
October 16th, 2011, 05:57 PM
Unity 2d
1. I have set the user to auto login in Sytem Settings/User Accounts but it does not work. It waits at the login screen for the user to press login.
How can I fix this?

2. Where do I find what used to be in Preferences to autorun a program, i.e.Firefox, on login?

------------------
I've found them.

zzztownsend
October 17th, 2011, 08:40 PM
how did you fix question 1?

98cwitr
October 17th, 2011, 11:04 PM
Try {

Gnome:
sudo /usr/lib/lightdm/lightdm-set-defaults -s gnome-shell

Unity:
sudo /usr/lib/lightdm/lightdm-set-defaults -s ubuntu

davidstoll
October 18th, 2011, 01:01 AM
I'm having the same problem.

I tried the command, but I still have to click the login button....no password required.

I'm wanting to do this so my VNC server starts for me.
Unless there is a way to have a script start before login and also my network connection (wireless) would have to also be allowed to connect without user interaction.



Try {

Gnome:
sudo /usr/lib/lightdm/lightdm-set-defaults -s gnome-shell

Unity:
sudo /usr/lib/lightdm/lightdm-set-defaults -s ubuntu

MonocleMike2
October 18th, 2011, 07:17 AM
how did you fix question 1?
Clicked top right, System Settings then User Manager and turned on "automatic login".
However I turned it off again very soon because it would not load Gnome Classic but insisted on Unity which is too slow to be usable on that machine. I've read the threads about auto logging in to Classic but they don't seem to get anywhere definitive.

MonocleMike2
October 18th, 2011, 07:24 AM
Try {

Gnome:
sudo /usr/lib/lightdm/lightdm-set-defaults -s gnome-shell

Unity:
sudo /usr/lib/lightdm/lightdm-set-defaults -s ubuntu

-----------------------
What is the syntax for Gnome Classic (No effects)? Is it -s gnome-session-fallback?