View Full Version : [ubuntu] Ubuntu 11.10 - Cannot Switch Users

October 16th, 2011, 04:16 AM
Installed Ubuntu 11.10 yesterday. Installation worked fine, however Ubuntu locks up when switching between user accounts. Password prompt appears as expected however once entered the session does not change to the new user account. Only option is to do a power off of the PC, shutdown does not work. Any thoughts on how to fix? Thanks.

October 16th, 2011, 08:44 AM
I think this might be a bug. I have the same problem as well. I cannot switch users because the password prompt locks up. For now, I guess the only alternative is to log off before changing users.

October 16th, 2011, 01:49 PM
Same problem here. i have to power off to log back in. Has anyone else sent a bug report to fix the issue?

October 16th, 2011, 04:01 PM
I confirm the problem. I have the same situation on both PCs with 11.10. I have to press Ctrl + Alt + F7 to get to my logged user and here I can restart it without power button. When I press Ctrl + Alt + F8 there is locked LightDM. Could you please someone report this bug? I haven't good English enough to do it. It happens when you have more users and try to switch to another user quickly through the upright menu.

October 16th, 2011, 05:09 PM
Same problem 64bit version. Have to log out before switching to other user.

October 17th, 2011, 02:02 AM
Me2; recent distribution upgrades have been very buggy... :=( (and unity sucks)

October 17th, 2011, 03:20 PM
I too am having this same issue... attempt to switch user, enter the password, nothing happens.

I'll file a bug report when I get home if no one else has done it by then.

October 17th, 2011, 06:53 PM
Same problem here. Don't get on with unity either, will be following the youtube instructions soon on how to get Gnome back.


October 17th, 2011, 08:44 PM
same here... is there a bug report done yet?

October 18th, 2011, 01:22 AM
Also, in reference to the previous post, the YouTube link shows how to get GNOME back using 11.04. Doesn't work with 11.10.

October 18th, 2011, 07:09 PM
Same here, can't find much info about it apart from this thread, and a bug report (https://bugs.launchpad.net/ubuntu/+source/lightdm/+bug/841351).

October 18th, 2011, 08:02 PM
An orderly shut down can be achieved by doing CTRL-ALT-F1 to get a console terminal, login, then "sudo shutdown -rf now" This will shutdown and restart with out doing a file system check.

October 18th, 2011, 09:26 PM
The link I posted earlier is a dupe of this bug report (https://bugs.launchpad.net/unity-greeter/+bug/835310), which has a solution that has worked for me: Remove the package libpam-smbpass and reboot.

October 19th, 2011, 12:21 AM
The link I posted earlier is a dupe of this bug report (https://bugs.launchpad.net/unity-greeter/+bug/835310), which has a solution that has worked for me: Remove the package libpam-smbpass and reboot.

I can confirm this method worked for me as well.

October 25th, 2011, 01:58 AM
Same problem here! Also I have to enter "startx" to get graphical environment!

November 23rd, 2011, 10:33 PM
I have the same problem, but rather than reboot, I CTRL+ALT+F1 and do

sudo service lightdm restart

I have not tried the above fix of removing the package.