View Full Version : [ubuntu] 11.10 Upgrade Deleted Partitions?

October 15th, 2011, 08:17 PM
warning: still a noob....

I was running 11.04 studio 64 bit and tried to upgrade to 11.10 last night. I started the upgrade and once it was going, I went to bed. When I woke up, I found a black screen that said:

"error: no such partition.
grub rescue>"

I tried rebooting a couple times and get this same message each time even if I try the HP System Recovery option.

Soooo, I downloaded 11.10 and created a LiveCD to make sure the OS actually works with my system. It will boot from the CD without any problems. I opened Gparted and sure enough, I have four partitions all labelled as "space not allocated." I lost my swap, windows, and linux partitions. Any files that I have that are important are saved on an external drive that has been unhooked since before I started the installation. Since I'm not too worried about lost files, I decided I'd just install the 11.10 from scratch, but on the "Installation Type" screen, I'm given no options (no clean install, or advanced option), the "new partition, add, change, delete, revert" buttons are all inactive, and no devices are listed. Just for the hell of it, I clicked "Install Now" and got the message "No root file system is defined. Please correct this from the partitioning menu." However at no point in the installer am I given a chance to configure any partitions nor can I access the partitioning menu (to m knowledge)

which leads me to my question. What the hell happened and how can I get the OS installed?

October 15th, 2011, 08:23 PM
show me the gparted screenshot

if its showing as all unallocated ...... you maybe need Testdisk ...... to check it out

Do not do anything with it yet though as data may still be ok

what may be missing is the MBR for some reason .....

What type of Disk is it and how big .... ?

October 15th, 2011, 08:44 PM
Harddrive model: ATA WDC WD10EADS-65M, (its the stock HD for my HP Pavilion Elite HPE)
Size is 931 GB

can't get the screen shot to show in the thread.

edit* can't even get it to load into photobucket. lol

honestly, I don't really care too much about recovering my partitions unless its actually necessary. I've only booted my windows partition twice since I first got 11.04 and like I said in the OP, I didn't have anything on the hard drive that wasn't already backed up. I would think that installing everything from scratch would be the easiest thing to do. Obviously, I could be wrong.

October 15th, 2011, 09:34 PM
I burned a second 64bit install disk with the same result as the first. so instead, I downloaded the 32bit install disk and tried to install from there with the exact same result. It doesn't give me an opportunity to select how I want to install and still doesn't have a root file. I (think) I double clicked inside the empty device list and got a "starting up the partitioner" dialogue, but it freezes there and I have to restart the system. is the partitioner something that should have been on my hard drive or should it be accessible from the LiveCD?

October 15th, 2011, 11:58 PM
quite frustrated at this point. I've tried multiple versions of linux along with old releases and everything I can think of. From what I can see, I (obviously) can't install linux without a root file system, but have no way of creating a root file system because I can't logon as root with a Live CD (if I can , please enlighten me).

is it possible to just copy the root file system used on the live cd to my hard drive?

if I had a computer with no OS or any kind of file system, how would I install ubuntu? I'm skeptical that there is not a way to do this from a live cd, but all my searching online has given me no results.

October 16th, 2011, 02:34 AM
I don't know what exactly went wrong, but whatever you do, do it with your backup drive physically disconnected from the computer. You can connect it back after you have a working system; you don't need it to get to this state.

You say that you can boot from the live CD into a working system. Open Disk Utility and use it do delete everything on your hard drive. When you select your drive on the left hand panel, on the right there will be a 'drive' section and a 'volumes' section. Press the 'format drive' button in the 'drive' section and choose "master boot record" as the scheme.

Reboot the system from the live CD again and run the installer. See if that helped.

October 16th, 2011, 02:54 AM
I would hate to jinx it, but so far its installing perfectly. thank you thank you thank you. I'm pretty mad at myself for not formatting the drive properly. I was literally thinking about swapping the drives in my int. and ext. just to ease the frustration. lol.

I'm still curious as to how this happened, but as long as I can use my computer, I'll be happy.

October 16th, 2011, 03:04 AM
working perfect. Thanks.

October 16th, 2011, 03:14 AM
Glad to help.
Do you think you could change the title of this thread to something like "Installer doesn't see hard drive" and mark is as solved?