PDA

View Full Version : [ubuntu] TrueCrypt Fails to Create Encripted Volume in Ubuntu 11.10



IntoFlow
October 15th, 2011, 07:32 PM
I've tried TrueCrypt 7.0a as well as 7.1. This problem occurs in Ubuntu 11.10.

When the volume size I want to create is around 10GB or above, after TC finishes encrypting, everything freezes and stays frozen. Nothing happens and I have to force shut down the computer. (I left it overnight once and it stayed frozen for hours - then I just shut it down.)

This issue did not occur in Ubuntu 11.04.

It's frustrating because I can't create a secure environment on my PC where I can store the files I want, and I need much more than 10GB.

When I want to encrypt around 300 MB, then it works...

Can anyone re-create this, or is this issue known about?

Thanks.

Rob_H
November 6th, 2011, 08:09 PM
I started having the same problem since upgrading to 11.10. I fixed it by going to Settings -> Preferences -> System integration and then put a checkbox next to "Do not use kernel cryptographic services". I was also getting intermittent lock-ups when accessing encrypted volumes so I'm hoping this fixes that problem, too, but I haven't been testing long enough to say for sure. At least volume creation works now.

c.cobb
November 7th, 2011, 09:54 PM
. . .put a checkbox next to "Do not use kernel cryptographic services".

Do you have the dmsetup package (http://packages.ubuntu.com/search?keywords=dmsetup) installed? If not, give that a try.

Rob_H
November 7th, 2011, 10:14 PM
Do you have the dmsetup package (http://packages.ubuntu.com/search?keywords=dmsetup) installed? If not, give that a try.

Yeah, it is installed. Makes no difference I guess.

c.cobb
November 8th, 2011, 12:26 AM
It used to make a difference. Maybe a defect came with with the upgrade, or something else has changed?

Dunno much about device mapper, but in a wrapper script I wrote for TC, when the dmsetup command was not found, had to add the 'nokernelcrypto' mount option or the script wouldn't work.

fufyr4ik
December 21st, 2011, 10:46 AM
I confirm the problem with Ubuntu 11.10. Hope, they'll fix it soon!

tubbygweilo
December 21st, 2011, 07:41 PM
Has any of the posters who came across this problem described it to LaunchPad (https://bugs.launchpad.net/ubuntu?field.searchtext=+truecrypt&orderby=-datecreated&search=Search&field.status%3Alist=NEW&field.status%3Alist=INCOMPLETE_WITH_RESPONSE&field.status%3Alist=INCOMPLETE_WITHOUT_RESPONSE&field.status%3Alist=CONFIRMED&field.status%3Alist=TRIAGED&field.status%3Alist=INPROGRESS&field.status%3Alist=FIXCOMMITTED&field.assignee=&field.bug_reporter=&field.omit_dupes=on&field.has_patch=&field.has_no_package=)?

replicant.nz
January 12th, 2012, 03:11 AM
I started having the same problem since upgrading to 11.10. I fixed it by going to Settings -> Preferences -> System integration and then put a checkbox next to "Do not use kernel cryptographic services". I was also getting intermittent lock-ups when accessing encrypted volumes so I'm hoping this fixes that problem, too, but I haven't been testing long enough to say for sure. At least volume creation works now.

Where do I find "Do not use kernel cryptographic services" with unity?

Rob_H
January 12th, 2012, 04:48 AM
Where do I find "Do not use kernel cryptographic services" with unity?

It's not in Unity. It's in the TrueCrypt GUI.

sh4d0w808
January 12th, 2012, 02:02 PM
Do you want to use fulldisk encryption?