View Full Version : [xubuntu] Compiz, annoying flicker when switching workspace

October 15th, 2011, 12:22 PM
Hi all,

Im running a fresh install of Xubuntu 11.10.

I have compiz installed and also im using emerald as the window decorator.

Card is a GTX570, on an I5 so it certainly isnt a hardware issue. I have the proprietary binary nvidia-current drivers from apt.

When ever i switch workspace with ctrl alt left or right there is a flicker moving to the new workspace, before it is re-drawn. That flicker is whatever was open on the previous workspace, and is very noticable.

Ok, its a minor gripe but annoying!

Ive done some googling and found this, but im not sure if its arch specific:


options nvidia NVreg_RegistryDwords="PerfLevelSrc=0x2222"

to /etc/modprobe.d/nvidia.conf

Ive noticed there is an /etc/modprobe.d/nvidia-graphics-drivers.conf with some blacklisted modules in, would it work to add the above to that?

Any help would be greatly appreciated.

October 15th, 2011, 02:12 PM

Ive narrowed it down to the cube desktop, enabling this gives the flicker. Disabling it and just using workspace switcher and all is well.

Ive have tried adding ppa:ubuntu-x-swat/x-updates and doing an apt update and upgrade to get onto 285.05 drivers but no luck.

It would be nice to get the cube back, if anyone has any suggestions?

Thanks again.

October 17th, 2011, 03:55 AM
I'm hoping there's a simple workaround for this too

October 17th, 2011, 04:26 AM
Happens here, as well as the rotate with window not working(ctrl+alt+shift+Right).
Window moves but then disappears back to previous workspace.

October 17th, 2011, 05:48 AM
Just before this started happening with rotate/cube there was an issue with flashing in the workspace switcher - same effect.
Have a bug on that here - with the compiz in 11.10 proposed it appears to be fixed, at least if using wall
(if you switch from rotate/cube to wall one may get flashing still, if so that can be fixed, ask


The issues with rotate/cube were mentioned in that bug, but have decided to open a new one specific to cube here -

It could use confirming & comments about which video card affected users have (and if on open source drivers or proprietary

October 18th, 2011, 03:25 PM

I confirm on Xubuntu Oneiric 64 bit with the latest nVidia drivers
Rotating the cube makes the screen flicker, looks like a split second image of the previous desktop.
Only happens on the active monitor

December 24th, 2011, 12:09 AM
I'm having the exact same problem (posted a video here (http://www.youtube.com/watch?v=vKWLavhaOuw)). I'm also looking for a workaround.

December 24th, 2011, 05:03 AM
I'm having the same problem. For some reason there is no good drivers to support nVidia cards. The other problem is that my fan won't stop on the graphics card...

January 10th, 2012, 05:07 AM
I don't think it's related to Nvidia drivers as I'm using Intel HD2000 graphics on my Pentium G620 and the Issue is still there.

January 11th, 2012, 09:34 AM
I Have a dell 6420 with NVS4200, after setting up the cube i have two problems:

1. the cube is 2d - meaning my desktop flips like a flat surface and switches between only 2 desktops.
2. when the fliping action is completed i get a flicker like you described.

is this indeed a driver issue related to activating the cube on nvidia?

January 12th, 2012, 04:35 PM
Open ccsm, go to General, "Desktop Size" tab and make sure you have a virtual horisontal size of 4. The other two can stay at 1 each.
That's what I've done, and it works. Hooray!

EDIT: Sorry, this was for the twopanel problem that elimitrani had.

January 13th, 2012, 11:24 AM
I don't think this fixes the bug, at least in my case.

February 18th, 2012, 02:54 PM
I fixed it by downgrading to 0.9.4 from natty - instructions are available here: http://sodnpoo.com/posts.xml/oneiric_compiz_downgrade.xml

February 18th, 2012, 04:49 PM
Thanks, good to know. The problem is I'm refusing to downgrade. I'm a bitch that way :-D

February 24th, 2012, 01:50 PM
Same here. Intel HD graphics. Still no fix?

Flicker when switching Workspace via Cubes.

Version Dependency
February 24th, 2012, 06:48 PM
Still no fix?

Despite the cries for fixing this bug (https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/876198), it is still unassigned. Apparently, the folks working on Compiz for Canonical aren't interested (or able) to work on it...after all, Unity doesn't even use the cube. And judging by the activity on Compiz's website, there is a serious lack of developers for the project. And their forum looks like it nothing more than a haven for spammers now.

Recently distros such as Fedora, OpenSUSE, and Gentoo dropped Compiz. Might be time to just put Compiz out of its misery. If it's not dead, it's on life support.

February 26th, 2012, 03:59 AM
I'm using the cube in Unity, and I have a similar issue, although it's not the previous desktop that flickers but the incoming one. It appears that for about 1/4 of a second the desktop is slightly undersized when it rotates into place. It pauses for about that amount of time and then it jumps to the full screen.

I notice it, but it's not a big enough deal for me to get worked up over. It kind of enhances the drama of switching.

September 5th, 2012, 05:03 PM
Found a solution that works for me.

Installing proposed updates, then locking the versions to make the fix permanent.

sudo apt-get install synaptic

sudo apt-add-repository ppa:vanvugt/compiz-preproposed

sudo apt-get update

sudo apt-get install compiz=1: compiz-core=1: compiz-gnome=1: compiz-plugins=1: compiz-plugins=1: compiz-plugins-default=1: libdecoration0=1:

(it will downgrade packages, allow it to continue)

Start synaptic

in "Search filter": put "compiz"

select every package that has a (!) next to it.

Select Package -> lock version

(they become red)

exit synaptic

Reboot or Restart X/Compiz.

September 28th, 2012, 01:24 AM
That fixes it for me too.
Thank you cbanakis!

October 26th, 2012, 08:35 AM
Thanks cbanakis (http://ubuntuforums.org/member.php?u=824651) !

Problem solved

February 14th, 2013, 12:58 AM
Thanks cbanakis! Flicker Eliminated.