PDA

View Full Version : [ubuntu] 11.10 Network Manager won't connect to secured wireless networks



abi278
October 14th, 2011, 10:57 PM
As it says in the subject line, really. :-/

I've just upgraded and I can't get onto secured wireless networks. On 11.04 I had no problems, but on 11.10 the Network Manager keeps asking for the password, trying to connect and timing out.

Wired works. Unsecured wireless networks work. It's just not coping with WPA.

Any ideas?

lspci output tells me that my wireless card is:

03:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)

abi278
October 15th, 2011, 01:11 PM
A workaround for anyone else with the same problem is to remove and purge all packages with network-manager in the name, and use wicd instead.

I might reinstall NM later to see if a clean install works, but not right now, too busy enjoying the working wifi. ;)

Jusii
October 15th, 2011, 04:54 PM
Same here. My workaround for time being was to downgrade network-manager to version from 11.04

Add main repo from natty and do:

apt-get install network-manager/natty network-manager-gnome/natty

Dago619
October 15th, 2011, 05:43 PM
I found that when I went to my network connections I was able to store my WEP password.

From the apps launcher goto Network Connections >> Wireless Tab >> Choose your network from the list and click edit.

From here goto the Wireless Security tab and choose the type of security, enter your key, and check the box at the bottom making it available to all users.

I'm not sure how this will effect your security settings on your machine, but for me, it works!

Jusii
October 16th, 2011, 08:10 AM
Will try that.

Forgot to mention that it also works if you choose Connect to hidden wireless network from network manager applet and enter the details. But you have to do that every time.

But with the above atleast for me the network feels laggy.

Torben.V.Olsen
October 17th, 2011, 05:47 PM
This worked for me:

sudo apt-get remove bcmwl-kernel-source

Wireless now working.

Arles
November 11th, 2011, 09:20 PM
A workaround for anyone else with the same problem is to remove and purge all packages with network-manager in the name, and use wicd instead.

I might reinstall NM later to see if a clean install works, but not right now, too busy enjoying the working wifi. ;)

Tried this but I'm just getting BAD Password error while authenticating. Any ideas how to solve the problem?

Yes I have the right pass phrase

elvisd
November 11th, 2011, 11:09 PM
Hi have the same problem. Network manager isn't storing WPA passwords/keys.
If i enter the key is accepted but not stored. on next boot will be asked again.

Hope someone find a solution

NixNub
November 13th, 2011, 07:15 AM
Hi have the same problem. Network manager isn't storing WPA passwords/keys.
If i enter the key is accepted but not stored. on next boot will be asked again.

Hope someone find a solution

Same here having the same problem with storing the network key. Until then it's data entry :D