PDA

View Full Version : [ubuntu] How to add user to auto group



Stanley2011
October 11th, 2011, 05:15 PM
Hi, need help adding myself to auto group. I am using Ubuntu 11.04 this time. 5th day out on build. Having no luck getting the system up and running with QJACK.CTL. I have follow all the instructions on here "https://help.ubuntu.com/community/UbuntuStudioPreparation" except for this code
sudo apt-get install ardour audacious hydrogen jackd jack-rack qjackctl seq24 vkeybd zynaddsubfx patchage vlc kino pitivi acidrip ubuntu-restricted-extras ubuntustudio-menu gcdmaster
http://www.youtube.com/watch?v=fMz6fDGBnA4
So I tought save Qjack for last to see if that would get it up and running????? Help please??????
In have spent to much time tring to get it up and running. Need to start recording.

Lisiano
October 11th, 2011, 05:19 PM
What is the question exactly? If you want to add a user to a group use

sudo adduser $USER auto
This will add the user you are currently using to the group "auto"

Stanley2011
October 11th, 2011, 05:46 PM
Configuring the real-time access for "audio" group users and applications

https://help.ubuntu.com/moin_static192/ubuntunew/img/alert.png Before adding a user to the audio group, please read about the implications of doing so (https://wiki.ubuntu.com/Audio/TheAudioGroup).
Since Ubuntu 10.04 the permissions to enable real time access for "audio" group users are set in the file /etc/security/limits.d/audio.conf. In versions prior to 10.04 these settings were done in /etc/security/limits.conf
If for some reason you need to tweak something, look for these lines:
# generated by jackd's postinst. <<BR>> # Do not edit this file by hand, use <<BR>> # dpkg-reconfigure -p high jack <<BR>> # instead <<BR>> @audio - rtprio 99 <<BR>> @audio - memlock unlimited <<BR>> #@audio - nice -19 <<BR>>These value are suggested by http://jackaudio.org/faq. The memlock line determines how much of your memory can be locked by audio processes. Some recommend setting this as half of your total memory (RAM, in KB). The nice setting has been commented out with a purpose, according to one of the main authors of JACK allowing users to renice processes is not necessary (http://wiki.linuxmusicians.com/doku.php?id=system_configuration#limits.conf). Thanks to Scott Lavender for precision about the new file configuration.
Don't forget to add your username to the "audio" group (System - Administration - Users and Groups).

Now it ask me to do this and It want let. the command you gave did not work. Said it could not be find.

Lisiano
October 11th, 2011, 05:54 PM
You confused me with the thread title "How to add user to auto group".
Use this instead to add yourself to the audio group

sudo adduser $USER audio

Stanley2011
October 11th, 2011, 06:03 PM
I'm sorry for that new here. Ok it add me but not to limits.conf