View Full Version : [ubuntu] A2DP Bluetooth Connection: iPhone4 to Ubuntu 11.04

October 10th, 2011, 11:11 PM
Hello all,
I have taken on the project of connecting my iPhone4 to my Ubuntu 11.04 machine through a Bluetooth A2DP connection (to stream music from my phone to the computer).

Has anyone accomplished this? I have my details below:

I have a Rocketfish Bluetooth adapter; I was using this adapter for the task above on a previous windows machine (I will accept abuse for this :D). The adapter supports A2DP.

I also feel as though I have exhausted many options: I have read into this forum with detail for instance:
which requires BlueZ and PulseAudio, I tried to install BlueZ, my terminal says I already have it; I fail to find it.

I have tried to install the driver for the adapter through Wine: failed, and of course tried the Bluetooth manager that came with the OS.

I have even installed VirtualBox and tried to install the driver through Windows7 through the virtual machine.

I have not however prayed to the Connectivity Gods and offered sacrifice of an innocent wireless router.

Any response would be greatly appreciated!

October 11th, 2011, 02:18 PM
Some further research suggests the adapter used can be an issue.
There are adapters better for linux than others. I am going to purchase another adapter that explicitly details itself as linux capable. I will post back with results on this.

November 16th, 2011, 03:54 PM
Update: Sorry for the long delay: I had some major issues updating to 11.10; and for a couple days I sat in my corner and cried... I'd rather not go into it but I'm back to 11.04.

I purchased a Cirago bluetooth adapter (BA). It doesn't seem to make a difference on what BA is used. I can only use the adapter through the Bluetooth software that comes with Ubuntu 11.04. I can get about halfway through installing the driver for the Cirago BA through wine, and the wizard crashes.

I can get the BA to discover my iphone4 through the original bluetooth software, and get a connect confirmation on the computer side, but the phone will not say connect. Under some cases the phone may "connect" if I use to phone to press on the target name; but still no option to stream through A2DP.

My only other thought is to try a different smart phone.