View Full Version : [ubuntu] dual booting

October 3rd, 2011, 10:12 PM
I was dual booting my Acer netbook XP & Ubuntu 11.04 for 5-7 months when it all went wrong.

Luckily on the last reboot I noticed a linux menu with 4-5 option, & one was "Acer eRecovery Management" which did the XP installation all on its own giving the option to save & install all files & programs.

Then, I went & installed Ubuntu 11.04 from my USB stick but, now on boot-up it does not give the XP boot.ini Menu I had before but, the "GNU GRUB" menu with 11 choices for Ubuntu (default) or XP, which is very complicated.

The rub now is how do I change the default to XP?

Any easy way?

October 3rd, 2011, 11:15 PM
If you have that many choices you may just want to house clean out some of the older kernels. Best to keep one older & of course the current one.

HOWTO: Grub Customizer
The Grub 2 Guide (formerly Grub 2 Basics) manual way

Check current kernel:
lsb_release -a
Go to Synaptic Package Manager and search for linux-image.
More info in post #8

October 4th, 2011, 08:49 PM

by These:-
You can change the default menu
entry to boot by either going to the

/boot/grub/grub.cfg file and near the top of the file changing the entry: set

default="0" to another number. Count the menuentry lines until you get to xp.

Put that number in the set default. Grub counts in this case from zero, so if

your xp is the 5tn entry, put a 4 there.

To keep grub with default boot set to XP, you may use the GRUB_DEFAULT option
on /etc/default/grub (as already said by yancek) or change the
/etc/grub.d/30_os-prober file order.

Then :-
sudo gedit /etc/default/grub ...This brings up grub in editor & change to what ever No. you require.

sudo update-grub ..........this in a new terminal updates Grub.

Mark Phelps
October 4th, 2011, 09:17 PM
Just so you know, when you ran "sudo update-grub" you OVERWROTE any changes you manually made in grub.cfg file -- which is why it is, except for limited testing, a BAD idea to edit that file.

If you notice when you open it, there is even text in the file telling you NOT to edit it.