View Full Version : [SOLVED] After configuring Compiz, the desktop environment disappeared!

October 1st, 2011, 12:20 PM
Dear fellows,

Today I was trying to enable the desktop 3D cube and I followed the instructions to do so in the Compiz Config.

After enabling them, I was prompted to disable the Desktop Wall and so I did.

Starting from that, only the Firefox browsing kept working, nothing else. Neither the app menu or anything else, all was completely locked.
I rebooted and logged in normally, at the "Ubuntu" option at the GUI login screen (as I always do). OS loads normally and, for instance, mail notifiers work at once. However, there's no top bar, neither unity bar on the left, no shortcut works (unless Ctrl+Alt+Del), only the desktop's wallpaper and its icons appear.

Rebooted and logged in safe mode, so I could disable the options that went wrong. So I did, and enabled Unity and Desktop Wall again, just as it was before.
Logged out and then logged in as "Ubuntu" again and still the same problem....

The only way I managed of "getting things normal" so far was logging as User Defined Session, but I confess my noobness and don't know what it is. How can I restore my "Ubuntu" normal session as it was before I messed up?

Thank you a lot in advance for helping me :)

October 1st, 2011, 12:22 PM
I have a similar issue. I ahve not been able to use the desktop since my upgrades installed.

October 1st, 2011, 12:23 PM
Tried to login as "User Defined Session" or as "Ubuntu (Safe Mode)"?

October 1st, 2011, 05:15 PM
Please see this troubleshooting guide:

It includes this guide to enable the Cube:

And, as also referred to in the first guide, there are two profiles in CompizConfig Settings Manager, in "Preferences" (lower left):
- classic Gnome: "Default"
- Unity: "Unity"


October 1st, 2011, 05:47 PM
I didn't care about the cube anymore, I just wanted my default Unity settings back!
So I followed your instructions on "Enable Ubuntu Unity Plugin", restarted GMD and everything was as it should be, except for the window title bars.
Just had to follow your tutorial under "Window Title Bars Missing".
And it's solved now, I can't tell you how much your help is appreciated. Thank you very much!!