PDA

View Full Version : How to: Broadcom Wireless cards



Pages : [1] 2 3 4

nickm
May 31st, 2006, 01:38 PM
****In my edgy knot 2 testing I found that edgy users can stop the guide after competing stage 4 or 4b as it 'just works' with out network-manager if you fill in the SSID and set the wireless device to DHCP in the "networking" option under System > Administration****


This Should work with Apple hardware as well as PC's.

How to get a wireless card working in Ubuntu 6.06 or 6.10) with a Broadcom chipset 43xx


This guide assumes 2 things:

Wired Internet access on the machine with the wireless card on it, in my case i had a 10/100 LAN card that i was using as i couldn't get wireless to work which gave me full access to internet - although it is possible to put the files required on a CD and then add that CD as a repo in synaptic on the wireless machine, how to do this is not covered here, you could even extract the firmware on a different PC and place it in the right location on a remote PC using a CD/Pen drive taking a .deb of network manager with you.
A CLEAN install of dapper or edgy, most of the problems/failures in the responses to this guide have been because of unclean installs giving configuration that gets in the way of this guide and stops it from working, my dapper was installed during the Flight 5 stage and updated from there to knot 2 so its not necessary to reinstall from 6.0* or even if it has been updated from breezy but you might want to think about reinstalling if you've messed around with Ndis prior to this.


Okay so you have a wireless card that shows up in ubuntu but doesnt connect to any wireless network?

The reason the card shows up but doesn't work is because ubuntu is only distributed with its driver (so it can recognize it) not with its firmware (so it can USE it) for legal reasons.

However you can take the firmware out of the windows drivers and put them into ubuntu and make the card work!

Follow these steps to get your wireless card working under ubuntu dapper 6.06:

To find out if your card has a broadcom chipset run the following command:


lspci | grep Broadcom\ Corporation
If that returns a string of numbers followed by the words Broadcom Corporation and then some more numbers then your in luck!
But if not, try my guide anyway, it cant do any harm and it might work for you, its largely untested for cards other than mine and the success stories posted here so give it a go and see!

Here is my output from doing this:


lspci | grep Broadcom\ Corporation
0000:02:0d.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 03)


It seems that if you get the following string back: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02) that this guide is VERY unlikly to work for you although it does sometimes, dont ask me why, but basically every "no" vote and "this didnt work for me" post comes from a BCM4318 user....

Prerequisite

Ubuntu dapper
A wireless card that shows up in Ubuntu
A driver installation CD (for Windows) OR a driver for your card from the internet
Access to the Ubuntu Universe Repository


1 ) Ensure you have access to the other ubuntu repos
follow the intructions on the second heading from this page to ensure you have the universe enabled
https://wiki.ubuntu.com/MOTU/Packages?action=show&redirect=UniversePackages

2 ) Copy your windows driver to your desktop

Use this driver with preference to any other:
http://boredklink.googlepages.com/wl_apsta.o
if this fails, your could use any of these:

Copy the driver from the CD that came with the Card
Copy it over from your windows partition if you have access to it, it will be located here: /Windows/System32/Drivers/bcmwl5.sys
Obtain it from here -http://sidulus.textdrive.com/bcmwl5sys.zip
Get any driver for your card of any date from their website - use this if initially you are not successful first tome try some newer/older drivers


3 ) Install bcm43xx-fwcutter
Open a terminal (dont worry) and type the following:


sudo apt-get install bcm43xx-fwcutter
It will ask for your password and may ask you to press y to install, but dont worry its really easy

GUI Alternative: go to System in the top Gnome bar then Administration then Synaptic Package Manager
From here click Search and search for bcm43xx-fwcutter

http://boredklink.googlepages.com/synapticsrearch.png
Right click on its entry in the package window, select Mark for Installation and then click apply

http://boredklink.googlepages.com/synapticselect.png

4 ) Extract your Cards firmware from the driver
Open a terminal (dont worry) and type the following:


sudo bcm43xx-fwcutter -w /lib/firmware ~/Desktop/wl_apsta.o
This will create lots of new files in the /lib/firmware directory, this is the firmware part of the driver that will make your card work with ubuntu!

http://boredklink.googlepages.com/libfirmware.png

4B ) Extract your Cards firmware from the driver
Just to be safe we'll put the driver in the kernel folder too




sudo bcm43xx-fwcutter -w /lib/firmware/`uname -r` ~/Desktop/wl_apsta.o



you may have to repeat this step each time the kernel is updated or you may not, your results may vary.

Note The location and name of the .o file for this command may differ in your case, if you really get stuck type bcm43xx-fwcutter and then hit space, find your file using the GUI and then drag and drop it into the terminal.

5 ) Install Network Manager
I find that this is the best way to manage wireless connections


sudo apt-get install network-manager-gnome
It may ask for your password and may ask you to press y to install, but dont worry its really easy

You may find that Network Manager adds itself to system > preferences > sessions >startup programs
or you may not, if you find its not inlcuded, add


nm-applet --sm-disable

as found here: http://ubuntuforums.org/showpost.php?p=1082980&postcount=32 , Network Manager might not work for Apple users, he says that a program called wifi-radar worked for him instead so if network manager is no good for you try this program instead
This might apply for non apple users as well
https://wiki.ubuntu.com/WifiDocs/Driver/bcm43xx#head-cf3f0ec9146ae9441b39c4bed74e5d044ef78d2f

6 ) Bookmark this page and Reboot
Press Ctrl + D and then click on add

http://boredklink.googlepages.com/bookmark.png
Then log out & reboot
Return to this page after logging back in again


7 ) Use your new Wireless connection
From what i remember network manager should now show up by your clock and display your current connection, if your lucky it will show a series of bars, this means your now using your wireless connection so lucky you!

http://boredklink.googlepages.com/nm.png
If it doesnt, right click on it and tick "Enable Wireless" then left click on it
and select the wirless network of your choice.

Thanks, i hope this helps...


Issues:
----------------------------------------------------
Ensure the router you are connecting to supports 802.11 B connections
as this is what the card is now set up to use, check if your router has a "mixed"
setting rather than a G only setting which it should as G is backwards compatible with B
----------------------------------------------------
For anyone that is having problems, try this:


modprobe bcm43xx
and reboot
----------------------------------------------------
Information about networkmanager

https://wiki.ubuntu.com/NetworkManager
----------------------------------------------------
people seem to be having trouble getting this specific card: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02) working using this guide, take a look at this post for help:
http://ubuntuforums.org/showpost.php?p=1084114&postcount=43
or
http://ubuntuforums.org/showpost.php?p=1105667&postcount=218 if your looking to Ndis instead
----------------------------------------------------
If you find your driver comes in a windows EXE format, typically this will just extract the drivers and can be run using Wine and then collected from your wine directory in the same places you can find them in windows
you could try renaming them to filename.zip and seeing if they open that way too.

markmcspadden
May 31st, 2006, 06:08 PM
A little adjustment...

The command "bcm43xx-fwcutter /home/$USER/Desktop/bcmwl5.sys" creates the firmware files in the directory you are current in...it cannot be assumed that is the "Desktop".

I couldn't figure out why it wasn't creating the files, then I stumbled across them in my "~" directory (where I ran the command). Not a huge thing, but I wouldn't consider myself too much of a linux newbie and it got me.

Other than that...great work...I have wireless without the pain of the ndiswrapper manual install!!! Thanks a ton!

nickm
May 31st, 2006, 06:28 PM
Hey, thanks, im glad i helped someone :)
out of interest what card is it?

I did put a little note about that in step 3 when i made it, i'v made it a little more prominent for other people

spd106
May 31st, 2006, 09:36 PM
Nice howto nickm, it deserves to be a sticky in my opinion.

Could you add a way for users to check what kind of cards are likely to work ie


$lspci
0000:02:00.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 03)

Cheers

nickm
May 31st, 2006, 10:07 PM
thanks spd106, i'll make an ammendment now :)

I decided people should be able to digg it too:
http://digg.com/linux_unix/Get_your_wireless_card_working_in_Ubuntu
that way people can find it right away untill google adds it

nickm
June 1st, 2006, 11:07 AM
Nice howto nickm, it deserves to be a sticky in my opinion.

Cheers

well, if any mods want to do it, i promise to maintain it.... ;)

imrumpf
June 1st, 2006, 05:37 PM
ian@ian-laptop:~/Desktop/SP32158A$ bcm43xx-fwcutter bcmwl5.sys
Sorry, the input file is either wrong or not supported by fwcutter.
I can't find the MD5sum 69f940672be0ecee5bd1e905706ba8ce :(

what is that supposed to mean?? :S:S

nickm
June 1st, 2006, 06:20 PM
that means that the specific file you have isnt supported by fwcutter, it checks the firmware md5sum against a list of what it knows works and yours hasnt come up

see for yourself

nickm@ubuntu:~$ bcm43xx-fwcutter -l | grep 69f9 (yours)
nickm@ubuntu:~$ bcm43xx-fwcutter -l | grep c3e (one i know works)
wl_sta.o 3.31.16.0 a/b/g c3e663cb78b2fc299088de69fc11a9a9


all i can suggest is that you look for a newer/older driver on the internet for your card and try it agian with that...

Vaan
June 1st, 2006, 07:43 PM
Thank you!

Wow, thank you soo much. This was an excellent guide. I cannot express my gratitude enough for taking the time to make such a wonderful guide.

I spent most of my day yesterday trying to setup my wireless on my laptop following the guides on the wiki. After messing around for quite some time, I finally got it to work. However, it wasn't even working all that great (I had to constantly config the wireless each time I rebooted via terminal).

Then unfortunetly I had to reinstall my unbuntu (Dapper Drake btw) becuase of some problems I had trying to install KDE. Any how, I told myself I would reread over the wiki again today.

To my unfortunate surprise, when I went to go look in the wiki today (search broadcom) all the guides that were there yesterday now redirect to a new guide that is terrible. I almost lost it. It was there one day, and gone the next (literally).

I didn't know what to do. So I tryed my luck to search on the forums, and up came this thread, my life saver.

Not only was this explanation much faster than anything else I've read, but it actually works completely for me. I love the new network manager that I didn't even know existed. Thank you for telling us about it, works much better than the default. I can just click and switch wireless connections easily.

In my opinion, not only should this thread be made a sticky, but someone should add it to the unbuntu wiki. This will help many people and spread the word out on how to once and for all get these cards to work.

Thanks again, really appreciate it. :)

Also I noticed this thread is under the Breezy section. I'm actually using the latest version of Dapper Drake (6.06 I believe) and I notice most users are having broadcom problems with Dapper. If it could be moved somewhere to a more general place, that would be very helpful for future users I'm sure.

Update

Also I didn't have my driver CD at hand during this whole process. Luckily I was able to copy the driver (bcmwl5.sys) from my windows disk (under /Windows/System32/Drivers/bcmwl5.sys) and extract it that way to my unbuntu firmware directory. For future members reading this helpful I guide, I would like to add that you can grab the latest version of this driver from here -> bcmwl5.sys (http://sidulus.textdrive.com/bcmwl5sys.zip) (if you could add that into the guide somehow it would be great)

nickm
June 1st, 2006, 07:59 PM
Thanks Vaan, i didnt even realise there was a dapper and breezy section, i have PMed a mod to rectify this, Thankyou!

I will also incorporate your update into the instructions an another method of obtaining the driver files.

I am testing my own modification to the guide at the moment which enables an entire step to be removed, it seems in Cutter you can specify where the files are created to, so if i specify that they are created to /lib/firmware you wont have to move them by hand! i'll give it a go and get back to you all tonight. - **implemented**

Vaan
June 1st, 2006, 10:00 PM
Ah that's no problem. I am now viewing this thread and happily browsing the net with my beautifully working wireless connection.

Yet again you have managed to make this fix even simpler. :)

swhit
June 1st, 2006, 10:08 PM
When extracting the card's firmware, I've seen this done differently by two seperate "How-To's". Which is correct?


sudo bcm43xx-fwcutter -w /lib/firmware /path/to/bcmwl5.sys

or

sudo bcm43xx-fwcutter -w /lib/firmware/2.6.15-23-386 /path/to/bcmwl5.sys

or does it not matter?

nickm
June 1st, 2006, 10:26 PM
swhit, I put the firmware in that 2.6.15-23-386 folder and it didnt work for me,
I should think that that would lead to a problem when the kernel was updated too, but i dont know how that works...
so i think it does matter, i know my method works and i cant speak for the other method beyond "it didnt work for me".

vaan, im glad i can help :), I think its thanks to you that this made it into the How to: catagory, which is a location that will make it much more helpfull to people, go team!

slooksterpsv
June 1st, 2006, 10:31 PM
I promise I will figure out how to get this working for us PPC users, I'm going to try this method, and if it works for my Apple PPC Mac I'll shout it out the Windows. PPC has had the biggest issue when working with wireless. Wish us luck everyone - if I get it to work I'll write a How TO specifically for Apple Users.

nickm
June 1st, 2006, 10:34 PM
Good Luck!! technically if it works isnt this the guide for apple users too?

Vaan
June 2nd, 2006, 01:01 AM
No problem, I'm glad I was able to lend some help.

Yesterday was my first Unbuntu experiance, and since today, it's been going very well. I love this OS. It's on a dual-boot with my WinXP Pro. I mainly installed it so I can get more familiar with linux and the terminal. Sometimes I do work via SSH (shell) on deticated linux servers, so it's extremely helpful to know how to use the terminal effectively.

Not only that, but the GNOME GUI is quite beautiful. :)

rjstevens3
June 2nd, 2006, 01:26 AM
Does not appear to be working with my HP dv8000. I have a Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02) and have tried a few different drivers obtainted from the ndiswrapper wiki (I'm not using ndiswrapper, but the windows drivers for my chipset will be the same). I have also tried the drivers from this guide without success.

The device shows up, but no essids show up when i try to configure. ifconfig shows that it is installed and should be working.

Has anyone else ran into this problem?

-RJ

thecrazymonk86
June 2nd, 2006, 02:42 AM
hey i got this message when moving the files into the firmware folder:

*****: Sorry, it's not posible to extract "bcm43xx_microcode11.fw".
*****: Extracting firmware from an old driver is bad. Choose a more recent one.
*****: Luckily bcm43xx driver doesn't include microcode11 uploads at the moment.*****: But this can be added in the future...

and my wireless doesnt work, i get an ip but no net and cant connect to router

Ziptar
June 2nd, 2006, 03:39 AM
Thanks for the excellent write up!! Worked like charm for me and I have been a linux user for all of 20 minutes ;)

crag277
June 2nd, 2006, 04:21 AM
I followed a very similar guide on the wiki to try and get my Broadcom 4318 working in my Compaq V2000Z laptop. Only differences are I'm using Kubuntu and the bcmwl5.sys file form the compaq driver site for this computer. I thought everything was going great. The blue light came on after the driver install and it found my wireless network. But when I tried to connect, using Wireless Assistant in KDE it could not connect to the network. Now, the light is still on, iwconfig correctly identifies the device, but it no longer sees any wireless networks, even though there are two very strong ones in range. Any ideas?

I have a Turion 64, AMD64 version of Kubuntu 6.06, and 1GB RAM.

I saw another post of problems with this wireless device when the system has >1GB of RAM. Is there any merit to that?

slooksterpsv
June 2nd, 2006, 05:04 AM
I did the same thing I've been doing before and it still works. Ubuntu just needs more support on getting these things working instead of a work-around.

nickm
June 2nd, 2006, 11:01 AM
For anyone that is having problems, try this:

modprobe bcm43xx
and reboot

nickm
June 2nd, 2006, 11:11 AM
The device shows up, but no essids show up when i try to configure. ifconfig shows that it is installed and should be working.

Has anyone else ran into this problem?

can you try this:

iwconfig
and post what you see?
------------------------------------------------------------


hey i got this message when moving the files into the firmware folder:

*****: Sorry, it's not posible to extract "bcm43xx_microcode11.fw".
*****: Extracting firmware from an old driver is bad. Choose a more recent one.
*****: Luckily bcm43xx driver doesn't include microcode11 uploads at the moment.*****: But this can be added in the future...

and my wireless doesnt work, i get an ip but no net and cant connect to router

hmm, i dont quite know what to make of this, i got that same error and mine works... i dont understand how you have an IP assigned to you from your router but you cant connect.. can you go to System > Administration > networking and see if your card is disabled on that menu? it should be.
Also clear out the values on the DNS tab too. hope that helps
------------------------------------------------------------


But when I tried to connect, using Wireless Assistant

Try network manager



I saw another post of problems with this wireless device when the system has >1GB of RAM. Is there any merit to that?


Doubtful, i dont think RAM will effect anything in that way

crag277
June 2nd, 2006, 02:07 PM
I'm using KDE, so I installed knetworkmanager, but still no luck. It still does not find any availible wireless networks. However when I manually tell it to connect to my network it must see it, because the progress bar gets stuck at 28% and says something like "Configuring Device". I'm at work now and don't remember exactly. It stays like this for ome time, during which the wired connection doesn't work either. Then, after some kind of timeout I assume, the blue wireless light goes off, then comes back on, and the process starts over again. The only way to end it is to quit KNetoworkManager.

Swad
June 2nd, 2006, 03:12 PM
Good guide and all very simple compared to to some of the previous beta guides for Dapper. That said, though, it doesn't actually work for me. In previous guides it said you couldn't have a protected WAP (ie: encryption) enabled when trying to connect. Is this still the case? There's no way I'm taking down our corporate security on our WAP just for this. This is a step backwards and uncalled for. ndiswrapper worked great for me in Breezy, but this seems like step backwards.

Honestly, it seems like networking in general with Dapper took a step or two back... or at least does it in totally new ways. The /etc/network/interfaces file seems to do nothing at all anymore. Even things such as activating and deactivating interfaces through the gnome Networking GUI only half works.

I'm still going to beat on this a bit more, but I'm about to throw in the towel as things that used to work for me one way before with network suddenly doing their own thing now and I can't seem to control the setup of my networking config. Wireless acts like it works (looking and TX/RX info on ifconfig) and the settings seem right with iwconfig, but nothing actually works.

UGH!

trivialpackets
June 2nd, 2006, 04:13 PM
A big thanks from me. But a question. Is there a reason this is better than ndiswrapper? I had tried to get this going using the wiki and for whatever reason failed on RC. I did reinstall of LTS after messing with Suse for my father in law, and this worked perfectly. Great How To. Now I just need a how to for getting gfxboot to work right.

marlobello
June 2nd, 2006, 06:00 PM
This is a great how-to with one major problem. You must have a network connection to get a network connection (apt-get fwcutter). Can you install this package for distro discs?

rjstevens3
June 2nd, 2006, 07:05 PM
$iwconfig
lo...

eth1 IEEE 802.11b/g ESSID:off/any Nickname: "Broadcom 4318"
Mode: Managed Frequency=2.437 GHz Access Point: Invalid
Bit Rate=11 Mb/s Tx-Power=18dBm
RTS thr:off Fragment thr:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

eth0.....

unicycler
June 2nd, 2006, 07:28 PM
I've been fighting with this for the past two days now, but it is almost all fixed thanks to you. My only remaining problem is that now, every time I restart, I need to sudo modprobe bcm43xx. Is there any way to get this command to run during the boot process?

pspowell
June 2nd, 2006, 07:36 PM
Thanks for a great guide!

I had just finished setting up NetworkManager not 10 minutes before this showed up on Digg. Sometimes, as in my case, the NetworkManager install isn't quite flawless, but I found this link which walked me thru the install. It's on the Ubuntu wiki at :https://wiki.ubuntu.com/NetworkManager

bieber
June 2nd, 2006, 07:54 PM
Question: Is there a way I can download the neccesary software on my computer with a wired connection, then put the files on a disk and install on the computer that isn't? I'd very much like to save the hassle of hauling the wirelessly connected machine and its monitor out into my living room...

System84
June 2nd, 2006, 08:03 PM
I use a 15" PowerBook G4 for work and I was able to successfully get wireless working with the above tutorial.

I did hit a slight snag however, for whatever reason I could not get connected through gnome-network-manager, kwifimanager, or anything like that, but I found a program in the repositories called Wifi-Radar and that allowed me connect with no problems.

There is hope for us Apple users!

jrattner
June 2nd, 2006, 09:39 PM
I have followed this guide verbatim for my Broadcom card ( Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)

Yet nothing has worked. I'm using the drivers from the website offered in the tutorial. Can you help me debug, or do anything to take a step in the right direction?

rjstevens3
June 2nd, 2006, 09:58 PM
jrattner, I have the same card and have followed the guide, but i used the drivers from the HP website and then intalled them with wine, to get the correct .sys file. Still doesn't work for me.

-RJ

lynxus
June 2nd, 2006, 09:59 PM
PCMCIA Card = wpc54gs

WOW
Thank you for this post!
This needs to be sticky or posted everywhere lol!

Im sure this methoud will probably work with other devices ( As longa s they have the .sys file thingy

Anywho
THANKS AGAIN!!
MADNESS! PERFECT WOW THANKS lol

Cheers
Graham

Mr Sprout
June 2nd, 2006, 10:52 PM
I'm unable to download the community maintained (universe) repositories, some of the files are 404ing.

http://antesis.freecontrib.org/mirrors/ubuntu/freecontrib/dists/breezy/free/binary-powerpc/Packages.gz: 404 Not Found
http://antesis.freecontrib.org/mirrors/ubuntu/freecontrib/dists/breezy/non-free/binary-powerpc/Packages.gz: 404 Not Found

:(

nickm
June 2nd, 2006, 10:54 PM
well its not dependant on a specific version of Ndis, as in if you use Ndis and the new version doesnt work with your card...your stuck, but this will work forever.

Also Ndis didnt work for me and this did.

Mr Sprout
June 2nd, 2006, 11:06 PM
well its not dependant on a specific version of Ndis, as in if you use Ndis and the new version doesnt work with your card...your stuck, but this will work forever.

Also Ndis didnt work for me and this did.

I used wifi-radar as mentioned above and that got it working fine. Perhaps you could add it to your main post as an alternative to Network Manager.

Thanks for this tutorial though, it's been a great help.

rjstevens3
June 2nd, 2006, 11:36 PM
Quote from the wiki page
You must remove wifi-radar, as it has a driver conflict with the driver https://wiki.ubuntu.com/WifiDocs/Driver/bcm43xx#head-cf3f0ec9146ae9441b39c4bed74e5d044ef78d2f

I'm glad you got it working, but it probably should be tested more to see why it worked.

-RJ

strattonbrazil
June 2nd, 2006, 11:45 PM
A little adjustment...

The command "bcm43xx-fwcutter /home/$USER/Desktop/bcmwl5.sys" creates the firmware files in the directory you are current in...it cannot be assumed that is the "Desktop".

I couldn't figure out why it wasn't creating the files, then I stumbled across them in my "~" directory (where I ran the command). Not a huge thing, but I wouldn't consider myself too much of a linux newbie and it got me.

Other than that...great work...I have wireless without the pain of the ndiswrapper manual install!!! Thanks a ton!

I think you misread the command. If you type in the command you have in your post, it will spit out the firmware in the folder you're in. If you do the command he has,

sudo bcm43xx-fwcutter -w /lib/firmware ~/Desktop/bcmwl5.sys

you can see the "-w /lib/firmware", which tells the program to put them in /lib/firmware. So, if you do use the -w, you can assume it goes to /lib/firmware (or where ever you tell it). If not, you can assume it they files will drop in your current directory. Did you type it with the -w option and forget to post to the forum with it and it still put the firmware files in your current directory? Maybe you misspelled in the /lib/firmware directory and the program just spit them out to the current directory.

Anyways, it was a good article.

stromb
June 2nd, 2006, 11:49 PM
Hah, just my luck...seems as though everyone on this thread with a "Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)" card hasn't been able to get this working :( . I followed this guide to a T and though it seems as though it should be working (laptop light finally coming on and no "hanging" when configuring in the Network Manager"), I get nothing. Here is what I've done...


root@lappy:~# lspci | grep Broadcom\ Corporation
0000:06:02.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)

Prerequisite
Ubuntu dapper *check*
A wireless card that shows up in Ubuntu *check*
A driver installation CD (for Windows) OR a driver for your card from the internet *check* (downloaded from http://sidulus.textdrive.com/bcmwl5sys.zip)
Access to the Ubuntu Universe Repository *check*

Did this:


root@lappy:~# apt-get install bcm43xx-fwcutter

When running:


root@lappy:~# bcm43xx-fwcutter -w /lib/firmware ~/Desktop/bcmwl5.sys

...I get:


*****: Sorry, it's not posible to extract "bcm43xx_microcode11.fw".
*****: Extracting firmware from an old driver is bad. Choose a more recent one.
*****: Luckily bcm43xx driver doesn't include microcode11 uploads at the moment.*****: But this can be added in the future...

...but it still appears to install the files into the firmware directory.

Did this:


root@lappy:~# apt-get install network-manager-gnome

And after a reboot and even trying this:


root@lappy:~# modprobe bcm43xx

...I get nothing. I've been playing around with this for hours now and am pretty much stuck. Here is some debug information (eth1 is the wlan card):


root@lappy:~# iwconfig
lo no wireless extensions.

eth1 IEEE 802.11b/g ESSID:"linksys_SES_54484" Nickname:"Broadcom 4318"
Mode:Managed Frequency=2.437 GHz Access Point: Invalid
Bit Rate=11 Mb/s Tx-Power=18 dBm
RTS thr:off Fragment thr:off
Encryption key:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

eth0 no wireless extensions.

sit0 no wireless extensions.

root@lappy:~# dhclient eth1
Internet Systems Consortium DHCP Client V3.0.3
Copyright 2004-2005 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/products/DHCP

Listening on LPF/eth1/00:14:a5:69:d9:46
Sending on LPF/eth1/00:14:a5:69:d9:46
Sending on Socket/fallback
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 9
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 21

I have reset ALL the router settings so there's no WEP (or any encryption at all), copied/pasted the SSID into the Network Manager and even tried statically assigning the IP address. But still nothing :( . And nothing shows up in the Gnome panel for wifi either. Has anyone gotten this specific card to work??? Any help would be GREATLY appreciated.

Thanks in advance!

kuriharu
June 2nd, 2006, 11:52 PM
Looks great, it's the first time I've had an explanation as to why my card can be seen in Ubuntu but never connect.

How do I find the firmware for an Atheros card? Any clues? My connection actually worked once but it hasn't since.

xXx 0wn3d xXx
June 3rd, 2006, 12:03 AM
This worked great with my Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02) card. And to everyone who is having problems with getting this to work, try this:


sudo gedit /etc/modprobe.d/blacklist
and add:

blacklist ndiswrapper
to a new line.

samjam
June 3rd, 2006, 12:04 AM
I have a linksys bcm card, I had no trouble getting it to work with native bcm drivers WITHOUT encryption, but who wants to run an open network?

Here's my solution to getting it working on bootup with encryption:

Put this in a file called: /usr/local/bin/bcm43xx


#! /bin/sh -x

: ${IFACE:=${1:-eth1}}

ifconfig $IFACE up
sleep 1
iwconfig $IFACE key off
sleep 3
iwconfig $IFACE essid freeden
sleep 3
iwconfig $IFACE key restricted 0000111111yourkeyinhexhere
sleep 3

and then this fragment in my /etc/network/interfaces



iface eth1 inet dhcp
pre-up /usr/local/bin/bcm43xx
auto eth1

If I specify the essids and keys in my network interfaces it doesn't work
If I try to associate with the essid/AP with encryption on, it always fails, hence the script makes sure it is turned off.
So then I set the essid, wait, and then I set the key and I have to say "restricted"

A most telling message in dmesg or /var/log/messages is one like this:

Jun 2 20:56:23 localhost kernel: [4295485.996000] ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready

the magic "link becomes ready" means essid and encryption all working fine.

chubsmalone
June 3rd, 2006, 02:05 AM
Thank God you put this out here. I have a Motorola WN825G wireless card and these steps worked PERFECTLY! No more ndiswrapper!! It "just works" now. Fantastic.

duelboot
June 3rd, 2006, 02:18 AM
nickm,

Thank you so much! I used this on my oldest computer (a Pent II (266)) with a Motorola PCI wireless card (Broadcom chipset)...this worked perfectly! No more ndiswrapper and no more driverloader.

Thanks again.
duel

Brainfish
June 3rd, 2006, 02:19 AM
This is a great how-to with one major problem. You must have a network connection to get a network connection (apt-get fwcutter). Can you install this package for distro discs?

I'll second this. My only access to the internet is via my wireless connection. The guide assumes that you already have internet access to download & install fwcutter. ](*,)

beck24
June 3rd, 2006, 02:33 AM
Well, the bad news is that I have that same:


Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)
card that isn't working for anyone else. The good news is that it is working for me. I followed the instructions as given, it gave me the same error:


*****: Sorry, it's not posible to extract "bcm43xx_microcode11.fw".
*****: Extracting firmware from an old driver is bad. Choose a more recent one.
*****: Luckily bcm43xx driver doesn't include microcode11 uploads at the moment.*****: But this can be added in the future...
as some other people. But on reboot it's working perfectly. Much better than in breezy using ndiswrapper and netapplet.
Thanks a bunch, I hope everyone else can get theirs going...

axiomata
June 3rd, 2006, 02:45 AM
I'd love to see a version of this guide for those like who are unable to get an ethernet internet connection that is required for a number of steps. Perhaps links to all the programs needed so they can be downloaded through windows or another computer as well as directions as to how to install the programs without the simple apt-get approach.

I know I'd appreciate it very much and I'm sure others may also.

xXx 0wn3d xXx
June 3rd, 2006, 02:55 AM
Well, the bad news is that I have that same:


card that isn't working for anyone else. The good news is that it is working for me. I followed the instructions as given, it gave me the same error:


as some other people. But on reboot it's working perfectly. Much better than in breezy using ndiswrapper and netapplet.
Thanks a bunch, I hope everyone else can get theirs going...
That's not an error. The message is saying that most broadcom cards do not currently support microcode11 uploads. I get the same message but my wireless works.

K.Mandla
June 3rd, 2006, 03:46 AM
I'm going to hack away at this a little when I get home. I have an Inspiron 600m with the Dell 1370 (4318 chipset), and was having no luck with ndiswrapper or the wiki instructions. It might have been the drivers I downloaded from Dell's support site, though.

The funny thing is, I got the same machine to work with ndiswrapper under Breezy -- not a hitch at all. I have a feeling I'm using a different driver than what I was using in January, though. ](*,)

zahidism
June 3rd, 2006, 04:37 AM
it worked beautifully on my 600m w/ a dell wlan 1350 wireless card (BCM4306 chipset). THANK YOU!!

Noahod
June 3rd, 2006, 05:59 AM
I just tried this on a fresh install of kubuntu dapper. I installed knetworkmanager instead of networkmanager gnome, which detected my lan card fine, but not my wireless.

Then I tried to set up the wireless with wlassistant, and the machine found the network, but hard locked when I tried to connect to it. :-|

Any ideas?

I did also have the
*****: Sorry, it's not posible to extract "bcm43xx_microcode11.fw".
*****: Extracting firmware from an old driver is bad. Choose a more recent one.
*****: Luckily bcm43xx driver doesn't include microcode11 uploads at the moment.
*****: But this can be added in the future...

error, but my card is a bcm4306.

chrishack14
June 3rd, 2006, 06:23 AM
I'm having problems similar to what others have been having. After following the guide in detail, blacklisting ndiswrapper, and removing wifi-radar, I can get my card to come up, but its access point still shows up as "invalid" in iwconfig, ifconfig does not show it as "running", and it will not detect any wireless network. I have a 4306 model. Did anybody else with this model do anything extra and have any success? Any ideas? Thanks.

Slicedbread
June 3rd, 2006, 06:45 AM
After much hassle and many fresh installs I got it to work.
My laptop is a HP ZE2308WM (similar to the Compaq V2000 only with AMD and ATi).

Wireless card: 0000:05:02.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)

The driver listed in the first post did not work for me, so I used the one listed in the wiki: driver (http://www.linksys.com/servlet/Satellite?blobcol=urldata&blobheadername1=Content-Type&blobheadername2=Content-Disposition&blobheadervalue1=application%2Fx-msdownload&blobheadervalue2=inline%3B+filename%3DWMP54GSv1.1_ 20050428.exe&blobkey=id&blobtable=MungoBlobs&blobwhere=1124848568427&ssbinary=true) and it worked. It's an exe so you need to extract it and it seems to be an older driver but as long as it works...

Other things I tried that may have contributed to it working was blacklisting ndiswrapper like MasterChief1234 had suggested and commenting out the interfaces (except lo) as described in the gnome network manager wiki (https://wiki.ubuntu.com/NetworkManager).

Hope this helps someone. EDIT: I uploaded the actual driver that I used from the wiki. It does work with WPA by the way, although it is limited to 11MBPS (B)

PPower
June 3rd, 2006, 07:14 AM
How to get a wireless card working in Ubuntu dapper(6.06) with a Broadcom chipset

Okay so you have a wireless card that shows up in ubuntu but doesnt connect to any wireless network?

The reason the card shows up but doesnt work is because ubuntu is distributed with its driver (so it can recognize it) but not with its firmware (so it can USE it) for legal reasons.

However you can take the firmware out of the windows drivers and put them into ubuntu and make the card work :mrgreen:
Follow these steps to get your wireless card working under ubuntu dapper 6.06:

To find out if your card has a broadcom chipset run the following command:

lspci | grep Broadcom\ Corporation
If that returns a string of numbers followed by the words Broadcom Corporation and then some more numbers then your in luck!
But if not, try my guide anyway, it cant do any harm and it might work for you, its largly untested for cards other than mine and the success stories posted here so give it a go and see!

Here is my output from doing this:

lspci | grep Broadcom\ Corporation
0000:02:0d.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 03)


Prerequisite
Ubuntu dapper
A wireless card that shows up in Ubuntu
A driver installation CD (for Windows) OR a driver for your card from the internet
Access to the Ubuntu Universe Repository

1) Ensure you have access to the other ubuntu repos
follow the intructions on the second heading from this page to ensure you have the universe enabled
https://wiki.ubuntu.com/MOTU/Packages?action=show&redirect=UniversePackages

2) Copy your windows driver to your desktop
You have 3 options here, you can either:
Copy the driver from the CD that came with the Card
Copy it over from your windows partition if you have access to it, it will be located here: /Windows/System32/Drivers/bcmwl5.sys
Obtain the newest version of it from here - http://sidulus.textdrive.com/bcmwl5sys.zip

3) Install bcm43xx-fwcutter
Open a terminal (dont worry) and type the following:

sudo apt-get install bcm43xx-fwcutter
It will ask for your password and may ask you to press y to install, but dont worry its really easy

GUI Alternative: go to System in the top Gnome bar then Administration then Synaptic Package Manager
From here click Search and search for bcm43xx-fwcutter
Right click on its entry in the package window, select Mark for Installation and then click apply

4) Extract your Cards firmware from the driver
Open a terminal (dont worry) and type the following:

sudo bcm43xx-fwcutter -w /lib/firmware ~/Desktop/bcmwl5.sys
This will create lots of new files in the /lib/firmware directory, this is the firmware part of the driver that will make your card work with ubuntu!

Note The location and name of the sys file for this command may differ in your case, if you really get stuck type bcm43xx-fwcutter and then hit space, find your file using the GUI and then drag and drop it into the terminal.

5) Install Network Manager
I find that this is the best way to manage wireless connections

sudo apt-get install network-manager-gnome
It may ask for your password and may ask you to press y to install, but dont worry its really easy

6) Bookmark this page and Reboot
Press Ctrl + D and then click on add
Then log out & reboot
Return to this page after logging back in again


7) Use your new Wireless connection
From what i remember network manager should now show up by your clock and display your current connection, if your lucky it will show a series of bars, this means your now using your wireless connection so lucky you!
If it doesnt, right click on it and tick "Enable Wireless" then left click on it
and select the wirless network of your choice.

8) Give me feedback
I am happy to revise this guide if people find other ways of doing it or if you find it doesnt work for you and have a solution
I am also happy to create screenshots of each step if i can find hosting for them, i dont like imageshack etc as pictures hosted there expire
Please contact me on Boredklink+forums@gmail.com for either of these

Thanks, i hope this helps...

Thanks to markmcspadden, spd106 and Vaan for giving suggestions/correction which proved invaluable to this guide :)
A BIG thanks to Dipswitch for a second pair of eyes on this Howto and contributing some changes also :)

----------------------------------------------------
For anyone that is having problems, try this:

modprobe bcm43xx
and reboot

Nice guide. It wont work for people without a internet connection though and there is a bug in some cards that requires a extra command. Mine is one (Belkin F5D7000). Here are some ajustments:

1: Everything looks OK but no net connection?
Open a terminal and type iwconfig. Look at the wireless device (it will probably be eth1). Under access point if it says invalid then we need to fix it. To do this type:
sudo iwconfig <device> ap any
and enter your password.
Back in your network management tool disable and enable your card. Now it will work. Note you will have to repeat this every bootup.

2: Getting the firmware without a internet connection: (another method to get the firmware).

You will need another pc and a floppy or something. On the other pc browse to http://packages.ubuntu.com and click Dapper. You will need to find the bcm43xx-fwcutter package. Good luck (I don't renember where it is). Stick the deb on a floppy. Now go to <wherever the special ubuntu script lists the archive> and download <the file that the script lists>. Put that on a floppy.

Back on Linux extract the file and install the fwcutter package. Then finally cut the firmware out of the <file listed in the script> and copy all the fw files to /usr/lib/firmware.

Noahod
June 3rd, 2006, 07:50 AM
After much hassle and many fresh installs I got it to work.
My laptop is a HP ZE2308WM (similar to the Compaq V2000 only with AMD and ATi).

Wireless card: 0000:05:02.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)

The driver listed in the first post did not work for me, so I used the one listed in the wiki: driver (http://www.linksys.com/servlet/Satellite?blobcol=urldata&blobheadername1=Content-Type&blobheadername2=Content-Disposition&blobheadervalue1=application%2Fx-msdownload&blobheadervalue2=inline%3B+filename%3DWMP54GSv1.1_ 20050428.exe&blobkey=id&blobtable=MungoBlobs&blobwhere=1124848568427&ssbinary=true) and it worked. It's an exe so you need to extract it and it seems to be an older driver but as long as it works...

Other things I tried that may have contributed to it working was blacklisting ndiswrapper like MasterChief1234 had suggested and commenting out the interfaces (except lo) as described in the gnome network manager wiki (https://wiki.ubuntu.com/NetworkManager).

Hope this helps someone. EDIT: I uploaded the actual driver that I used from the wiki.

This made things closer for me, networkmanager detected the network, and started to connect, although it couldn't get an ip.

Then I ran iwconfig and the system hard locked.. I guess it's just not ready for prime time, back to ndiswrapper I go.

Noahod
June 3rd, 2006, 08:20 AM
ok, now I've loaded ndiswrapper, + the driver and I've appended it to /etc/modules

Now when I start up, it is detected by networkmanager, but it won't connect to any of the networks, it just sits there configuring the interface, then goes link is down, and stops.

However, wlassistant works perfectly, and I can connect... But I want to use networkmanager.. any ideas?

n00bWillingToLearn
June 3rd, 2006, 09:00 AM
I would be happy to host the images on my googlepage. That is pretty much all I use my google page for, mirroring stuff. It is pretty much guarenteed to stay up (it's google) and I don't have any other use for the 100 meg.:)

K.Mandla
June 3rd, 2006, 09:01 AM
First of all, thanks for the guide. It's been helpful, although it didn't work for my 1370.

However, I have the wireless more or less working, through ndiswrapper and the driver files listed here. ...

ftp://ftp.hp.com/pub/softpaq/sp30001-30500/SP30379.exe

Unfortunately, that's a Windows installer program, although it really only spits out the Broadcom drivers and installation programs, into a directory you choose. Later on (like tomorrow, after I've slept :D ) I can decompress that file and strip out the .inf and .sys that I used, then post them here.

I hope that's what solved it for me. The problem is that at this point, I've whacked away at this problem so many times that I might have tweaked something completely unrelated. A fresh install is in order, for testing purposes.

Thanks and cheers.

xiota
June 3rd, 2006, 09:26 AM
Some of the comments people have typed seem like there is a way to get a list of available ESSIDs. Is this available in Network Manager somehow, already installed with Ubuntu, or something extra that would need to be installed? If such a feature were available, would clicking on it automatically configure wireless for connection to the selected access point? (If that were the case, then it might be a solution to the problem I describe below.)

I have a Linksys WMP54GS... Following the steps from this thread, I got the card to work in 802.11b mode, but not in 802.11g mode. Does anyone know how to get G mode working?


The card functioned properly, most of the time, in Windows 2000. The drivers glitched or crashed occassionally, which required a reboot.

Signal strength is definitely not a problem.

I tried both the bcmwl5.sys file linked in the original instructions as well as a couple versions provided by Linksys. The Linksys files gave an error about missing microcode, but with a comment that the missing microcode is not currently used by the drivers.

I've searched these forums and elsewhere, but have not encountered anything helpful so far. I'm about a stone's throw away from giving up and trying ndiswrapper.

Thanks for any help anyone can provide.

Someone typed a comment elsewhere saying that G-mode seems to be not supported at the moment. People whose cards will detect, but not connect, to a wireless network might be trying to connect to G-only networks. So some of us may be stuck with ndiswrapper for now.

SpackMonkeh
June 3rd, 2006, 12:28 PM
Has anyone got a 4303 working? I can get it to work but fail to connect to any AP's..
Chaz.

nickm
June 3rd, 2006, 02:03 PM
I'm sorry if i dont reply to you, i'v been swamped with replys, 4 pages over night, apparently the digg i made hit front page, good and bad i guess :/


I'm using KDE, so I installed knetworkmanager, but still no luck. It still does not find any availible wireless networks. However when I manually tell it to connect to my network it must see it, because the progress bar gets stuck at 28% and says something like "Configuring Device". I'm at work now and don't remember exactly. It stays like this for ome time, during which the wired connection doesn't work either. Then, after some kind of timeout I assume, the blue wireless light goes off, then comes back on, and the process starts over again. The only way to end it is to quit KNetoworkManager.

Try wifi radar as suggested further on in this thread, see if you have any luck with that


$iwconfig
eth1 IEEE 802.11b/g ESSID:off/any Nickname: "Broadcom 4318"
Mode: Managed Frequency=2.437 GHz Access Point: Invalid
Bit Rate=11 Mb/s Tx-Power=18dBm
RTS thr:off Fragment thr:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

hmm, did you try the modprobe thing?


I've been fighting with this for the past two days now, but it is almost all fixed thanks to you. My only remaining problem is that now, every time I restart, I need to sudo modprobe bcm43xx. Is there any way to get this command to run during the boot process?

Yes, modprobe bcm43xx should do it, maybe try it without sudo? thats what i did


Question: Is there a way I can download the neccesary software on my computer with a wired connection, then put the files on a disk and install on the computer that isn't? I'd very much like to save the hassle of hauling the wirelessly connected machine and its monitor out into my living room...
Honestly, i dont know, it might be a good idea to go onto ubuntu Irc or search some more, but in any case, you'd only have to move it once and back to find out if it would work for you :)


I'm unable to download the community maintained (universe) repositories, some of the files are 404ing.

http://antesis.freecontrib.org/mirrors/ubuntu/freecontrib/dists/breezy/free/binary-powerpc/Packages.gz: 404 Not Found
http://antesis.freecontrib.org/mirrors/ubuntu/freecontrib/dists/breezy/non-free/binary-powerpc/Packages.gz: 404 Not Found

:(

Its okay, the freecontrib ones are not needed to perform this guide


I used wifi-radar as mentioned above and that got it working fine. Perhaps you could add it to your main post as an alternative to Network Manager.

Thanks for this tutorial though, it's been a great help.

Done :)

SpackMonkeh
June 3rd, 2006, 02:37 PM
Hey, This is my card:

0000:02:02.0 Network controller: Broadcom Corporation BCM4303 802.11b Wireless LAN Controller (rev 02)

I have got it so it detects and it can see my network however it doesnt actually connect to it and just fails.
It even promts me for my WPA-PSK key...i put it in and it doesnt connect. I've tried without encryption too.
Any ideas?
Thanks,
Chaz.

nickm
June 3rd, 2006, 02:52 PM
Hey, This is my card:

0000:02:02.0 Network controller: Broadcom Corporation BCM4303 802.11b Wireless LAN Controller (rev 02)

I have got it so it detects and it can see my network however it doesnt actually connect to it and just fails.
It even promts me for my WPA-PSK key...i put it in and it doesnt connect. I've tried without encryption too.
Any ideas?
Thanks,
Chaz.

If your sure your putting your key in properly, there is something you have to put infront of your key to tell the router wether you wrote the key as plantext or HEX but i'v never used encryption so i dont know what it is but i found this written by jonny in another wirless post

8. BE CAREFUL entering your WEP key, if you're using one. You're expected to enter this in hexadecimal form; if you don't speak hex, prefix your key with s:

But if you've tried without encryption too then check your router settings to see if they allow 802.11B connections

people have been saying they have been having trouble with that card though :-k

Kawayanan
June 3rd, 2006, 03:20 PM
ok, I have an interesting tale :p

First of all, I have a Compaq Presario V2401CL which has a Broadcom BCM4318. Here is exactly what it reports:


0000:05:02.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)

As soon as 6.06 came out, I first tried kubuntu. I followed the instructions in this howto and it worked like a charm. The only difference is I did not do the last step of installing the gnome network manager. There was already a KDE Wireless Assistant loaded (wlassistant 0.5.5-0). Using the wireless assistant, I see the networks and can connect without a problem. It not automatic, it seems you have to manualy connect each time (though it does remember the settings).

After playing around for a bit, I decided that I actually wanted to gnome instead of KDE. To keep everything clean (and since I hadn't done any other customization), I just went with a clean ubuntu install. Once again, I followed this howto. Everything seemed to work well. After installing the gnome network manager and restarting, I could see the wireless networks that were available, but I cannot get any to connect. Mine uses WEP, but I cannot get it to connect without WEP either. As I mentioned, I can see the network. When I enter the WEP key and settings it just sits for a long time trying to connect (when I mouse over the icon I get a bubble that says it is waiting for a network key from my wireless network). I am sure my WEP key is correct and that I have the other correct settings (its open, not shared key).

To test this a bit and make sure something strange had not happened, I went back and did a clean install of kubuntu. Once again, it connects easily and I have wireless access. I did a second clean install of ubuntu and run into the same problem (see the wireless networks, but cannot connect).

I would rather used ubuntu with the gnome network manager if possible. The KDE wireless assistant requires manual connecting and that can be a pain when moving between different locations with multiple wireless networks and wired networks. I like the idea of the user level daemon that tries to keep you connected. I just can't seem to get it to work though :confused: I works great for the wired network. After trying to connect the wireless as soon as I plug in the ethernet cable it recognized it, activates it, and get an IP (DHCP). Anyone have any ideas what wrong with the wireless? Is this a software problem with the gnome network manager?

Thanks for the help.

Kawayanan

nickm
June 3rd, 2006, 04:03 PM
There is just network-manager as well as network-manager-gnome i dont know what that will do for Kde or another DE

DrkAngel
June 3rd, 2006, 04:41 PM
I've been fighting with this for the past two days now, but it is almost all fixed thanks to you. My only remaining problem is that now, every time I restart, I need to sudo modprobe bcm43xx. Is there any way to get this command to run during the boot process?
I added the following to my /etc/network/interfaces:

auto eth0
iface eth0 inet dhcp

This causes the wireless card to activate when Ubuntu configures the network interfaces at boot. Of course, you'd want to change eth0 to whatever device your wireless card is configured as. This setting is compatible with Network Manager, but may cause a delay during boot (I haven't noticed the delay with BCM43xx, but the delay was quite noticable with Ndiswrapper). Good Luck!

-Drk^Angel-

nickm
June 3rd, 2006, 04:59 PM
I added the following to my /etc/network/interfaces:

auto eth0
iface eth0 inet dhcp

This causes the wireless card to activate when Ubuntu configures the network connections at boot. Of course, you'd want to change eth0 to whatever device your wireless card is configured as. This setting is compatible with Network Manager, but may cause a delay during boot (I haven't noticed the delay with BCM43xx, but the delay was quite noticable with Ndiswrapper). Good Luck!

-Drk^Angel-

doesnt the BCM43xx module have to be loaded first, thats what his problem is isn't it? maybe i misunderstood.

jobyjoby
June 3rd, 2006, 05:08 PM
I am also trying to get the BCM4318 to actually connect to a wireless network after following all of the steps. This has been a very helpful topic though!

DrkAngel
June 3rd, 2006, 05:14 PM
doesnt the BCM43xx module have to be loaded first, thats what his problem is isn't it? maybe i misunderstood.
The bcm43xx module is loaded by modprobe.d, but on my system, the card isn't activated until after Network Manager loads. I would have to modprobe bcm43xx once I logged in then restart Network Manager to get it to recognise the wireless. Wasn't sure if this was the same issue unicycler was having, so I thought I'd post my solution just in case it could help.

-Drk^Angel-

btboudreaux
June 3rd, 2006, 05:19 PM
Im also having trouble with bcm4318, I followed the directions exactly and still nothing. This problem is the only thing keeping me from switching over to linux on my laptop. I couldn't get it to work with any Ubuntu release.

nickm
June 3rd, 2006, 05:20 PM
The bcm43xx module is loaded by modprobe.d, but on my system, the card isn't activated until after Network Manager loads. I would have to modprobe bcm43xx once I logged in then restart Network Manager to get it to recognise the wireless. Wasn't sure if this was the same issue unicycler was having, so I thought I'd post my solution just in case it could help.

-Drk^Angel-

Oh okay, i guess annother (but lesser) fix would be to add the instructions you have to do to the sessions program if you dont want to edit files etc

Slicedbread
June 3rd, 2006, 05:26 PM
I think the reason that a lot of people are not getting it to install despite having the exact sam cards is due to some configurations errors. Before the fresh install different methods did:

It could see wireless networks but not connect.
It would connect automatically to an unsecured network, but not obtain an ip.
It would require modprobe to start up but not do anything.
NetworkManager would not show wireless connection even though wireless was on.
ndiswrapper didnt work at all.

As far as I have found, the network interfaces file does nothing. I have them all commented out and it still works.

I would suggest if you can to do a clean install or find some way to delete the config files.

nickm
June 3rd, 2006, 05:31 PM
yes, thats right network manager does not use the traditional config files, looking at my networking through system > administration > networking shows all my netowork cards to be disabled.

If/Iw config show accurate stats but making changes by these two commands dont effect the network manager settings.

bieber
June 3rd, 2006, 06:06 PM
Is there a similar procedure I could use to get my Linksys WUSB54G working? It does the same thing the Broadcom cards do without firmware installed, that is, showing up in Networking but not working...

jobyjoby
June 3rd, 2006, 06:11 PM
Hello again! I fluked out and mine is working now. This was the last/main step I followed from the guide slicedbread linked to:

Gnome

Go to System -> Preferences -> Sessions In the Startup Programs tab, click Add type "nm-applet", click OK. log out of your gnome session, and log back in again.
Cheers!


I am also trying to get the BCM4318 to actually connect to a wireless network after following all of the steps.

FullMetlaMonkey
June 3rd, 2006, 06:13 PM
Thnak you so much for posting suck a great guide! I've been trying to get my Linksys wmp54gs to work with Ubuntu for an insane amount of time!

nickm
June 3rd, 2006, 06:15 PM
AHH! i assumed NM added itself to this list, NEVER ASSUME :p i'll put a thing on my guide about that, thanks!
Great that you got it working

DrkAngel
June 3rd, 2006, 06:22 PM
Okay... I completely removed NetworkManager, and installed it again, and now I don't need the extra lines in my /etc/network/interfaces. Must've been something I messed up in the configs way back when I first installed NetworkManager with Ndiswrapper. Thanks.

-Drk^Angel-

zahidism
June 3rd, 2006, 08:57 PM
err...so my wireless was shifty as in it would stop working periodically...so i decided to just up and remove network manager. now my wireless and ethernet are screwed. any suggestions? i didnt remove the bcm43xx fwcutter. and i tried sudo apt-get install network-manager-gnome but w/o internet connection im convinced it wont do anything. any ideas?

rjstevens3
June 3rd, 2006, 08:58 PM
After much hassle and many fresh installs I got it to work.
My laptop is a HP ZE2308WM (similar to the Compaq V2000 only with AMD and ATi).

Wireless card: 0000:05:02.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)

The driver listed in the first post did not work for me, so I used the one listed in the wiki: driver (http://www.linksys.com/servlet/Satellite?blobcol=urldata&blobheadername1=Content-Type&blobheadername2=Content-Disposition&blobheadervalue1=application%2Fx-msdownload&blobheadervalue2=inline%3B+filename%3DWMP54GSv1.1_ 20050428.exe&blobkey=id&blobtable=MungoBlobs&blobwhere=1124848568427&ssbinary=true) and it worked. It's an exe so you need to extract it and it seems to be an older driver but as long as it works...

Other things I tried that may have contributed to it working was blacklisting ndiswrapper like MasterChief1234 had suggested and commenting out the interfaces (except lo) as described in the gnome network manager wiki (https://wiki.ubuntu.com/NetworkManager).

Hope this helps someone. EDIT: I uploaded the actual driver that I used from the wiki. It does work with WPA by the way, although it is limited to 11MBPS (B)

Are you running i386 or amd_64? I keep getting the feeling that i'm using the wrong firmware files for my card.

I have a turion 64 in my laptop, but i'm running ubuntu i386. I've tried many different windows drivers without any luck. Does anyone know if the different drivers from different makers matter? (i have an HP dv8000 with wifi that only sometimes worked in windows...)

I'm going to try reloading nm_applet after setting iwconfig ap any and see if that works. Thats the only thing i haven't tried yet.

-RJ

n00bWillingToLearn
June 3rd, 2006, 09:05 PM
I followed your howto exactly on my 17'' powerbook with airport extreme and it workes!

I used the link you gave to download the drivers.


I used Network manager at first but while -Network Manager- saw only my ethernet interface, network-admin (System -> administration -> networking) connected fine since I had already manually entered the ESSID and when I installed wifi-radar ( after removing network manager ) it indeed did work and actually found more wireless networks than OSx could.:D

nickm
June 3rd, 2006, 09:11 PM
err...so my wireless was shifty as in it would stop working periodically...so i decided to just up and remove network manager. now my wireless and ethernet are screwed. any suggestions? i didnt remove the bcm43xx fwcutter. and i tried sudo apt-get install network-manager-gnome but w/o internet connection im convinced it wont do anything. any ideas?

:-k can you still set the ethernet up using system > administration > networking?
if you can just use that with your ethernet or connect to the internet and re-do this guide to get your wireless working again

Fwcutter is only used during the guide to cut up the sys file, and seing as you already have the firmware in the right folder its no longer needed

Read one of the bullet points at the top of this guide about being offline, see if that gives you any further help.

nickm
June 3rd, 2006, 09:12 PM
I followed your howto exactly on my 17'' powerbook with airport extreme and it workes!

I used the link you gave to download the drivers.


I used Network manager at first but while -Network Manager- saw only my ethernet interface, network-admin (System -> administration -> networking) connected fine since I had already manually entered the ESSID and when I installed wifi-radar ( after removing network manager ) it indeed did work and actually found more wireless networks than OSx could.:D

Hey thats great n00bWillingToLearn, thanks for your offer of image hosting too, i sent you a reply if your still here.

Slicedbread
June 3rd, 2006, 09:23 PM
Are you running i386 or amd_64? I keep getting the feeling that i'm using the wrong firmware files for my card.

I have a turion 64 in my laptop, but i'm running ubuntu i386. I've tried many different windows drivers without any luck. Does anyone know if the different drivers from different makers matter? (i have an HP dv8000 with wifi that only sometimes worked in windows...)

I'm going to try reloading nm_applet after setting iwconfig ap any and see if that works. Thats the only thing i haven't tried yet.

-RJ

Im using the i386 dapper 6.06, It doesnt really make sense though, because the ones I use in windows from HP dont work nor do the ones in the main link. Each manufacturer must have modified the firmware or something like that.

n00bWillingToLearn
June 3rd, 2006, 09:33 PM
Hey thats great n00bWillingToLearn, thanks for your offer of image hosting too, i sent you a reply if your still here.

I got the reply and BTW I think that this HowTo is easier / more updated to Dapper than the one in the wiki for airPort Extreme cards speifically so if others are also successfull mabe it should be updated.

https://wiki.ubuntu.com/WifiDocs/Device/AirportExtreme

Kawayanan
June 3rd, 2006, 09:44 PM
ok, I have an interesting tale :p

First of all, I have a Compaq Presario V2401CL which has a Broadcom BCM4318. Here is exactly what it reports:



As soon as 6.06 came out, I first tried kubuntu. I followed the instructions in this howto and it worked like a charm. The only difference is I did not do the last step of installing the gnome network manager. There was already a KDE Wireless Assistant loaded (wlassistant 0.5.5-0). Using the wireless assistant, I see the networks and can connect without a problem. It not automatic, it seems you have to manualy connect each time (though it does remember the settings).

After playing around for a bit, I decided that I actually wanted to gnome instead of KDE. To keep everything clean (and since I hadn't done any other customization), I just went with a clean ubuntu install. Once again, I followed this howto. Everything seemed to work well. After installing the gnome network manager and restarting, I could see the wireless networks that were available, but I cannot get any to connect. Mine uses WEP, but I cannot get it to connect without WEP either. As I mentioned, I can see the network. When I enter the WEP key and settings it just sits for a long time trying to connect (when I mouse over the icon I get a bubble that says it is waiting for a network key from my wireless network). I am sure my WEP key is correct and that I have the other correct settings (its open, not shared key).

To test this a bit and make sure something strange had not happened, I went back and did a clean install of kubuntu. Once again, it connects easily and I have wireless access. I did a second clean install of ubuntu and run into the same problem (see the wireless networks, but cannot connect).

I would rather used ubuntu with the gnome network manager if possible. The KDE wireless assistant requires manual connecting and that can be a pain when moving between different locations with multiple wireless networks and wired networks. I like the idea of the user level daemon that tries to keep you connected. I just can't seem to get it to work though :confused: I works great for the wired network. After trying to connect the wireless as soon as I plug in the ethernet cable it recognized it, activates it, and get an IP (DHCP). Anyone have any ideas what wrong with the wireless? Is this a software problem with the gnome network manager?

Thanks for the help.

Kawayanan


There is just network-manager as well as network-manager-gnome i dont know what that will do for Kde or another DE

I understand that. As far as network-manager is the only daemon based "auto-connect" type of network manager available. network-manager-gnome is only a graphical frontend for network-manager. KDE does have a frontend called knetworkmanager. It doens't work for me either :(

I am back to using the more manual approach that worked. I am back to kubuntu and am using Wireless Assistant (wlassistant). I have to manually logon to each wireless network, but it works. The knetworkmanager (KDE frontend to network-manager) had the same problems as under gnome - the card seems to work, network-manager is started and running, I can see the available wireless networks, but when I try to connect to any (WEP or not) it just sits and never connects. From reading in this thread and others, it seems that there are a reasonable number of people haveing this type of problem.

I read through everything I can find about network-manager (doc's, man, web, etc.). I am looking for a way to get something like a verbose terminal output, but can't find anything like that. I don't know where to find any log messages for it either. Since it seems to almost work, I would like to see what part of connecting to the network is not working. I works great for wired, and can detect the wireless networks, it just hangs somewhere during the attempt to connect. If anyone how to see exactly what network-manager is trying to do as it connects, let me know. I will keep people posted on what I find.

Thanks btw for this howto :) I got me connected and close enough to network-manager working to smell it :p

Kawayanan

tactus
June 3rd, 2006, 10:13 PM
Amazing, it looks like someone is online at last. Thanks for a very good tutorial nickm. I am new to Linux and had no problems follow it.

I have the same chipset as (you) nickm, BCM4306, but I am on a PowerBook G4 12". I tried the automatic firmware installer in one of the latest Ubuntu flight versions and went with Network Manager. It't didn't work for me back then, but I could see the available networks. So this time I just went straight for Wifi-radar instead, and lo and behold, it worked. Thanks for the Wifi-radar tip System84, that might have saved me for some headache. :)

One issue I have is that I can't see how good the signal is. All the networks shows either zero or full spike all the time (depending on app), but I asume that's driver related.

Here is a question btw: Can I use my BCM43xx and Wifi-radar on WPA networks? I usually have WPA enabled.

tarr2468
June 3rd, 2006, 11:04 PM
I am getting so close to having this work. I can see my netowork, but I cannot connect. I even turned off encryption, but still no luck. Any one have any suggestions?

Riona
June 4th, 2006, 12:44 AM
This didn't work for me. Followed the instructions. I see the network conections and the wireless connection options. However when i try to connect to my wireless router a linksys I get nothing. Tried it with no encyption and with encryption as well. My laptop a dell inspiron b130 will not connect wireless. I also set the security to mix mode and have my ssid broadcasted.
Here are a few outputs from the terminal. I have no idea what to try next.
eth0 no wireless extensions.

eth1 IEEE 802.11b/g ESSID:off/any Nickname:"Broadcom 4318"
Mode:Managed Frequency=2.484 GHz Access Point: 00:0F:B5:6F:E6:F8
Bit Rate=11 Mb/s Tx-Power=18 dBm
RTS thr:off Fragment thr:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

sit0 no wireless extensions.
eth0 no wireless extensions.

eth1 IEEE 802.11b/g ESSID:off/any Nickname:"Broadcom 4318"
Mode:Managed Frequency=2.484 GHz Access Point: 00:0F:B5:6F:E6:F8
Bit Rate=11 Mb/s Tx-Power=18 dBm
RTS thr:off Fragment thr:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

sit0 no wireless extensions.
--------------------
lspci | grep Broadcom\ Corporation
0000:02:00.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
0000:02:03.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)

?????
June 4th, 2006, 01:05 AM
This guide got my card working! But I have 2 questions:


1. Is it possible to get 802.11g working? (I prefer 54 mbps over 11 mbps)
2. Can I use WPA-PSK on this?

chronusdark
June 4th, 2006, 01:06 AM
i agree i would like to get G support

Slicedbread
June 4th, 2006, 01:59 AM
This guide got my card working! But I have 2 questions:


1. Is it possible to get 802.11g working? (I prefer 54 mbps over 11 mbps)
2. Can I use WPA-PSK on this?


You can use WPA and WPA2 (if your card supports it), I dont think G is supported with the ubuntu driver but you wont see a difference unless your transferring large files over a network or able to download files at over 1300Kbps.

chronusdark
June 4th, 2006, 03:53 AM
i did this command


iwconfig eth2 rate 54M

and it seems to work but i need to restart to check if networkmanager sees the change

ps replace eth2 with your wireless interface

MrObvious
June 4th, 2006, 04:02 AM
Well the code worked chronusdark :). I've been having problems but somehow I got it to work using the alternate driver someone else pointed out I think for the 4318 chipset (try that if you have problems). Thanks to all who have worked hard to make this thread usable for others. It is much appreciated.

zahidism
June 4th, 2006, 04:24 AM
phew, we are back online...thanks again. this is great because I'm such a newb and i dreaded ndiswrapper since 5.10 (i broke it so i uninstalled ubuntu and went back to windows). how do i get the following type of output within the terminal?


eth1 IEEE 802.11b/g ESSIDff/any Nickname:"Broadcom 4318"
Mode:Managed Frequency=2.484 GHz Access Point: 00:0F:B5:6F:E6:F8
Bit Rate=11 Mb/s Tx-Power=18 dBm
RTS thrff Fragment thrff
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0


edit* nvm, figured it out...

trbloomer
June 4th, 2006, 05:24 AM
Wow!

Works like a charm for me. I'm a linux noobe started with debian etch couldn't get ndiswrapper to work with my WPA setup at home. On a whim I downloaded ubuntu 6.06 LTS and found this thread and in about 10.5 secs was up and running with my Motorola 825g card.

Now if we could get the full 54 speed with fall back and oh a working signal indicator but thats just icing on the cake for now.

Thank you.

piracyrocks
June 4th, 2006, 05:58 AM
i have done this tutorial straight through and followed the extra stuff and i cant get my 4318 card to work with y wireless network...this is kind of troublesome...i wish to switch to linux but i will stick with m$ if i cant get wirless to work...its kind of neccessary

DJLC
June 4th, 2006, 06:11 AM
I tried this, and now I can't really do anything. Upon boot (from both the HD AND a LiveCD), I get 3 errors. After closing them all, all I have is a dark brown/red background with a cursor - all I can do is move the cursor around.

In chronological order:
There was a problem registering the panel with the bonobo-activation server. The error code is: 3. The panel will now exit.

There was an error starting the GNOME Settings Daemon. Some things, such as sound, themes, or background settings may not work correctly. The Settings Daemon restarted too many times. The last error message was: System Exception: IDL:omg.org/CORBA/COMM_FAILURE:1.0 GNOME will still try to restart the settings daemon the next time you log in.

Nautilus can't be used now, due to an unexpected error. (Under the Show More Details arrow is the following) Nautilus can't be used now, due to an unexpected error from Bonobo when attempting to register the file manager view server.

Three questions:
1) What, exactly, is the issue?
2) What did I do wrong, and is there anything I can do to correct it w/o reinstalling?
3) If I must reinstall, how can I do this if I can't boot from a LiveCD?

I'm on a Powerbook G3 Lombard. The only thing I did different was that I installed Network Manager BEFORE I installed the card firmware. My "Airport card" is a PCMCIA wireless card w/ Broadcom chipset - it was previously recognized by OS X as an AirPort card.

bluezdood
June 4th, 2006, 06:33 AM
Ok, well this did work for me at the office since they have B and G enabled on the routers around campus. However at home I've only got G available and hence it doesn't connect to the Netgear router I have even though it can detect the network. Since I would rather use G anyway, how can I enable this? The "iwconfig eth2 rate 54M" command didn't work for me. What I get is

Error for wireless request "Set Bit Rate" (8B20) :
SET failed on device eth1 ; Operation not permitted.

Anyone know how to fix this? ](*,)

Slicedbread
June 4th, 2006, 07:02 AM
Ok, well this did work for me at the office since they have B and G enabled on the routers around campus. However at home I've only got G available and hence it doesn't connect to the Netgear router I have even though it can detect the network. Since I would rather use G anyway, how can I enable this? The "iwconfig eth2 rate 54M" command didn't work for me. What I get is

Error for wireless request "Set Bit Rate" (8B20) :
SET failed on device eth1 ; Operation not permitted.

Anyone know how to fix this? ](*,)

Use the sudo command in front. What router do you have? It seems strange that it is able to support 54 but not 11. I doubt that will change much because as far as I can tell gnome network manager doesnt reference /etc/network/interfaces at all.

joergenlie
June 4th, 2006, 07:57 AM
Thanks! My wireless works like a charm, but. There's one but. Is there anyway at all to get this to connect at boot up? Theres too much for my wife to modprobe and use network manager. She only uses the internet. I've tried playing with networking interfaces but still I can't get it to load at boot up.

I have a broadcom 4306 card.

Anyone with a solution to this?


Jørgen

Noahod
June 4th, 2006, 08:14 AM
Mine finally sorted itself out. Works now with ndiswrapper and networkmanager :)

PPower
June 4th, 2006, 08:23 AM
Can I please tell everybody this message from the people at #bcm-users:

When Ubuntu upgrade to a new kernel (and thus a new version of the bcm module) you MUST NOT use the driver supplied on this thread. It is IMPERATIVE that you use wl_apsta.o (see the wiki article or log on to #bcm-users OR run ubuntus script). This new module + driver fixes the invalid AP bug. I have sent a PM to whatshisname (the starter of this thread, sorry i forgot!) as it is a important issue.

PPower
June 4th, 2006, 08:27 AM
Thanks! My wireless works like a charm, but. There's one but. Is there anyway at all to get this to connect at boot up? Theres too much for my wife to modprobe and use network manager. She only uses the internet. I've tried playing with networking interfaces but still I can't get it to load at boot up.

I have a broadcom 4306 card.

Anyone with a solution to this?


Jørgen
It should as long as the bcm driver is not blacklisted. As soon as you boot up type dmesg. Do you see anything related to the bcm driver? It should say something similar to this:
[4294686.432000] bcm43xx driver

Are you using the driver on this thread. It works like a breeze for me. Disable the module and delete all the fw files out of /lib/firmware. Then fwcutter the file on the thread **unzip it first** and ignore the microcode11.fw error. Copy all files to /lib/firmware. Reboot and be on your way to networking heaven!

joergenlie
June 4th, 2006, 08:45 AM
dmesg lists the bcm driver and I have used the driver from this thread, but still it will not connect?

And how do I disable the module?


Jørgen

PPower
June 4th, 2006, 08:48 AM
dmesg lists the bcm driver and I have used the driver from this thread, but still it will not connect?

And how do I disable the module?


Jørgen
You want to turn off bcm and use ndiswrapper? Simpy edit /etc/modprobe.d/interfaces and add blacklist bcm43xx and reboot your computer.

joergenlie
June 4th, 2006, 08:55 AM
Ok. Is it better to use ndiswrapper? I get my wireless to connect and it works fine, but thats just after modprobing it and restart it in network-manager. The only problem is that it doesnt connect at boot up so I have to ifconfig up, depmod -a, update-modules and modprobe 43xx to get connection.

Jørgen

nickm
June 4th, 2006, 12:49 PM
Ok. Is it better to use ndiswrapper? I get my wireless to connect and it works fine, but thats just after modprobing it and restart it in network-manager. The only problem is that it doesnt connect at boot up so I have to ifconfig up, depmod -a, update-modules and modprobe 43xx to get connection.

Jørgen

Theirs a note about this in the guide about checking for nm-applett in the sessions, maybe you could add your modprobe stuff also?

fletch
June 4th, 2006, 04:12 PM
I have the "AirForce One rev 02" broadcom card, and it took most of the tricks displayed on this page to get it working. Hibernation finally works for me in Dapper (didnt in Hoary), but powering back up my v2000, my wireless isn't working. Its active in the Network Manager panel, blue LED is glowing, but no such luck. Anybody experience this problem?

(EDIT: Wireless works fine with a simple reboot, just not coming back out of hibernation, I re-read this and figured it might confuse some people.)

Also, on a side note, how well does Ubuntu deal with PCMCIA wireless cards?? I would like to test out some of the wireless tools offered within the package database in Synaptics, such as kismet or airsnort.

I tried setting up kismet with my broadcom, but it said it only has "experimental" support with the broadcom, but speaks about the other workaround "berlios" driver I've read about back when I was working with ndiswrapper and 5.10 Ubuntu.

SuicideInvoice
June 4th, 2006, 04:35 PM
Nickm, you are my hero. I'm still somewhat new to Linux and I was fighting with ndiswrapper on 5.10 and after upgrading to Dapper and using your how to, my belkin 54g F5D7010 (BCM4306) finally works.

Next up is to see how well the new 'experimental' Broadcom support for Kismet works. No high hopes there though.

Thanks again

grsing
June 4th, 2006, 04:43 PM
THANK YOU! I've been futzing with making wireless work on dapper for several days now (not straight, but many hours still), and this finally did it. Awesome work.

Same chipset and all as you, so of course it should work. Just wish I'd seen this when it was created.

nickm
June 4th, 2006, 05:00 PM
THANK YOU! I've been futzing with making wireless work on dapper for several days now (not straight, but many hours still), and this finally did it. Awesome work.

Same chipset and all as you, so of course it should work. Just wish I'd seen this when it was created.


Nickm, you are my hero. I'm still somewhat new to Linux and I was fighting with ndiswrapper on 5.10 and after upgrading to Dapper and using your how to, my belkin 54g F5D7010 (BCM4306) finally works.

Next up is to see how well the new 'experimental' Broadcom support for Kismet works. No high hopes there though.

Thanks again

Hey i'm glad it works for both of you, iv been in both of your positions and i know how fustrating it is, and also how great it is when you can take the Ethernet wire out, hit "Home" in firefox and have google come up anyway :-D

On a side note, does anyone know what it means when your title is changed to "Spilled the beans" as mine was a few days ago?

?????
June 4th, 2006, 05:09 PM
I'm unsure about the beans.. I think it has to do with your post rate. And i'll try the iwconfig one I boot into Ubuntu which is right after I post this

nickm
June 4th, 2006, 05:20 PM
beat you to it, it didnt work for me :) i think its because its editing the conf files that network manager doesnt use..so it wont have any effect, i dont know what wifi-radar uses though..

As for the title thing, i thought it maybe had something to do with this guide appearing on digg.com and getting 13,000 page views over a few hours or something "spilled the beans" "told everyone" i dunno

slakkie
June 4th, 2006, 06:59 PM
Thanks for the HOWTO, got the wireless up pretty quick (without encryption)
.
Got it working without encryption and with encryption (WPA).
I'm using the gnome-network manager, which is described in the HOWTO. And I'm using wpasupplicant in order to get it working with WPA.

Failover from Wired to wireless isn't that good (non existent tbh)... Hopefully I will get this working somewhere this week(end).

drachir
June 4th, 2006, 07:51 PM
I finally found the time to try this out. I Have a Compaq Presario V2000 Turion64. I have been ](*,) over this since 5.10 and thanks to :KS nickm :KS I am doing a post from a new install of 6.06 with my Broadcom 4318 up and running.

Thanks nickm for you time and help with this. You have made lots of people very happy.

piracyrocks
June 4th, 2006, 07:53 PM
ok drachir...did u do this tutorial straight through?...cus i did it straight through from a clean install of 6.06 and my wireless still isnt working....maybe its cus i have an athlon amd 64?...woudl that make a difference?

nickm
June 4th, 2006, 08:04 PM
maybe piracyrocks, i dont know if there is a special 64bit driver for the card you have? are you using the X86 or 64 bit version of ubuntu?

piracyrocks
June 4th, 2006, 08:09 PM
64 bit version

Cenotaph
June 4th, 2006, 08:17 PM
I can't get it to work. I have the same card that is causing lots of problems.

i did everything, but i cant even check for available networks at this point. I never could get wireless to work here, but on 5.10 with ndiswrapper i could at least get it to check for available networks. what could be wrong here?

nickm
June 4th, 2006, 08:24 PM
Okay, for everyone who couldnt get this to work PLEASE try it again with the revised instructions, i have added a new driver that is reccomended for use so go over it again before posting a "mine doesnt work" thankyou

Slicedbread
June 4th, 2006, 08:26 PM
piracyrocks did you happen to mess with the built in network manager that gnome has? That may be your problem.

I was doing a little experimenting when my wireless BCM4318 card was working and found that trying to configure my wireless card in and activating it would completely fudge the wireless system over. Even though I have not changed anything and disabled the cards in the built in network manager it will not detect any networks, even though the wifi light is on. This leads me to believe that there is some configuration bug in Dapper's built in network manager.

I have the HP version of your laptop and I can tell you that a fresh install with no messing around will get it working fine.

Cenotaph
June 4th, 2006, 09:09 PM
Okay, for everyone who couldnt get this to work PLEASE try it again with the revised instructions, i have added a new driver that is reccomended for use so go over it again before posting a "mine doesnt work" thankyou
that driver worked like a charm :D

thank you :)

guess i should change my vote now hehe

piracyrocks
June 4th, 2006, 09:11 PM
im about to re-try this whole thing..i just did a fresh install of 6.06 on my computer...here goes nothing *crosses fingers*

nickm
June 4th, 2006, 09:20 PM
im about to re-try this whole thing..i just did a fresh install of 6.06 on my computer...here goes nothing *crosses fingers*

good luck :)

piracyrocks
June 4th, 2006, 09:40 PM
so uh...i just did this whole thing with the new reccomended driver thing...the wl_apsta.o one...and it still doesnt work....not only can i not connect to my wireless network...but no wireless networks show up to connect to...none ever have...so im not that surprised...but im a bit dissapointed because that other guy with the same pc as me got this to work...what gives?

KiLLeR_WoMBaT
June 4th, 2006, 09:44 PM
Sorry...wrong thread!

nickm
June 4th, 2006, 09:45 PM
No matter what I try...the only way to NOT get a blank screen upon login is to use VESA. I have tried everything in this thread...both methods of installing ATI's driver and still Dapper will not get past the login screen.

If I try to use ATI or FGLRX with dpkg-reconfigure xserver-xorg, everything goes fine and upon reboot I have two drum sounds (this is how I know it won't work) and everything looks fine. I put in the username and password...everything looks good but just the cursor and a blank (default brown) screen. Nothing...I've let it sit for hours and nothing. It will let me ctrl+alt+bkspc and get out to the login screen again.

I have no DRI with VESA of course either; it still says MESA.

What should I post to help diagnose this problem? I upgraded from breezy...not a new install.

what?

piracyrocks
June 4th, 2006, 09:47 PM
does anyone have any help for me?...i got that card that is the one people seem to have problems with and it also has been said that some got it to work...

bcm4318

nickm
June 4th, 2006, 09:48 PM
so uh...i just did this whole thing with the new reccomended driver thing...the wl_apsta.o one...and it still doesnt work....not only can i not connect to my wireless network...but no wireless networks show up to connect to...none ever have...so im not that surprised...but im a bit dissapointed because that other guy with the same pc as me got this to work...what gives?

Maybe your using the 64 bit and he isnt?
thats all i can think of, maybe ask him what driver he used, or even ask him to emal you the EXACT firmware he's using as a gzip of files that you can put in place?

piracyrocks
June 4th, 2006, 09:51 PM
darn...i really wanna try out linux as my full-time OS ...but im thnkng of ditching it now just cus of this...i really dont want to have to do that.... :-(

Cenotaph
June 4th, 2006, 09:52 PM
I should note that i have put the firmware into the /lib/firmware/2.6.15-23-386 folder, not the the /lib/firmware, although it shouldnt really matter.

and i'm using 32bits version.

nickm
June 4th, 2006, 09:54 PM
I should note that i have put the firmware into the /lib/firmware/2.6.15-23-386 folder, not the the /lib/firmware, although it shouldnt really matter.

and i'm using 32bits version.


Really? i found the opposite :neutral:

piracyrocks
June 4th, 2006, 09:54 PM
even though i have an athlon amd 64 bit processor...will the 32 bits version of ubuntu run on it?...cus if thats all i need to do to get this to work i will do it by all means

piracyrocks
June 4th, 2006, 09:56 PM
whoa...i just looked at my stuff and most of my other firmware is in that folder inside firmware as well....my computer says i dont have the rights to move all the other firmware into that folder...how do i do this?...i want to try putting it in that other folder to see if it will work

do i simply just re-extract the wl_apsta.o stuff into that other folder?

Cenotaph
June 4th, 2006, 09:59 PM
yes, it would run the 32bits version. i actually have a 64bit processor myself, but im still attached to the 32bits coz of driver issues that are somewhat usual.

you can use sudo to move the files to that other folder if you wish to try it

do something like "sudo mv /lib/firmware/bcm* /lib/firmware/(whatever the folder name is)" it should be different than mine since ur using the 64bits version

piracyrocks
June 4th, 2006, 10:01 PM
what do i type to move them?...im new with linux

piracyrocks
June 4th, 2006, 10:04 PM
thanks..it moved em...im gonna reboot and see what happens....if this doesnt work i will just download the 32 bit version and run that with all of this since u got it to work that way....here goes nothing *crosses fingers*

Cenotaph
June 4th, 2006, 10:05 PM
i told ya

mv - move :)

cp - copy

sudo - lets you execute actions that need administrator privileges, you need to put your password, and this is really your pass, not the root password :)

nickm
June 4th, 2006, 10:05 PM
what do i type to move them?...im new with linux
yes, do what cenotaph is suggesting OR take a look at step 4B on the guide, i added it for you, just take note of the name of the folder you want to move them to and apply that command to your situation.

piracyrocks
June 4th, 2006, 10:11 PM
well, it looks liek im gonna be trying the 32 bit version of ubuntu....

i just downlod the x86 one, right?

piracyrocks
June 4th, 2006, 10:12 PM
well, it looks liek im gonna be trying the 32 bit version of ubuntu....

i just downlod the x86 one, right?

nickm
June 4th, 2006, 10:13 PM
well, it looks liek im gonna be trying the 32 bit version of ubuntu....

i just downlod the x86 one, right?


i386 i think it'l be called, but yes, thats the x86 one :)

Cenotaph
June 4th, 2006, 10:14 PM
:(

are you sure the module is loaded? do "lsmod | grep bcm" just to check if bcm43xx is there

and yes, you just have to download the 86 version and install like you did with the AMD64 version. no biggy.

drachir
June 4th, 2006, 10:21 PM
well, it looks liek im gonna be trying the 32 bit version of ubuntu....

i just downlod the x86 one, right?

Sorry about the delay piracyrocks, I got caught up surfing.

I have a Turion 64 but I am using the 32bit Ubuntu. I did follow nickm's guide and I did have some hills to climb but don't worry they are worth it and I feel you will get your wireless up and running. One think I did that wasn't on the guide was I set up a dymanic ip and I have wep encryption as well.

if you post after you install the 32bit version we can help you and walk you through it. Don't give up

hermesrules
June 4th, 2006, 10:41 PM
I've been using ndiswrapper for a very long time now, and was really thrilled to be able to use a native driver for my Broadcom 4306. It does work, it find the device, etc., however, connectivity is so choppy and slow. I had to resort back to ndiswrapper, which gives me excellent connectivity. I wonder if it is the drivers that need more work, or something in my configuration. I first set it using Flight 5 live cd, just to test it before I do it on my machine. Even though I have not done clean install (meaning I've been upgrading from Breezy), I am not certain that is the sole reason why connectivity sucks with the bcm43xx. Is it some other driver that needs to be enabled too, or is it choppy for everyone?

MetalMusicAddict
June 4th, 2006, 10:57 PM
Ok. Everythings works great except 1 thing (theres always a catch ;)). Everytime I reboot the connection is gone. I have to go to the "Properties" of the wireless card and as soon as I do that (I dont touch a thing but look at its properties) its up and working fine. Untill a reboot. Weird.

Heres my info:

Dell Inspiron 2200 laptop


user@pc:~$ lspci | grep Broadcom\ Corporation
0000:02:03.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)


Interfaces


# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth1
iface eth1 inet static
address 192.168.1.105
netmask 255.255.255.0
gateway 192.168.1.1

iface eth0 inet static
address 192.168.1.106
netmask 255.255.255.0
gateway 192.168.1.1



iface wlan0 inet static
address 192.168.1.105
netmask 255.255.255.0
gateway 192.168.1.1
wireless-essid ********
wireless-key ************************

auto wlan0

Id rather not use ndiswrapper but hey, it worked. :) Thanx.

crag277
June 4th, 2006, 11:32 PM
Sorry about the delay piracyrocks, I got caught up surfing.

I have a Turion 64 but I am using the 32bit Ubuntu. I did follow nickm's guide and I did have some hills to climb but don't worry they are worth it and I feel you will get your wireless up and running. One think I did that wasn't on the guide was I set up a dymanic ip and I have wep encryption as well.

if you post after you install the 32bit version we can help you and walk you through it. Don't give up

Hmmm... Looks like this is what I should do, as I have the same system. This is a bit discouraging though. I paid for a 64 bit processor and it would have been nice to finally use an OS that took advantage of that instruction set. Are there any performance differences between the two? How about power management?

drachir
June 5th, 2006, 12:26 AM
Hmmm... Looks like this is what I should do, as I have the same system. This is a bit discouraging though. I paid for a 64 bit processor and it would have been nice to finally use an OS that took advantage of that instruction set. Are there any performance differences between the two? How about power management?

The main reason for the 64 was for the next generation of computing. There isn't to many progs out there that support 64 on any platform, we even see this in linux as well as MS, but there will be a day that the support will be there and I feel I will be ready. It does suck a bit not using the computer what it is build for but such is life. I tried the ubuntu64 but it didn't work as well as the 32 performance wise.

Battery life is a whole lot better with 6.06. I have a 80g hdd with linux on a 20g partition and MS on a 50g partition and Backtrack on a 9g partition and a 1g swap. Ubuntu is showing me the best battery life with over 3 hours, ms gives me 2 hours and backtrack under 2 hours.

Cenotaph
June 5th, 2006, 01:28 AM
well, i found out that actually this native broadcom driver was too unstable so i decided to use ndiswrapper and its working great :)

so my advice is: ndiswrapper plus network manager for the win :)

jobyjoby
June 5th, 2006, 02:34 AM
so uh...i just did this whole thing with the new reccomended driver thing...the wl_apsta.o one...and it still doesnt work....not only can i not connect to my wireless network...but no wireless networks show up to connect to...none ever have...so im not that surprised...but im a bit dissapointed because that other guy with the same pc as me got this to work...what gives?
If you cannot see the networks with bcm4318, have you tried to blacklist ndiswapper as listed in a link at the end of the guide? Using that was how my networks appeared, then adding nm-applet in startup programs allowed me to connect to them.

chrishack14
June 5th, 2006, 02:57 AM
Well, after switching back to ndiswrapper, I finally got the card to come up and discover networks properly, but it cannot use WEP encryption. Anytime I try to connect to a WEP-enabled network, it fails to connect and a message shows up in dmesg that says:

ndiswrapper (add_wep_key:848): adding encryption key 1 failed (C0010015)

Did anyone else have this problem? By the way, I am using the AMD64 version of Kubuntu, I have a Broadcom 4306 card, and I have tried wlassistant and wifi-radar. Any ideas?

SuicideInvoice
June 5th, 2006, 04:21 AM
I see now it's updated with different drivers. It's working fine for me using the .sys file from the CD. Even works in rfmode in Kismet. The only thing that doesn't work right is the signal strength. Do the newer drivers fix that? If not, i'm staying where im at.

Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 03)

crag277
June 5th, 2006, 04:46 AM
Different Ubuntu, same result.

It just seems like these 4318 chipsets do not want to work.

I originally tried to make it work using the 64-bit version of Kubuntu Dapper. The very first time I scanend for networks there I saw all the availible networks, but could not connect. Then after that first scan it was never able to find a network again.

Now after reading every post here I've installed 32-bit Ubuntu and went through the guide again, except using the driver posted by Slicedbread in post 55. http://ubuntuforums.org/showpost.php?p=1085392&postcount=55
I picked this driver because I have a Compaq V2000 with AMD and ATI, just like Slicedbread.

There were no problems or errors during the process, and after reboot network manager loaded properly, but did not immediately connect to a wireless network. As was the problem before it did not see any networks. I then installed WiFi Radar. Again, no networks found, but when I manually entered the SSID for my network it showed up on the list with a full signal. However when I tried to connect it got no farther than trying to aquire an IP address.

Hopefully someone can make these 4318s work!

Is there any way to undo this process? I'd like to try it again using the driver specified by the author, but it's quite annoying to have to re-install the OS every time.

piracyrocks
June 5th, 2006, 05:41 AM
i installed the 32 bit version and did the whole guide and i even blacklisted ndiswrapper and i still have no go on seeing or connecting to any wireless networks...any help would be appreciated

n00bWillingToLearn
June 5th, 2006, 06:04 AM
I tried this, and now I can't really do anything. Upon boot (from both the HD AND a LiveCD), I get 3 errors. After closing them all, all I have is a dark brown/red background with a cursor - all I can do is move the cursor around.

In chronological order:
There was a problem registering the panel with the bonobo-activation server. The error code is: 3. The panel will now exit.

There was an error starting the GNOME Settings Daemon. Some things, such as sound, themes, or background settings may not work correctly. The Settings Daemon restarted too many times. The last error message was: System Exception: IDL:omg.org/CORBA/COMM_FAILURE:1.0 GNOME will still try to restart the settings daemon the next time you log in.

Nautilus can't be used now, due to an unexpected error. (Under the Show More Details arrow is the following) Nautilus can't be used now, due to an unexpected error from Bonobo when attempting to register the file manager view server.

Three questions:
1) What, exactly, is the issue?
2) What did I do wrong, and is there anything I can do to correct it w/o reinstalling?
3) If I must reinstall, how can I do this if I can't boot from a LiveCD?

I'm on a Powerbook G3 Lombard. The only thing I did different was that I installed Network Manager BEFORE I installed the card firmware. My "Airport card" is a PCMCIA wireless card w/ Broadcom chipset - it was previously recognized by OS X as an AirPort card.

I had a similar problem when I screwed up java, but what this has to do with wireless I don't know, so this is just a hunch but try just running the java command with no arguments ie: press ctrl + alt + F1 **this will bring you to a black terminal screen to get out of it press ctrl + alt + F7**
then type :code: java :code: and if it gives you an error like " cant find file libjvm.so" then you are having the same problem I had and I may be able to help if not then I don't know what is happening, sorry.

Slicedbread
June 5th, 2006, 06:20 AM
i installed the 32 bit version and did the whole guide and i even blacklisted ndiswrapper and i still have no go on seeing or connecting to any wireless networks...any help would be appreciated

I was having the same problem. I was able to get the driver to install with the newly linked one and the Wifi light was lit but was still getting the invalid ap error. In addition, whenever i tried to scan for networks, it would not display any results. I noticed that my router's wifi light would flash when starting up but not when trying to connect so I determined it was a user setting, heres how I got it to work on my BCM 4318 chipset:

1. I removed bcm43xx-fwcutter package
2. Removed gnome network manager and network manager packages
3. Deleted all broadcom files (bcm43xx_***) in /lib/firmware
4. Commented out all connections accept lo in /etc/network/interfaces
5. Blacklisted ndiswrapper
6. Restarted
7. Followed the guide in the 1st post using the new wl_apsta.o (http://drinus.net/airport/wl_apsta.o) driver.

I know it seems like it should work with out having to delete the files but, I was still getting the invalid ap bug wihen I didn't delete the files. Now I dont get the microdell error or invalid ap bug. It was not also discovering the networks without commenting (#) the interfaces file. If your wifi light is not when you restart during step 6, then you know you have removed the driver and are good to start over.

rko618
June 5th, 2006, 06:54 AM
how is the wl_apsta.o driver better?

also if I did the guide with bcmwl5 should I go back and redo it with wl_apsta.o? Will I see a performance boost?

PPower
June 5th, 2006, 07:03 AM
how is the wl_apsta.o driver better?

also if I did the guide with bcmwl5 should I go back and redo it with wl_apsta.o? Will I see a performance boost?

According to the developers of the bcm43xx module they say this is the most up to date driver avaliable. They also they when Ubuntu upgrade to a 2.6.17+ kernel you should use this driver as it will fix the invalid ap errors (thus eliminating the need for network-manager).

dtlinker
June 5th, 2006, 07:03 AM
I wanted to report my results with one of the "Airforce One 54g" in a Dell Inspiron B130, and Dapper in a new install.

I had already tried and failed with the native drivers, and was using ndiswrapper.

I tried blacklisting ndiswrapper, removing all bcm43xx firmware from the /lib/firmware directory and the subdirectory, and then following the instructions with the wl_apsta.o driver.

When I rebooted, I checked dmesg, and the firmware appeared to be installed, but I was unable to connect.

I then deleted all of the bcm43xx files, and re-installed using the BCMWL5.SYS file from the windows installation, rebooted, and although the driver appeared to be installed, I was still unable to connect.

Finally, I blacklisted bcm43xx, unblacklisted ndiswrapper, and rebooted, and everything works again.

Another vote saying that the Airforce One 54g driver doesn't always work!

Slicedbread
June 5th, 2006, 07:15 AM
Did you comment out the /etc/network/interfaces file and did your wife button light up? It does seem that it is kind of touch and go with this driver but if it only depends on the wireless chipset then everyone should be able to use one solution right?

nickm
June 5th, 2006, 09:52 AM
I've been using ndiswrapper for a very long time now, and was really thrilled to be able to use a native driver for my Broadcom 4306. It does work, it find the device, etc., however, connectivity is so choppy and slow. I had to resort back to ndiswrapper, which gives me excellent connectivity. I wonder if it is the drivers that need more work, or something in my configuration. I first set it using Flight 5 live cd, just to test it before I do it on my machine. Even though I have not done clean install (meaning I've been upgrading from Breezy), I am not certain that is the sole reason why connectivity sucks with the bcm43xx. Is it some other driver that needs to be enabled too, or is it choppy for everyone?
It seems fine for me on that card, it must be your configuration or building/location etc

stromb
June 5th, 2006, 10:41 AM
This worked great with my Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02) card.

What system do you have? I have an HP dv5000v laptop. I've tried everything in this post and still can't get this card to work. Any other suggestions?

Thanks!

MetalMusicAddict
June 5th, 2006, 12:04 PM
I dont need to "blacklist ndiswrapper" if I did a clean install then only used this guide right?

Is there anyone that can help with the info I posted a couple of posts above? Should I just use ndiswrapper or would it be a problem after using this guide?

slakkie
June 5th, 2006, 12:35 PM
Thanks for the HOWTO, got the wireless up pretty quick (without encryption).
Got it working without encryption and with encryption (WPA).
I'm using the gnome-network manager, which is described in the HOWTO. And I'm using wpasupplicant in order to get it working with WPA.

Failover from Wired to wireless isn't that good (non existent tbh)... Hopefully I will get this working somewhere this week(end).

Got my system up and running without the need of network managers.
The failover doesn't work automaticly, but its scripted so it became really easy to change from Wireless to Wired.

nickm: Don't know if you have already done this, but I created a simple install script which will do everything which is described in this HOWTO. The script can also include installing a network manager (I have disabled this for my setup).
It can also remove the installation, so you can start all over again if you want to :)

Automated install:
http://www.euronet.nl/users/wesleys/ubuntu/installWireless.zsh

Switching from Wired to Wireless and vice versa:
http://www.euronet.nl/users/wesleys/ubuntu/enableNW.zsh

Hope this will help some of you guys.

Dr Von Bon Bon
June 5th, 2006, 01:26 PM
Hi,


I can't seem to install bcm43xx thingy.

Whenever I put it up in the terminal or synaptic it can't find the file.

I think I have all the universes enabled.

chronusdark
June 5th, 2006, 02:16 PM
ok so earlier i posted that


sudo iwconfig eth1 rate 54M

will set my wlan into wireless G mode is there any way i can set it to do this on restart because when i reboot its back into B

if i get this figured out it should be added to the howto like a post script or something

charles woodward
June 5th, 2006, 02:48 PM
Worked like a dream - I've been struggling to get it all to work for about two months - I could get it to work but couldn't get wep encryption to work. Now it does using Network Manager.

The encryption didn't work straight away, but I had read a bug that it would not work in shared mode (which the network in question used) - so I got the network to change to `open` and it worked. XP computers (can't get the family to change) don't seem to mind if it is open, shared or what.

Anyway thanks

toorima
June 5th, 2006, 03:13 PM
ok so earlier i posted that


sudo iwconfig eth1 rate 54M

will set my wlan into wireless G mode is there any way i can set it to do this on restart because when i reboot its back into B

if i get this figured out it should be added to the howto like a post script or something

Add iwconfig eth1 rate 54M to /etc/init.d/rc.local

rowanq
June 5th, 2006, 03:37 PM
Worked like a dream - I've been struggling to get it all to work for about two months - I could get it to work but couldn't get wep encryption to work. Now it does using Network Manager.

The encryption didn't work straight away, but I had read a bug that it would not work in shared mode (which the network in question used) - so I got the network to change to `open` and it worked. XP computers (can't get the family to change) don't seem to mind if it is open, shared or what.

Anyway thanks

Right on!,
I've been at this on and off for the last few days and I've had no success. I got every thing to install, Network Manager would show up list and my encrypted network but the connection would always fail.
I tried various iterations of this guide (the new drivers wl_apsta.o, the drivers that came on my install cd, and the bcmwl5sys.zip download) all with the same result.
So after reading your post I went in to my Linksys router config page and set the Authentication Type to Auto and tried again. It worked like a charm! Not only that, but I can see one other WLAN that I knew was in my neighborhood but wasn't showing up for some reason.
Thanks for the tip Charles. And a big thanks to nickm, your guide was much needed!:D

RowanQ

piracyrocks
June 5th, 2006, 04:09 PM
if anyone is reading this thread that has gotten there bcm4318 to work could you please post exactly what you did to get it to work? im at a loss here

axiomata
June 5th, 2006, 04:25 PM
I'm having mixed results here. I've got that famous AirForce linksys card and at first, after following this guide it worked nicely. But now, most of the time when I reboot I get no connection. The network manager says "connecting to my LAN" but it never fully does. Sometimes it will default to the disabled wired connection and sometimes it will appear to connect, signal strength bars shown with 100% but it doesn't work. Then seemingly randomly, on a later boot it will connect.

Slicedbread
June 5th, 2006, 04:42 PM
if anyone is reading this thread that has gotten there bcm4318 to work could you please post exactly what you did to get it to work? im at a loss here

If you get on AIM i can help, mine is slicedbread87.

PPower
June 5th, 2006, 05:12 PM
For the benefit of people without internet connections on wired I have made a floppy image containing the core essencials needed to get connected to the internet plus an ODT of the guide (plus a ultra quick 4 step one). This does not include network-manager due to space limitations with all the dependencies. It also contains a 1 line script to install the firmware but I never tested it. It contains the wl_apsta.o file. The download is about 300kb and once extracted it inflates to about 660kb.

Enjoy!

What you get in the floppy:
1 copy of the guide on ODT.
1 quick install guide.
1 wl_apsta.o
1 copy of the bcm43xx-fwcutter deb
1 experimental install script for the firmware
1 readme.

This is a tar.gz containing the required files. It is not a image to dd so just copy the files to a floppy

chronusdark
June 5th, 2006, 08:42 PM
Add iwconfig eth1 rate 54M to /etc/init.d/rc.local

do i just add it to the end of the file?

dmarook
June 5th, 2006, 09:02 PM
nickm: Don't know if you have already done this, but I created a simple install script which will do everything which is described in this HOWTO. The script can also include installing a network manager (I have disabled this for my setup).
It can also remove the installation, so you can start all over again if you want to :)

Automated install:
http://www.euronet.nl/users/wesleys/ubuntu/installWireless.zsh

Switching from Wired to Wireless and vice versa:
http://www.euronet.nl/users/wesleys/ubuntu/enableNW.zsh

Hope this will help some of you guys.

Would you kindly help out a noob? How can I run the sript in UBUNTU? And what should I do to add in network manager? Thanks.

toorima
June 5th, 2006, 09:15 PM
do i just add it to the end of the file?

yeah and after you have a connection check with command iwconfig to see that it worked, if you don't get it to connect with 54M try with 36M, that worked for me

Kawayanan
June 5th, 2006, 09:26 PM
if anyone is reading this thread that has gotten there bcm4318 to work could you please post exactly what you did to get it to work? im at a loss here

If you get on AIM i can help, mine is slicedbread87.

If you guys get do your bcm4318 to work please post what you learn. I am still fighting with mine. I have tried many different suggestions here with fresh installs, but have yet to get it consistantly working. I may give ndiswrapper a try.

Kawayanan

piracyrocks
June 5th, 2006, 09:36 PM
i havent gotten it to work yet

im going to be trying ndiswrapper pretty soon after another fresh install of 6.06

nickm
June 5th, 2006, 09:42 PM
yeah and after you have a connection check with command iwconfig to see that it worked, if you don't get it to connect with 54M try with 36M, that worked for me

Isnt the config files that iwconfig writes and reads totally unused? i think so.
so this wont make any difference to anything that uses networkmanager?

nickm
June 5th, 2006, 09:45 PM
oops

slakkie
June 5th, 2006, 10:14 PM
Would you kindly help out a noob? How can I run the sript in UBUNTU? And what should I do to add in network manager? Thanks.

Hi,

I would advise u to use only the first script. You can use the second, but I saw some HOWTO's on setting up WPA with network-managers.

This is what you need to do (terminal only and non-root user):

0) mkdir ~/tmp ; cd ~/tmp
1) wget "http://www.euronet.nl/users/wesleys/ubuntu/installWireless.zsh"
2) chmod 755 installWireless.zsh
3) get the correct dirvers, see opening post of this thread
4) Uncomment the following lines by running this:


perl -p -i -e 's/^ \#(RemovePackage|installNWmanager)/ $1/' installWireless.zsh or do it yourself with your favorite editor:


#installNWmanager

#RemovePackage $NWMANAGER


Should look like this now:



installNWmanager

RemovePackage $NWMANAGER


Now you will be installing 'network-manager-gnome', if you want a different one, change the following line somewhere in the beginning of the script.


NWMANAGER=network-manager-gnome


5) ./installWireless install <location of driver>

You can undo all your actions by entering ./installWireless remove

You will get some examples by only running ./installWireless.

For the network manager I want to point you to this HOWTO:
http://ubuntuforums.org/showthread.php?t=125150

As I'm doing this differently (script #2 - enableNW.zsh), I can't help you with this.

Good luck!

toorima
June 5th, 2006, 11:35 PM
Isnt the config files that iwconfig writes and reads totally unused? i think so.
so this wont make any difference to anything that uses networkmanager?

I'm not sure but when it boots with iwconfig eth1 rate 56M network manager can't connect and iwconfig shows rate 54M, when I try to connect again it connects but iwconfig shows 11M, setting it to 36M network manager connects and iwconfig shows 36M and my wireless performs better then it is when I have it at 11M so you tell me

piracyrocks
June 5th, 2006, 11:40 PM
ok, anyone with the bcm4318 wireless card, below i will be telling you the absolute 100% gaurenteed way of getting it to work with 6.06 ubuntu:

go to this website, http://www.beginningubuntu.com/dapper_tips.html , and follow the guide for setting up the wireless card with ndiswrapper. (right now this website is down due to traffic hieghts but u can still get to it if u do a google search for it and view the cached version)

if your router uses a wep encryption, u have to install network manager in order to use it. the default wireless thingy wont work with wep.

there you go, ure done...it works....oh god im so glad it worked


:-)

KiLLeR_WoMBaT
June 5th, 2006, 11:42 PM
Add iwconfig eth1 rate 54M to /etc/init.d/rc.local


Where in that file/script do I add it? (total noob on this issue).](*,)

dmarook
June 6th, 2006, 12:05 AM
Hi,

I would advise u to use only the first script. You can use the second, but I saw some HOWTO's on setting up WPA with network-managers.

This is what you need to do (terminal only and non-root user):

0) mkdir ~/tmp ; cd ~/tmp
1) wget "http://www.euronet.nl/users/wesleys/ubuntu/installWireless.zsh"
2) chmod 755 installWireless.zsh
3) get the correct dirvers, see opening post of this thread
4) Uncomment the following lines by running this:


perl -p -i -e 's/^ \#(RemovePackage|installNWmanager)/ $1/' installWireless.zsh or do it yourself with your favorite editor:


#installNWmanager

#RemovePackage $NWMANAGER


Should look like this now:



installNWmanager

RemovePackage $NWMANAGER


Now you will be installing 'network-manager-gnome', if you want a different one, change the following line somewhere in the beginning of the script.


NWMANAGER=network-manager-gnome


5) ./installWireless install <location of driver>

You can undo all your actions by entering ./installWireless remove

You will get some examples by only running ./installWireless.

For the network manager I want to point you to this HOWTO:
http://ubuntuforums.org/showthread.php?t=125150

As I'm doing this differently (script #2 - enableNW.zsh), I can't help you with this.

Good luck!

Thank you for your prompt response. I did as you instructed but get an error saying:

bash: ./installWireless.zsh: /bin/zsh: bad interpreter: No such file or directory

the driver file is on my desktop. Should I put it in a specific directory? Another thing, what would be the usual path to a file on the desktop? would it be ~/Desktop/wl_apsta.o? Thanks again.

toorima
June 6th, 2006, 01:13 AM
Where in that file/script do I add it? (total noob on this issue).](*,)

Just add it at the end of the file

Oni-Dracula
June 6th, 2006, 01:35 AM
I followed the instructions to the letter. (With the exception of a clean install).

Nothing seems to be working.... when I modprobe bcm43xx, I get module not found.

What am I doing wrong? ](*,)

zahidism
June 6th, 2006, 03:52 AM
how do i make my bcm4306 use full power?

solarwind
June 6th, 2006, 05:35 AM
How about if my router needs WPA-PSK authentication? Nice howto by the way, this is excellent for noobs. I should make something like this sometime. But it it were me, I would have used ndiswrapper... Whatever happned to that? Anyway, how do I get WPA-PSK support in Ubuntu Dapper? Thanks!

slakkie
June 6th, 2006, 07:43 AM
Thank you for your prompt response. I did as you instructed but get an error saying:

bash: ./installWireless.zsh: /bin/zsh: bad interpreter: No such file or directory

the driver file is on my desktop. Should I put it in a specific directory? Another thing, what would be the usual path to a file on the desktop? would it be ~/Desktop/wl_apsta.o? Thanks again.

This could mean you don't have zsh installed, run the following command:
sudo apt-get install zsh

And your desktop can be found at the location you mentioned: ~/Desktop

slakkie
June 6th, 2006, 08:10 AM
How about if my router needs WPA-PSK authentication? Nice howto by the way, this is excellent for noobs. I should make something like this sometime. But it it were me, I would have used ndiswrapper... Whatever happned to that? Anyway, how do I get WPA-PSK support in Ubuntu Dapper? Thanks!

I got it working with wpasupplicant:

1) Install supplicant
2) Edit the file /etc/wpa_supplicant.conf

MIne looks like this:




# Minimal /etc/wpa_supplicant.conf to associate with open
# access points. Please see
# /usr/share/doc/wpasupplicant/wpa_supplicant.conf.gz for more complete
# configuration parameters.

# http://www.vollink.com/gary/deb_wifi.html

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0

eapol_version=1
ap_scan=1
fast_reauth=1

### Associate with any open access point
### Scans/ESSID changes can be done with wpa_cli
network={
ssid=""
key_mgmt=NONE
priority=1
}

## Home WPS - TPIK
network={
ssid="wnl.opperschaap.net"
proto=WPA
key_mgmt=WPA-PSK
pairwise=TKIP
psk='cryptedKey'
priority=5
}



You can generate the network = { } section by using wpa_passphrase.
Make sure that your ESSID is the same as you want to connect to, I tried creating a key with a fake ESSID and I couldn't connect due to mismatching keys, turns out WPA used the ESSID to create the key..



Source: http://en.wikipedia.org/wiki/Wi-Fi_Protected_Access
Security in pre-shared key mode

Pre-shared key mode (PSK, also known as personal mode) is designed for home and small office networks that cannot afford the cost and complexity of an 802.1X authentication server. Each user must enter a passphrase to access the network. The passphrase may be from eight to 63 ASCII characters or 64 hexadecimal digits (256 bits). If you choose to use the ASCII characters, a hash function reduces it from 504 bits (63 characters * 8 bits/character) to 256 bits (using also the SSID). The passphrase may be stored on the user's computer at their discretion under most operating systems to avoid re-entry. The passphrase must remain stored in the Wi-Fi access point.


But enough background info, now the command you need to create your key :)



8:47 wesleys@nomad [/home/wesleys/bin] # wpa_passphrase wnl.opperschaap.net
# reading passphrase from stdin
TEst12345678
network={
ssid="wnl.opperschaap.net"
#psk="TEst12345678"
psk=0e17eb2e34b5e7292cf0a56c0cb44c4fe40ae0dcf61130 686512e40b2b926000
}


3) Edit the following file: /etc/default/wpasupplicant
Set the options, and set the ENABLE flag to 1

Now try running it:


wpa_supplicant -w -ddd -i $WLAN_INTERFACE -D wext -c /etc/wpa_supplicant.conf


What can help you is iwevent, this will show you events from your wireless interface, which can come in handy when debugging.

When you started up wpa_supplicant, try dhclient, or if you have defined a static IP start checking wheter you have a connection with your AP.

For more info:
https://wiki.ubuntu.com/WPAHowto

Which is the guide that I followed.

Good luck.

nickm
June 6th, 2006, 09:03 AM
how do i make my bcm4306 use full power?

You cant really, but it wont effect you unless you were working with large files or had an interenet connection greater than 11mb/s.
If you want to work with large files then i suggest not using wireless at all and just go with a nice 100/1000 mb/s wired network.

toorima
June 6th, 2006, 09:54 AM
How about if my router needs WPA-PSK authentication? Nice howto by the way, this is excellent for noobs. I should make something like this sometime. But it it were me, I would have used ndiswrapper... Whatever happned to that? Anyway, how do I get WPA-PSK support in Ubuntu Dapper? Thanks!

Create /etc/default/wpasupplicant and put ENABLED=0 in it and network manager will show wpa-psk network, that was all i had to do.

eternalsunshine
June 6th, 2006, 10:38 AM
I tried to do everything but i couldn't manage to receive wireless access from my university's ap. I don't have windows installed in my computer only dapper drake.I am using hp compaq nx9030 laptop.iwconfig eth1 gives this message:

eth1 radio off ESSID:off/any
Mode:Managed Channel:0 Access Point: Not-Associated
Bit Rate=0 kb/s Tx-Power=off Sensitivity=8/0
Retry limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Because i think i can't put the wireless light on ubuntu does not see the button...

tomtomgg
June 6th, 2006, 11:06 AM
Cheers! Although network-manager does not report on any activity, the wireless connection works perfectly. I'm also running a Broadcom BCM4318; so you win at life.

dmarook
June 6th, 2006, 11:18 AM
Well, got my Belkin F5D7011 Notebook wireless network card (BCM 4306 chip) going with the help of nice people like nickm (Thanks for this killer guide=D> ) , slakkie and toorima. I can now connect on startup to my home wireless network with WPA-AEP encription. A big thanks to all the posters of this thread.

I just followed the guide. The encription has been handled quite nicely by the Network-Manager without any fiddling from my part. IWCONFIG says my connection speed is 54M (Thanks toorima) though I don't know how I can test the actual speed.

One thing I still have to sort out is that the Network-Manager cant seem to find my Router if the ESSID is not being broadcast. I am not really keen to keep broadcasting my ESSID all the time. Anyone can advice me on this matter? Is it a specific problem with Network-Manager?

I am only a week old in the world of UBUNTU and any Linux for that matter. So I am yet to discover all the gems hidden inside this brilliant new OS I have stumbled upon. Now that my wireless connection is 95% sorted (apart from the ESSID issue as above) I can spend some quality time with my Laptop exploring this strange new world. :D

maddbaron
June 6th, 2006, 03:39 PM
i tried this and got this? anything i can do that doesn't involve buying an external card?

ubuntu@ubuntu:~$ lspci | grep Broadcom\ Corporation
0000:00:0b.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)
ubuntu@ubuntu:~$ sudo apt-get install bcm43xx-fwcutter
Reading package lists... Done
Building dependency tree... Done
The following NEW packages will be installed:
bcm43xx-fwcutter
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 16.6kB of archives.
After unpacking 102kB of additional disk space will be used.
Get:1 http://archive.ubuntu.com dapper/universe bcm43xx-fwcutter 20060108-6build1 [16.6kB]
Fetched 16.6kB in 0s (28.9kB/s)
Preconfiguring packages ...
Selecting previously deselected package bcm43xx-fwcutter.
(Reading database ... 75854 files and directories currently installed.)
Unpacking bcm43xx-fwcutter (from .../bcm43xx-fwcutter_20060108-6build1_i386.deb) ...
Setting up bcm43xx-fwcutter (20060108-6build1) ...

ubuntu@ubuntu:~$ sudo apt-get install network-manager-gnome
Reading package lists... Done
Building dependency tree... Done
The following extra packages will be installed:
dhcdbd libnl1-pre6 libnm-util0 network-manager
The following NEW packages will be installed:
dhcdbd libnl1-pre6 libnm-util0 network-manager network-manager-gnome
0 upgraded, 5 newly installed, 0 to remove and 0 not upgraded.
Need to get 704kB of archives.
After unpacking 2748kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://archive.ubuntu.com dapper/main dhcdbd 1.10-0ubuntu11 [42.8kB]
Get:2 http://archive.ubuntu.com dapper/main libnl1-pre6 1.0~pre5+svn21-2ubuntu2 [76.5kB]
Get:3 http://archive.ubuntu.com dapper/main libnm-util0 0.6.2-0ubuntu7 [116kB]
Get:4 http://archive.ubuntu.com dapper/main network-manager 0.6.2-0ubuntu7 [228kB]
Get:5 http://archive.ubuntu.com dapper/main network-manager-gnome 0.6.2-0ubuntu7 [241kB]
Fetched 704kB in 8s (86.0kB/s)
Selecting previously deselected package dhcdbd.
(Reading database ... 75862 files and directories currently installed.)
Unpacking dhcdbd (from .../dhcdbd_1.10-0ubuntu11_i386.deb) ...
Selecting previously deselected package libnl1-pre6.
Unpacking libnl1-pre6 (from .../libnl1-pre6_1.0~pre5+svn21-2ubuntu2_i386.deb) ...
Selecting previously deselected package libnm-util0.
Unpacking libnm-util0 (from .../libnm-util0_0.6.2-0ubuntu7_i386.deb) ...
Selecting previously deselected package network-manager.
Unpacking network-manager (from .../network-manager_0.6.2-0ubuntu7_i386.deb) ...Selecting previously deselected package network-manager-gnome.
Unpacking network-manager-gnome (from .../network-manager-gnome_0.6.2-0ubuntu7_i386.deb) ...
Setting up dhcdbd (1.10-0ubuntu11) ...
* Reloading system message bus config [ ok ]
* Stopping DHCP client manager... [fail]
* Starting DHCP client manager... [ ok ]

Setting up libnl1-pre6 (1.0~pre5+svn21-2ubuntu2) ...

Setting up libnm-util0 (0.6.2-0ubuntu7) ...
Setting up network-manager (0.6.2-0ubuntu7) ...
* Reloading system message bus config [ ok ]
* Stopping NetworkManager daemon [ ok ]
* Starting NetworkManager daemon [ ok ]
* Stopping NetworkManager dispatcher [ ok ]
* Starting NetworkManager dispatcher [ ok ]

Setting up network-manager-gnome (0.6.2-0ubuntu7) ...
find: WARNING: Hard link count is wrong for .: this may be a bug in your filesystem driver. Automatically turning on find's -noleaf option. Earlier results may have failed to include directories that should have been searched.
find: WARNING: Hard link count is wrong for .: this may be a bug in your filesystem driver. Automatically turning on find's -noleaf option. Earlier results may have failed to include directories that should have been searched.

Gurgeh
June 6th, 2006, 04:04 PM
That was spot on - I really cannot express how clear and simple the instructions are - it did help that i'm using exactly the same card as you. I bow to your greatness mate.

Thanks again.

joergenlie
June 6th, 2006, 06:28 PM
Now I've been playing around for two days. Still my problem is that my card will not connect at boot up, but now I have found that the only thing needed is to run
sudo iwconfig eth0 ap any

and

/etc/init.d/networking restart

the wiki page about the subject suggests that I add iwconfig eth0 ap any to /network/interfaces

Still this doesnt do it. Is there anywhere else I can put these commands to make it connect at boot up? Or is there a special way or place to put them in the interfaces file?

ANother thing ,when i run iwconfig it says bitrate 11mbps, but in iwlist scan it says 54 mbps? Whats the difference?

JØrgen

RyanR313
June 6th, 2006, 07:20 PM
This was the easiest most straight forward instructions I have found in the linux world. OK so that may be hyperbole but WOW! It took five minutes for me to set this up and I am up and running.
Thanks

nickm
June 6th, 2006, 07:24 PM
not to blow my own trumpet, but i just used my guide with a fresh install of ubuntu and it works!! =D>

:roll:

I was wondering if someone can help me though, on step 4b the user is going to have to find out what kernel they have etc, is there a command to do this, but just list the numbers so i could change it from
sudo bcm43xx-fwcutter -w /lib/firmware/2.6.15-23-386 ~/Desktop/wl_apsta.o
to
sudo bcm43xx-fwcutter -w /lib/firmware/`command' ~/Desktop/wl_apsta.o ?

PPower
June 6th, 2006, 08:04 PM
not to blow my own trumpet, but i just used my guide with a fresh install of ubuntu and it works!! =D>

:roll:

I was wondering if someone can help me though, on step 4b the user is going to have to find out what kernel they have etc, is there a command to do this, but just list the numbers so i could change it from
sudo bcm43xx-fwcutter -w /lib/firmware/2.6.15-23-386 ~/Desktop/wl_apsta.o
to
sudo bcm43xx-fwcutter -w /lib/firmware/`command' ~/Desktop/wl_apsta.o ?
it would be uname -r i think but you dont need to put it in a specific folder on /lib/firmware. just dump it in /lib/firmware.

nickm
June 6th, 2006, 08:06 PM
it would be uname -r i think but you dont need to put it in a specific folder on /lib/firmware. just dump it in /lib/firmware.

well some people were finding that they had to, so i dont know if it makes a difference or not.

Thanks anyway, ill try it out :)

joergenlie
June 6th, 2006, 08:16 PM
Now I've been playing around for two days. Still my problem is that my card will not connect at boot up, but now I have found that the only thing needed is to run
sudo iwconfig eth0 ap any

and

/etc/init.d/networking restart

the wiki page about the subject suggests that I add iwconfig eth0 ap any to /network/interfaces

Still this doesnt do it. Is there anywhere else I can put these commands to make it connect at boot up? Or is there a special way or place to put them in the interfaces file?

ANother thing ,when i run iwconfig it says bitrate 11mbps, but in iwlist scan it says 54 mbps? Whats the difference?

JØrgen

Sing HALLELUJAH!!! I went through the howto over again and now my broadcom 4306 works like silk:mrgreen:

Thank you very much!

Jørgen

PPower
June 6th, 2006, 08:17 PM
well some people were finding that they had to, so i dont know if it makes a difference or not.

Thanks anyway, ill try it out :)

It works fine for me in /lib/firmware. The problem with sticking it in a kernel dir is that you have to reinstall it every time the kernel is updated. Thanks for adding the wl_apsta.o. It will come in handy when Ubuntu upgrade to 2.6.17 or later.

nickm
June 6th, 2006, 08:24 PM
It works fine for me in /lib/firmware. The problem with sticking it in a kernel dir is that you have to reinstall it every time the kernel is updated. Thanks for adding the wl_apsta.o. It will come in handy when Ubuntu upgrade to 2.6.17 or later.

its okay, im using it now and its fine with the current kernel too.

helfire
June 6th, 2006, 09:44 PM
After i go through the guide i can see AP's and connect to them (i get an IP and gw/dns) but i cannot get connectivity. Anyone else had this problem? I cant ping my DNS ip's or anything. I'm hopeing this is just a configuration issue. Did this on a fresh install.

xxrealmsxx
June 6th, 2006, 09:49 PM
It works, finally!

Thanks, this thread alone made me partition a hdd for mostly linux use for the first time.

Is there a command to start the wireless nic?

When I leave my house if I hibernate while im on wired network and I get on campus I have to restart the laptop to connect to the wireless network, any easy way around that?

solarwind
June 6th, 2006, 11:01 PM
Yeah, this is great, but what about ndiswrapper and the bcmwl5.inf and bcmwl5.sys files? Does this method have an advantage over the ndiswrapper method?

TheAngryPenguin
June 7th, 2006, 02:17 AM
It didn't work for me. I have a Dell Latitude D400 with a "0000:01:03.0 Network controller: Broadcom Corporation BCM4309 802.11a/b/g (rev 02)" wireless card. I tried with the files from the first post as well as with a .sys that's known to work well with ndiswrapper. In all cases, I've ended up with a kernel panic right as the wireless card became active. To anyone else with this particular flavor of Broadcom, here's what I've done to get it to work (and I won't go that much into detail since most of this is documented very well elsewhere...):

1) Install ndiswrapper-utils

2) Download the TrueMobile 1400 (BCM4309 - 802.11a+b+g) (http://ftp.us.dell.com/network/R63259.EXE) driver package from Linuxant's site (http://www.linuxant.com/driverloader/drivers.php).

3) Rename R63259.EXE to R63259.EXE.ZIP and open with Archive Manager -- extract bcmwl5.inf and bcmwl5.sys from /TMSetup

4) Do the ndiswrapper voodoo with the file(s) above.

5) Blacklist bcm43xx

6) Add ndiswrapper to /etc/modules

7) Reboot

Now, if I could only get NetworkManager to work with ndiswrapper...

Kawayanan
June 7th, 2006, 02:58 AM
ok, anyone with the bcm4318 wireless card, below i will be telling you the absolute 100% gaurenteed way of getting it to work with 6.06 ubuntu:

go to this website, http://www.beginningubuntu.com/dapper_tips.html , and follow the guide for setting up the wireless card with ndiswrapper. (right now this website is down due to traffic hieghts but u can still get to it if u do a google search for it and view the cached version)

if your router uses a wep encryption, u have to install network manager in order to use it. the default wireless thingy wont work with wep.

there you go, ure done...it works....oh god im so glad it worked


:-)

Ok, after trying lots and lots of stuff (and many fresh installs) to get my bcm4318 working, ndiswrapper worked like a charm.

The website above was great (also has a bunch of other nice tips too). The ndiswrapper install and setup was just as easy as the howto here for the bcm43xx driver, and for the 4318 at least, it works great. As piracyrocks said, the website seems to be down (over bandwidth maybe?). As said above, just search google for the url and use the google cache. I would also suggest checking out the ndiswrapper install wiki (http://ndiswrapper.sourceforge.net/mediawiki/index.php/Installation). They have some nice info if you have more questions. They also suggest what to look for in the system logs for a sucessful install. After installing ndiswrapper, I installed network-manager-gnome and it worked with wep on the first try (using it right now :) ).

Thanks again to everyone here for their help and suggestions, and thank you nickm for all your work on this howto. You might think about putting something in it for 4318 owners as many seem to be having problem getting connected with the bcm43xx driver. ndiswrapper may work better for them.

Kawayanan

nickdr
June 7th, 2006, 03:13 AM
wow nickm i freaking love you. i tried so much to get my wireless card working in ubuntu, starting with breezy. i tried ndis-wrapper and anything else i found that sounded remotely helpful. i was actually ready to give up on linux, when i saw this link on digg.com and i decided to give it one last try.
you're a lifesaver

big_gie
June 7th, 2006, 04:49 AM
I'm having trouble using NetworkManager. It works ok with cable, but wireless is a no-go.

I have a Dell Inspiron 8500 with a Broadcom 4306 wifi card using bcm43xx.

Attached is the log of "NetworkManager --no-daemon"

It get stock to line 141 for 60 seconds it seems, then time out with "Activation (eth1/wireless): association took too long (>60s), failing activation."

Anyone have an idea???

Thanx

smylie
June 7th, 2006, 05:20 AM
C

When Ubuntu upgrade to a new kernel (and thus a new version of the bcm module) you MUST NOT use the driver supplied on this thread.

i've had to upgrade kernel to fix acpi issues, and thus need to recompile the bcm module. However, I can't (embarrasingly enough) find the source.
The http://bcm43xx.berlios.de/ page states that it will be included in the 2.6.17 kernel, but seem to have removed the link to download the module from the page already. You can get the firmware cutter from their svn repository, but that's about it.
The documentation merely states that you can download the module from the site.

I've patched my kernel up to 2.6.17-rc6, but although the bcm43xx files are now there in drivers/net/wireless/bcm43xx, i can't find the option to include it in menconfig.

Any one know where I can download the seperate source for this module, or how to force it to build as part of the 2.6.17 kernel?

smylie

crag277
June 7th, 2006, 06:20 AM
First of all, thanks to all the posts on these forums I'm posting from a wireless connection, and I have a Broadcom 4318 "AirForce One 54g".

Here's how I did it, maybe it'll help someone. You don't even need an internet connection.

The drivers I used are attached to the message. To follow this guide to a T downlad them and place in a folder bcm43xx on your desktop.

I've tried the procedure in this HowTo several times, on different versions of Dapper, with different drivers and it would never work. I had to use ndiswrapper to get it working.

I'm running Ubuntu i386 Dapper, Turion 64, ATI Radeon XPRESS 200M.

1) Blacklist bcm43xx driver


Open a Terminal window


Type "sudo gedit etc/modprobe.d/blacklist"


At the bottom add the lines


# get rid of the default kernel drivers


blacklist bcm43xx

2) Make sure network interfaces file is correct


Type "sudo gedit /etc/network/interfaces"


Remove all comments ('#') that you see so that all devices are
handled by the default network manager.


I would reboot here and make sure the wireless light goes out

3) Install ndiswrapper


Put in Ubuntu CD. Open Synaptic Package Manager (Click
System -> Administration -> Synaptic Package Manager),
search for ndiswrapper-utils, and install it.

You could also type "sudo apt-get install ndiswrapper-utils

4) Conigure ndiswrapper


Open termianl and navigate the folder where your drivers are.

"cd Desktop/bcm43xx"


Type "sudo ndiswrapper -i oem3.inf"

Then type "sudo ndiswrapper -m"


Type "sudo gedit /etc/modprobe.d/ndiswrapper"

Change the one line in that file to read "alias eth1 ndiswrapper"

Now you should reboot so all the drivers load.

Once you reboot the wireless light on your laptop should be lit. If it worked, you should be able to click the Network Manager icon in the top right. It will probably show a disconnected ennection becuase the computer is not plugged in.
Left click it and select eth1 from the drop down menu.
Click Configure
Click Wireless Connection, then Properties. Here just enter your network information. If you're using an unprotected network you should only have to type yout SSID.

Click OK and you should now be connected! If a green signal meter and connected network icon appear in the upper right you'll know it worked.

Hope this helps!

PPower
June 7th, 2006, 06:36 AM
i've had to upgrade kernel to fix acpi issues, and thus need to recompile the bcm module. However, I can't (embarrasingly enough) find the source.
The http://bcm43xx.berlios.de/ page states that it will be included in the 2.6.17 kernel, but seem to have removed the link to download the module from the page already. You can get the firmware cutter from their svn repository, but that's about it.
The documentation merely states that you can download the module from the site.

I've patched my kernel up to 2.6.17-rc6, but although the bcm43xx files are now there in drivers/net/wireless/bcm43xx, i can't find the option to include it in menconfig.

Any one know where I can download the seperate source for this module, or how to force it to build as part of the 2.6.17 kernel?

smylie
If I believe correctly it is installed by default. Not compiling a kernel ever I dont 100% know but oh well. Ill hunt around bcm-users later when everybody is awake! (6:30 here!)

There is a guide for compiling for .15/.16 at http://random.blackworlds.org/bcm43xx-how-to.txt

smylie
June 7th, 2006, 08:39 AM
If I believe correctly it is installed by default. Not compiling a kernel ever I dont 100% know but oh well. Ill hunt around bcm-users later when everybody is awake! (6:30 here!)

There is a guide for compiling for .15/.16 at http://random.blackworlds.org/bcm43xx-how-to.txt

same problem - that documentation says to download the module source from http://bcm43xx.berlios.de, but as previously mentioned, the module source is not available on that page (that I can see).

smylie

veebis
June 7th, 2006, 09:06 AM
Followed your excellent step by step, and here I am, posting from the living room (my regular spot for writing/browsing)... Thank you! Only suggestion I can think of is maybe make it clearer that the pieces (esp. the ".o" file) actually works for Apple hw. Made me a little nervous, what with all that sudo-ing and being pretty noob. Great job, and thanks again!
-Vb

PPower
June 7th, 2006, 05:31 PM
same problem - that documentation says to download the module source from http://bcm43xx.berlios.de, but as previously mentioned, the module source is not available on that page (that I can see).

smylie
The module depends on PCI && IEEE80211 && IEEE80211_SOFTMAC && NET_RADIO && EXPERIMENTAL

Use \ to find it in menuconfig. When done the bcm option will magically appear.:KS

rjstevens3
June 7th, 2006, 07:30 PM
First of all, thanks to all the posts on these forums I'm posting from a wireless connection, and I have a Broadcom 4318 "AirForce One 54g".

Here's how I did it, maybe it'll help someone. You don't even need an internet connection.

The drivers I used are attached to the message. To follow this guide to a T downlad them and place in a folder bcm43xx on your desktop.

I've tried the procedure in this HowTo several times, on different versions of Dapper, with different drivers and it would never work. I had to use ndiswrapper to get it working.

I'm running Ubuntu i386 Dapper, Turion 64, ATI Radeon XPRESS 200M.

1) Blacklist bcm43xx driver


Open a Terminal window


Type "sudo gedit etc/modprobe.d/blacklist"


At the bottom add the lines


# get rid of the default kernel drivers


blacklist bcm43xx

2) Make sure network interfaces file is correct


Type "sudo gedit /etc/network/interfaces"


Remove all comments ('#') that you see so that all devices are
handled by the default network manager.


I would reboot here and make sure the wireless light goes out

3) Install ndiswrapper


Put in Ubuntu CD. Open Synaptic Package Manager (Click
System -> Administration -> Synaptic Package Manager),
search for ndiswrapper-utils, and install it.

You could also type "sudo apt-get install ndiswrapper-utils

4) Conigure ndiswrapper


Open termianl and navigate the folder where your drivers are.

"cd Desktop/bcm43xx"


Type "sudo ndiswrapper -i oem3.inf"

Then type "sudo ndiswrapper -m"


Type "sudo gedit /etc/modprobe.d/ndiswrapper"

Change the one line in that file to read "alias eth1 ndiswrapper"

Now you should reboot so all the drivers load.

Once you reboot the wireless light on your laptop should be lit. If it worked, you should be able to click the Network Manager icon in the top right. It will probably show a disconnected ennection becuase the computer is not plugged in.
Left click it and select eth1 from the drop down menu.
Click Configure
Click Wireless Connection, then Properties. Here just enter your network information. If you're using an unprotected network you should only have to type yout SSID.

Click OK and you should now be connected! If a green signal meter and connected network icon appear in the upper right you'll know it worked.

Hope this helps!


When I

dmesg | grep ndiswrapper

I get ndiswrapper 1.6 loaded... driver loaded... wlan0:ndiswrapper ethernet device (numbers) using driver oem3.... I changed the alias in /etc/modprobe.d/ndiswrapper, but the module still loads with wlan0 as the wireless card. Network manager doesn't show wlan0, nor does ifconfig or iwconfig. This has been my problem with ndiswrapper all along. I have used the .deb and built from source with same results. I'm using source right now.

-RJ

cfischer
June 7th, 2006, 08:59 PM
I've read and re-read every post here - thanks, all. And I guess I should contribute - just got the wireless card working on my Dell Inspiron 5150. The secret (after two days of work) is to use ndiswrapper (disable bcm43xx and install ndiswrapper-utils) and the drivers from dell - bcmwl5.inf and bcmwl5.sys. The other driver (wl_apsta.o) does not bring up the link - that is handled (I guess) by the RadioState line in bcmwl5.inf - it needs to be set to 0 to turn on the card. I spent two days wondering why dmesg kept telling me that eth1: link is not ready.

see part 2 here: https://wiki.ubuntu.com/WifiDocs/Driver/bcm43xx#head-cf3f0ec9146ae9441b39c4bed74e5d044ef78d2f

cfischer
June 7th, 2006, 09:08 PM
I've read and re-read every post here - thanks, all. And I guess I should contribute - just got the wireless card working on my Dell Inspiron 5150. The secret (after two days of work) is to use ndiswrapper (disable bcm43xx and install ndiswrapper-utils) and the drivers from dell - bcmwl5.inf and bcmwl5.sys. The other driver (wl_apsta.o) does not bring up the link - that is handled (I guess) by the RadioState line in bcmwl5.inf - it needs to be set to 0 to turn on the card. I spent two days wondering why dmesg kept telling me that eth1: link is not ready.

see part 2 here: https://wiki.ubuntu.com/WifiDocs/Driver/bcm43xx#head-cf3f0ec9146ae9441b39c4bed74e5d044ef78d2f

Oh, yeah ... ndiswrapper wants to name the wireless device wlan0 - and automatically does that by adding a line to /etc/modprobe.d/ndiswrapper: alias wlan0 ndiswrapper. That needs to be fixed. And then be sure the script, /etc/network/interfaces uses eth1 for the interface name - can't just pop in your old script! I added ndiswrapper to modules and blacklisted bcm43xx.

Now, on to getting my usb mouse and storage working ...

MarkSheely
June 7th, 2006, 10:52 PM
Thank you so much for this guide. I have one of the dreaded BCM4318[Air ForceOne 54g] cards that everyone has been having problems with, and a Dell B130 laptop. I began with a clean install of Dapper (as you recommended), followed the instructions you gave, and the recommendation here:
http://ubuntuforums.org/showpost.php?p=1084114&postcount=43

Within 15 minutes, my wireless was working.

I think the most important thing was that I went through the process immediately after installing Dapper. I didn't have the chance to screw anything up.

roadkillbunny
June 8th, 2006, 12:41 AM
I have a BCM4306 wireless card in my amd64 laptop. I have been using it sucessfully with ndiswrapper for some time now, but since I updated to Drapper I figured I will give the native bcm43xx driver a shot. I followed this guide to a step and am able to connect to my neighbors' unencrypted network. But when I try conneting to my WEP encrypted I get the following error in dmesg:


bcm43xx: FATAL ERROR: BCM43xx_IRQ_XMIT_ERROR
ADDRCONF(NETDEV_UP): wlan0: link is not ready
SoftMAC: Open Authentication with 00:c0:49:ee:7b:78 failed, error code: 13


I tried using the same firmware from what I use with ndiswrapper, one that I found in bcm43xx's README, the one from this site, and one that I found on compaq's site. Anyone know what I could do to fix this?

?????
June 8th, 2006, 03:10 AM
I have a BCM4306 wireless card in my amd64 laptop. I have been using it sucessfully with ndiswrapper for some time now, but since I updated to Drapper I figured I will give the native bcm43xx driver a shot. I followed this guide to a step and am able to connect to my neighbors' unencrypted network. But when I try conneting to my WEP encrypted I get the following error in dmesg:


bcm43xx: FATAL ERROR: BCM43xx_IRQ_XMIT_ERROR
ADDRCONF(NETDEV_UP): wlan0: link is not ready
SoftMAC: Open Authentication with 00:c0:49:ee:7b:78 failed, error code: 13


I tried using the same firmware from what I use with ndiswrapper, one that I found in bcm43xx's README, the one from this site, and one that I found on compaq's site. Anyone know what I could do to fix this?

What comes up when you type iwconfig into terminal? Is your AP "Open" and not "shared"?

roadkillbunny
June 8th, 2006, 03:42 AM
What comes up when you type iwconfig into terminal? Is your AP "Open" and not "shared"?
Right after loading the bcm43xx module:

wlan0 IEEE 802.11b/g ESSID:off/any Nickname:"Broadcom 4306"
Mode:Managed Access Point: Invalid Bit Rate=1 Mb/s
RTS thr:off Fragment thr:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

After doing ifconfig wlan0 up:

wlan0 IEEE 802.11b/g ESSID:off/any Nickname:"Broadcom 4306"
Mode:Managed Frequency=2.437 GHz Access Point: Invalid
Bit Rate=11 Mb/s Tx-Power=15 dBm
RTS thr:off Fragment thr:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

I have also tried doing "ap any" and "rate 11M" or 54M as suggested by a post with no success.

Also I am using shared mode.

smylie
June 8th, 2006, 07:13 AM
The module depends on PCI && IEEE80211 && IEEE80211_SOFTMAC && NET_RADIO && EXPERIMENTAL

Use \ to find it in menuconfig. When done the bcm option will magically appear.:KS



my god man. i've been using linux since 1997 and I never knew you could hunt thru menuconfig like that! i hate to think how many hours of hunting round that would have saved me =)

i do have one more question . . . how did you find out what the dependancies on making it appear are?

thanks heaps =)

smylie

PPower
June 8th, 2006, 07:24 AM
my god man. i've been using linux since 1997 and I never knew you could hunt thru menuconfig like that! i hate to think how many hours of hunting round that would have saved me =)

i do have one more question . . . how did you find out what the dependancies on making it appear are?

thanks heaps =)

smylie

They are them. Thanks to the bcm team!
downloading vista public beta

ososxe
June 8th, 2006, 08:30 AM
Thanks, crag277!!
Following the steps on your ho to, it made the broadcom wireless card on my Acer Aspire 3003 works flawlessly!
Nut i have a minor correction to make on your how to. Where it says




Type "sudo gedit etc/modprobe.d/blacklist"


Should say "sudo gedir /etc/modprobe.d/blacklist
A newbie like me may get troubles with this ;)

nickm
June 8th, 2006, 09:05 AM
why is everyone reporting using NDIS Wrapper? i really hope all these people have atleast tried my guide first ](*,)
It might be better to take NDIS questions to a thread related to their use?

Slicedbread
June 8th, 2006, 09:56 AM
why is everyone reporting using NDIS Wrapper? i really hope all these people have atleast tried my guide first ](*,)
It might be better to take NDIS questions to a thread related to their use?

They probably tried using the bcm43xx driver but failed and the title is labled "How to: Broadcom Wireless Cards". Maybe you should include ndiswrapper instructions as an alternative, I personally found that it's more stable, as easy to install and performs better than bcm43xx driver.

cyberknight72
June 8th, 2006, 10:07 AM
Thanks for the great how to! I had thought at first it had not functioned however I did not read through the how to properly and built my own problems. ](*,) I went from a fresh install and followed the how to line line for line (same broadcom device). Now I am up on wireless on my Compaq Pressario 2585US! Thanks a lot! =D> One question, under breezy, I was able to get 802.11g support with the same device using ndiswrapper however I noted that my wireless under 6.0.6 is only 802.11b. Is this due to the way the driver functions under dapper drake? Or is it some failure that I made? :confused:

nickm
June 8th, 2006, 11:40 AM
They probably tried using the bcm43xx driver but failed and the title is labled "How to: Broadcom Wireless Cards". Maybe you should include ndiswrapper instructions as an alternative, I personally found that it's more stable, as easy to install and performs better than bcm43xx driver.

Ah Right, well its never worked for me so i cant provide instructions for how to get it working..

gesho
June 8th, 2006, 02:52 PM
great topic, thanks to the author.

for BCM4318 users (same here, on my inspiron 600m): look like the post by Slicedbread is the best for us.
http://ubuntuforums.org/showpost.php?p=1085392&postcount=55

here is what I did
installed bcmxx
downloaded bcmwl5 from Slisedbread's link in above post
blacklisted ndiswrapper
rebooted
sudo bcm43xx-fwcutter -w /lib/firmware bcmwl5.sys (got same errors here as other BCM4318 users, don't worry)
rebooted

and cheers, signal is there

big_gie
June 8th, 2006, 04:39 PM
I'm having trouble using NetworkManager. It works ok with cable, but wireless is a no-go.

I have a Dell Inspiron 8500 with a Broadcom 4306 wifi card using bcm43xx.

Attached is the log of "NetworkManager --no-daemon"

It get stock to line 141 for 60 seconds it seems, then time out with "Activation (eth1/wireless): association took too long (>60s), failing activation."

Anyone have an idea???

Thanx

Anyone? ](*,)

PPower
June 8th, 2006, 05:05 PM
Ah Right, well its never worked for me so i cant provide instructions for how to get it working..

For me ndiswrapper segfaults. Oh well...

DW5
June 8th, 2006, 06:16 PM
Upgraded from Breezy, tried all day yesterday to get this to work following the guide. Have an Compaq nx9010 with a Broadcom 4303. Blacklisted ndiswrapper, deleted old drivers, used the cutter, modprobed, etc. To no avail, could see network, but dhcp failed to get an ip. This morning, I blacklisted bcm43xx and unblacklisted ndiswrapper. Rebooted. It worked. Sorry. I really wanted this to work for me as I'd rather use a native linux driver, but I don't have time to keep trying to get it to work.

DW

Kawayanan
June 8th, 2006, 06:29 PM
why is everyone reporting using NDIS Wrapper? i really hope all these people have atleast tried my guide first ](*,)
It might be better to take NDIS questions to a thread related to their use?

I have a 4318 and tried you guide with every permutation suggested in this thread. Yes, they were clean installs (I think I did 5 clean installs in 2 days). I could always see the available networks, but never connect. I tried it with Network Manager and without (manually inputting settings). Nothing worked. I am guessing there are just some hardware the bcm43xx driver doesn't work well with.

Kawayanan

PPower
June 8th, 2006, 07:15 PM
Upgraded from Breezy, tried all day yesterday to get this to work following the guide. Have an Compaq nx9010 with a Broadcom 4303. Blacklisted ndiswrapper, deleted old drivers, used the cutter, modprobed, etc. To no avail, could see network, but dhcp failed to get an ip. This morning, I blacklisted bcm43xx and unblacklisted ndiswrapper. Rebooted. It worked. Sorry. I really wanted this to work for me as I'd rather use a native linux driver, but I don't have time to keep trying to get it to work.

DW

Is it a nx9110? That is supported but 9010 is not on the list. Please try again once Ubuntu has updated their kernels.

Darklance
June 8th, 2006, 07:51 PM
Thanks, this how to came in handy, i was starting to think my cardbus was damaged or some how unsupported again thank you

medw1974
June 8th, 2006, 08:41 PM
This is interesting I successfully used this howto to get my broadcom 4306 to work automatically on boot on my dell inspiron 9100 using the 686 kernel. Network-Manager would not work for me but I didn't seem to need it.

However I have tried to replicate this now using the 686-smp kernel but the best result I can acheive is having to:

sudo iwconfig eth1 ap any
sudo dhclient eth1

on each reboot.

Any idea what the differences could be? Or how to run those 2 lines automatically at boot time?

nickm
June 8th, 2006, 08:49 PM
sudo iwconfig eth1 ap any
sudo dhclient eth1

on each reboot.

Any idea what the differences could be? Or how to run those 2 lines automatically at boot time?

Yes, you can add them to System > preferences > sessions > start up programs

just add each seperate command into its own entry and restart, see if that fixes it.

medw1974
June 8th, 2006, 08:54 PM
Yes, you can add them to System > preferences > sessions > start up programs

just add each seperate command into its own entry and restart, see if that fixes it.

Thanks, I'd already tried that but it didn't do anything.

But I have an update to my earlier post - because network-manager didnt seem to work when I originally got things going on the plain 686 kernel I didn't install it on the 686-smp, but I thought I'd give it a go anyway and voila it's connected on startup.

Strangely though as per before network-manager doesnt see any connections.

xxrealmsxx
June 8th, 2006, 09:22 PM
This method of getting the wireless networking to work for me is very inconsistent, I followed the instructions in every way but for some reason I will show 100% signal strength in network manager and the wifi light on my laptop will be on but I wont be able to browse or do anything.

However some times, like now, the wifi light is off, but network manager says 100% and it works fine.

Other than that this works great, I just wish it more consistent because I know I have signal here 24/7 in windows.

crag277
June 8th, 2006, 09:47 PM
why is everyone reporting using NDIS Wrapper? i really hope all these people have atleast tried my guide first ](*,)
It might be better to take NDIS questions to a thread related to their use?


Oh your guide was the first thing I tried. It's excellet, just didn't work with my hardware. With NDISwrapper it works perfectly with all default software and even works at full 54MBps.

Vogateer
June 9th, 2006, 04:51 AM
I have the BCM4318 [AirForce One 54g] 802.11 g wireless LAN Controller (rev 02), so count me amongst those who can't get this working just yet. Well done on the howto, though, glad to see a lot of people having success with it. My time will come. :)

Cable
June 9th, 2006, 06:03 AM
I've tried this, and it didn't work for me either. The light on my card has never turned on. My card shows up as eth0, not wlan0 like I've seen other people mention. Is there a way to remove what I did in this guide to try this again or try other things? Or do you have any suggestions? Also, I noticed that your guide says this makes the card word with B. Is there a way to get G to work? I really need G.

My card is a WMP54G BCM4306.