PDA

View Full Version : [ubuntu] Problem using two monitors



Aries01
September 26th, 2011, 05:13 PM
With the proprietary driver of my Radeon graphics card activated, I tried to set up a two-monitor display arrangement ("show same image in both monitors" unchecked), but the system gave the following error message:

"Required virtual size (2560,1024) does not fit available size, min. 320,200 max. 1600,1600."

Curiously, this problem does not occur when the Radeon driver is left unactivated.

Is there a way to adjust those parameters that are causing a problem, so that I could set up a two-monitor desktop?

Toz
September 27th, 2011, 09:20 PM
Hello and welcome to the forums.

Can you post the contents of your /etc/X11/xorg.conf file? There should be a section there about Virtual size. If not, we can try adding one.

Reference link: https://wiki.ubuntu.com/X/Config/Resolution#Setting_resolution_changes_in_xorg.conf _--_resolution_lower_than_expected

Aries01
October 8th, 2011, 05:46 PM
Thank you for your advice. Here is the contents of xorg.conf:

Section "Screen"
Identifier "Default Screen"
DefaultDepth 24
EndSection

Section "Module"
Load "glx"
EndSection


I tried replacing the contents of the file with the code offered at your reference link, but it rendered the computer incapable of booting. The graphics card is a Radeon HD 4670. I would be grateful for further advice.

Toz
October 8th, 2011, 06:21 PM
Try this one:


Section "Screen"
Identifier "Default Screen"
DefaultDepth 24
SubSection "Display"
Virtual 2560 1024
EndSubSection
EndSection

Section "Module"
Load "glx"
EndSection

jonnyboysmithy
October 8th, 2011, 08:09 PM
I had this problem till yesterday I figured out you have to use the proprietary drivers setting tools, for me it looks like the attached picture.
As you can see my normal screen config tools don't know the screens, the nvidia tool knows what to do.
Use the proprietary driver screen settings software.

Aries01
October 10th, 2011, 04:11 PM
The proprietary driver screen settings software did the trick. Thanks for the tip.