PDA

View Full Version : [ubuntu] Ubuntu 11.04 Update: "Could Not Download All Repository Indexes"



jmk08
September 24th, 2011, 06:18 PM
Hello all,

For thee days now, the red exclamation point triangle has been showing on the top right task bar of my 11.04 classic. Upon attempting to update, I receive:
------------
Failed to fetch http://ppa.launchpad.net/n-muench/bur/ubuntu/dists/natty/main/source/Sources 404 Not Found
Failed to fetch http://ppa.launchpad.net/n-muench/bur/ubuntu/dists/natty/main/binary-i386/Packages 404 Not Found
Some index files failed to download. They have been ignored, or old ones used instead.
------------
This error has essentially stupefied me lol. Help ye wise ones!

General System:
Ubuntu 11.04
Asus U36SD with Ubuntu Nvidia drivers installed.

dino99
September 24th, 2011, 06:26 PM
you are trying to get packages from links that does not exist :(

http://ppa.launchpad.net/n-muench/

Old_Grey_Wolf
September 24th, 2011, 06:39 PM
Read my next post before you do this.


gksudo gedit /etc/apt/sources.list

Change the lines with http://ppa.launchpad.net/n-muench/bur/... to http://ppa.launchpad.net/n-muench/burg/...
The "g" is missing.

Old_Grey_Wolf
September 24th, 2011, 07:24 PM
Hello again jmk08,

With Calculus+Biology+Chemistry you still have time to play with the Burg boot loader?

You may want to read about reinstalling Grub2 from the Live USB or CD before messing with the boot loader. If something goes wrong with the Burg install you may have troubles getting the computer to boot.

For future reference this is how I derived the solution to the Repository Index problem:

1. I clicked on the link in your post ://ppa.launchpad.net/n-muench/bur/ubuntu/dists/natty/main/source/Sources and got a 404 error

2. I removed part of the link a /blahblah/ one at a time until i did not get a 404 error

://ppa.launchpad.net/n-muench/bur/ubuntu/dists/natty/main/source/
://ppa.launchpad.net/n-muench/bur/ubuntu/dists/natty/main/
://ppa.launchpad.net/n-muench/bur/ubuntu/dists/natty/
...
://ppa.launchpad.net/n-muench/bur

3. When the link was only ://ppa.launchpad.net/n-muench/ I got a list of files and directories where burg (not bur) was listed

Index of /n-muench
[ICO] Name Last modified Size
[DIR] Parent Directory -
[DIR] burg/ 28-Apr-2011 03:36 -
[DIR] bzr/ 15-Feb-2011 04:25 -
[DIR] bzr2/ 15-Feb-2011 04:35 -
...
__________________________________________
Apache/2.2.14 (Ubuntu) Server at ppa.launchpad.net Port 80

4. I put the g on the end of bur in the original link (://ppa.launchpad.net/n-muench/burg/ubuntu/dists/natty/main/source/Sources) and a file was displayed rather that the 404 error

Package: burg
Binary: burg, burg-common, burg-pc, burg-emu
Version: 1.98+20100623-1
...

Package: burg-themes
Binary: burg-themes, burg-themes-common
Version: 1.98+20100623-1
...




I hope this helps you in the future.

klein8
October 5th, 2011, 04:16 PM
Hello again jmk08,

With Calculus+Biology+Chemistry you still have time to play with the Burg boot loader?

You may want to read about reinstalling Grub2 from the Live USB or CD before messing with the boot loader. If something goes wrong with the Burg install you may have troubles getting the computer to boot.

For future reference this is how I derived the solution to the Repository Index problem:

1. I clicked on the link in your post ://ppa.launchpad.net/n-muench/bur/ubuntu/dists/natty/main/source/Sources and got a 404 error

2. I removed part of the link a /blahblah/ one at a time until i did not get a 404 error
://ppa.launchpad.net/n-muench/bur/ubuntu/dists/natty/main/source/
://ppa.launchpad.net/n-muench/bur/ubuntu/dists/natty/main/
://ppa.launchpad.net/n-muench/bur/ubuntu/dists/natty/
...
://ppa.launchpad.net/n-muench/bur3. When the link was only ://ppa.launchpad.net/n-muench/ I got a list of files and directories where burg (not bur) was listed
Index of /n-muench
[ICO] Name Last modified Size
[DIR] Parent Directory -
[DIR] burg/ 28-Apr-2011 03:36 -
[DIR] bzr/ 15-Feb-2011 04:25 -
[DIR] bzr2/ 15-Feb-2011 04:35 -
...
__________________________________________
Apache/2.2.14 (Ubuntu) Server at ppa.launchpad.net Port 804. I put the g on the end of bur in the original link (://ppa.launchpad.net/n-muench/burg/ubuntu/dists/natty/main/source/Sources) and a file was displayed rather that the 404 error
Package: burg
Binary: burg, burg-common, burg-pc, burg-emu
Version: 1.98+20100623-1
...

Package: burg-themes
Binary: burg-themes, burg-themes-common
Version: 1.98+20100623-1
...


I hope this helps you in the future.

I tried this way ,but it does nothing. I mean it doesn't work in my system.:(

klein8
October 5th, 2011, 04:18 PM
Hello again jmk08,

With Calculus+Biology+Chemistry you still have time to play with the Burg boot loader?

You may want to read about reinstalling Grub2 from the Live USB or CD before messing with the boot loader. If something goes wrong with the Burg install you may have troubles getting the computer to boot.

For future reference this is how I derived the solution to the Repository Index problem:

1. I clicked on the link in your post ://ppa.launchpad.net/n-muench/bur/ubuntu/dists/natty/main/source/Sources and got a 404 error

2. I removed part of the link a /blahblah/ one at a time until i did not get a 404 error
://ppa.launchpad.net/n-muench/bur/ubuntu/dists/natty/main/source/
://ppa.launchpad.net/n-muench/bur/ubuntu/dists/natty/main/
://ppa.launchpad.net/n-muench/bur/ubuntu/dists/natty/
...
://ppa.launchpad.net/n-muench/bur3. When the link was only ://ppa.launchpad.net/n-muench/ I got a list of files and directories where burg (not bur) was listed
Index of /n-muench
[ICO] Name Last modified Size
[DIR] Parent Directory -
[DIR] burg/ 28-Apr-2011 03:36 -
[DIR] bzr/ 15-Feb-2011 04:25 -
[DIR] bzr2/ 15-Feb-2011 04:35 -
...
__________________________________________
Apache/2.2.14 (Ubuntu) Server at ppa.launchpad.net Port 804. I put the g on the end of bur in the original link (://ppa.launchpad.net/n-muench/burg/ubuntu/dists/natty/main/source/Sources) and a file was displayed rather that the 404 error
Package: burg
Binary: burg, burg-common, burg-pc, burg-emu
Version: 1.98+20100623-1
...

Package: burg-themes
Binary: burg-themes, burg-themes-common
Version: 1.98+20100623-1
...


I hope this helps you in the future.


.:(
And I want to know how can open the file which contain the above statements.

Old_Grey_Wolf
October 5th, 2011, 11:23 PM
.:(
And I want to know how can open the file which contain the above statements.

Are you having the same problem as jmk08 or are you trying to get the Burg boot loader?

subehsharma
November 10th, 2011, 11:46 AM
Best method to getaway from this problem is to install fix404. You can read about it more here:

Under Ubuntu, the APT package index is a database containing all packages of repositories (PPAs) defined in the /etc/apt/sources.list file. To update this database after adding some repositories, we need to use this command from the Terminal:

sudo apt-get update

Sometimes, when running the command given above, we get error messages (404 Not Found) that are the result of wrong PPAs, which may slow down the update process via the Terminal. In fact, this 404 Not Found error messages are not harmful at all, but you can use Fix404 to detect and remove these PPAs.

To install Fix404 on Ubuntu 11.04, launch the Terminal and run these commands:

sudo apt-add-repository ppa:lkjoel/fix404
sudo apt-get update
sudo apt-get install fix404

To install on Ubuntu 10.10/10.04, download this deb package here.

To start using Fix404, run this command (root privileges required):

sudo fix404

Then follow displayed instructions to disable PPAs causing the 404 Not Found Error.

http://www.upubuntu.com/2011/07/remove-ubuntu-ppas-that-cause-404-not.html

subehsharma
November 10th, 2011, 11:46 AM
http://www.upubuntu.com/2011/07/remove-ubuntu-ppas-that-cause-404-not.html