PDA

View Full Version : [ubuntu] 9.10 and TeVii S630 dvb-usb



micantox
September 23rd, 2011, 10:03 AM
Hi all,

I'm facing a big problem with the device in the subject. I've downloaded the proper drivers from the website, copied the required firmware files in /lib/firmwares, compiled and installed the driver.

At the following reboot the system correctly recognized and
initialized the device. This is the output of the command 'cat
/var/log/messages | grep dvb'.


Sep 23 09:48:05 IDU kernel: [ 8.178590] dvb-usb: found a 'TeVii
S630 USB' in cold state, will try to load a firmware
Sep 23 09:48:05 IDU kernel: [ 8.178606] usb 1-5: firmware:
requesting dvb-usb-s630.fw
Sep 23 09:48:05 IDU kernel: [ 8.479111] dvb-usb: downloading
firmware from file 'dvb-usb-s630.fw'
Sep 23 09:48:05 IDU kernel: [ 8.908055] dvbh0: mixed HW and IP
checksum settings.
Sep 23 09:48:05 IDU kernel: [ 8.997257] dvb-usb: found a 'TeVii
S630 USB' in warm state.
Sep 23 09:48:05 IDU kernel: [ 8.997378] dvb-usb: will pass the
complete MPEG2 transport stream to the software demuxer.
Sep 23 09:48:12 IDU kernel: [ 16.412525] dvb-usb: MAC address:
00:18:bd:5b:97:44
Sep 23 09:48:12 IDU kernel: [ 16.775333] dvb-usb: schedule remote
query interval to 150 msecs.
Sep 23 09:48:12 IDU kernel: [ 16.775347] dvb-usb: TeVii S630 USB
successfully initialized and connected.
Sep 23 09:57:27 IDU kernel: [ 7.255661] dvbh0: mixed HW and IP
checksum settings.
Sep 23 09:57:27 IDU kernel: [ 7.292012] dvb-usb: found a 'TeVii
S630 USB' in cold state, will try to load a firmware
Sep 23 09:57:27 IDU kernel: [ 7.292024] usb 1-5: firmware:
requesting dvb-usb-s630.fw
Sep 23 09:57:27 IDU kernel: [ 7.877607] dvb-usb: downloading
firmware from file 'dvb-usb-s630.fw'
Sep 23 09:57:27 IDU kernel: [ 7.997036] dvb-usb: found a 'TeVii
S630 USB' in warm state.
Sep 23 09:57:27 IDU kernel: [ 7.997164] dvb-usb: will pass the
complete MPEG2 transport stream to the software demuxer.
Sep 23 09:57:32 IDU kernel: [ 14.784140] dvb-usb: MAC address:
00:18:bd:5b:97:44
Sep 23 09:57:33 IDU kernel: [ 15.632086] dvb-usb: TeVii S630 USB
successfully initialized and connected.

As far as I understood reading on Internet, this should lead to the creation of the required device nodes in /dev/dvb/adapter0/, namely demux0, dvr0, frontend0 and net0. None of this happens.

I've even tried to create an on-purpose udev rule in
/etc/udev/rules.d/, called 70-persistent-dvb.rules, containing the following rows.


KERNEL=="dvb0.dvr0", SUBSYSTEM=="dvb", MODE="0666"
KERNEL=="dvb0.demux0", SUBSYSTEM=="dvb", MODE="0666"
KERNEL=="dvb0.frontend0", SUBSYSTEM=="dvb", MODE="0666"
KERNEL=="dvb0.net0", SUBSYSTEM=="dvb", MODE="0666"

But, still, no device nodes get created.

How to solve this?

Thank you all.
M.

kareempharmacist
November 20th, 2011, 10:26 AM
I have the same card .I am using Ubuntu 11.10 but it is not working .we are in the same boat....

kareempharmacist
November 23rd, 2011, 08:11 AM
I managed to get it working on crunch bang!# Linux which is based on debian
it worked out-of-the-box but if it didn't upgrade the package firmware-linux-free
I think it may work with any debian based distribution I suggest Kanotix
waiting for your reply

kareempharmacist
November 23rd, 2011, 08:34 AM
sorry the package may be firmware-linux-nonfree