PDA

View Full Version : [SOLVED] dependency problem



ak123
September 22nd, 2011, 02:08 PM
hey everyone.. been a while since i posted here but i am in need of some help..

I have to install a program called logger svt pro or something like that.. its at http://www.vernier.com/downloads/logger-pro-linux/

its an urgent thing for school. Problem is, it wont install thanks to a missing dependency on something called libhall. Anyone know how to fix it?

Hakunka-Matata
September 22nd, 2011, 03:37 PM
by ak123: its an urgent thing for school. Problem is, it wont install thanks to a missing dependency on something called libhall. Anyone know how to fix it?

a missing dependency means the program needs that library in order to function, so install libhall (you may have trouble installing it, as libhall may conflict with other libraries already installed, try it, and find out).

Your thread 'subject line': Major problem!, Urgent!, in not very descriptive. !!! equates to shouting, turns some people off.

ak123
September 23rd, 2011, 01:48 AM
Well thats the issue here.. i cant seem to find the package.. its not in the default repositories and i cant seem to find a ppa for it..

Shazaam
September 23rd, 2011, 02:44 AM
Are you spelling it correctly?
I found this...

http://packages.ubuntu.com/lucid/libhal-dev

Notice only one L in libhal?

mrgs
September 23rd, 2011, 05:37 AM
Your thread 'subject line': Major problem!, Urgent!, in not very descriptive. !!! equates to shouting, turns some people off.

Fixed.

ak123
September 25th, 2011, 04:23 AM
thanks @mrgs

@shazaam you were right.. the package was actually spelt libhal1 (Last character was the number one) so it looked like two l's

mrgs
September 25th, 2011, 08:54 AM
If this solved the problem, please mark the thread so using 'thread tools'.