View Full Version : [SOLVED] Getting Samsung ML-1865 Black Mono Laser Printer to work

September 20th, 2011, 11:58 AM
Just bought one of these nifty laser printers and struggled like mad to get it to work until I sussed how to do it and it was simplicity itself!


Add to repositories under update manager...

"deb http://www.bchemnet.com/suldr/ debian extra" without the quote marks!

Then get the apt-key

Refresh your repository listings

Go to synaptic and do search for... samsungmfp

Install samsungmfp-data & samsungmfp-driver

Plug in, turn on samsung laser, 'Add Printer' and presto should work!!

More info at http://www.bchemnet.com/suldr/

September 20th, 2011, 05:36 PM
Also just purchased the Samsung ML-1865, unfortunately I have downloaded another driver before I saw your comments. As a Ubuntu beginner how do I remove the first driver so I can follow your instructions to install the correct driver

September 20th, 2011, 06:21 PM
Sorted - worked out how to de install the original driver then used your process - thank you

January 7th, 2012, 12:32 PM
Thank's for the help. At last it worked! Have a nice day!

January 26th, 2012, 09:06 PM
Guys, how do I unninstall everything related to the ML-1865W?

I'm on the edge here. My printer goes frenzy and prints hearts, smiles, pipes in two lines, then goes to the next page and starts printing theses nasty little symbols all over again!

Other question: are your printers working also "wirelessly"?

Bryn Mawr
July 3rd, 2012, 10:33 PM
Thank you - this has sorted a problem I've been trying to solve for weeks.

You're a star :-)

July 6th, 2012, 12:27 PM
Thank you very much. After many attempts I made my ml-1670 work in crunchbang linux following your instructions.