View Full Version : [ubuntu] Keyboard not working

September 19th, 2011, 11:30 AM
An introduction to myself, i am currently using a laptop: Acer Aspire 4935, totally new to Linux and Ubuntu. So, would need a good guide on how to solve my problem.

After the trying Ubuntu on CD, only one word can describe it: Excellent (light speed compared to my Windows Vista)!

Then i went on to install Ubuntu from CD alongside my windows. After keying in my username and password, the installation went smoothly and extremely fast!

After the first reboot, selected "Ubuntu" in the DOS format OS selection page, and it proceed to complete the remaining installation. Upon completion, it rebooted again.

After the 2nd reboot, same DOS format OS selection page and use my keyboard to select "Ubuntu". I was then directed to a purple screen which ask me to select the OS i want to log in again (is this the so called GRUB?)

Without much thinking, i selected "Ubuntu" again, using my keyboard.

Suddenly, i saw a message "Unable to reactivate AUX port" on a black screen flashed through very quickly. Very soon, I am in the login page!

Here comes the problem. When i wanted to key in my password, found that my keyboard was not working at all! The cap-lock light did not even respond after i tried to press the cap-lock button to check the condition of the keyboard!

The username shown on the screen was also not the one i keyed in previously! It only showed the first letter of the username i keyed in.

However, to my relief, the mouse was still working and could at least help me to shut-down the laptop.

Restarted the computer again. Comes the same DOS format OS selection. Wanted to select "Ubuntu", but the keyboard still not working! Then the system just booted into the default OS: Windows Vista (I didn't set any password for my Windows).

At the Windows main page, tried to use the keyboard. And again, no response from the keyboard at all. Restarted again and again and tried again and again, still no response from my keyboard.

In the end, i uninstalled Ubuntu from my Windows (luckily my mouse was still able to function properly), and restarted my computer again. *blink* my keyboard comes to alive!!

Is this a hardware incompatibility problem? Or??

Would like to get some help on how to solve this problem.

Thank you in advance.

September 19th, 2011, 02:32 PM
two questions:

are the bios settings about pci set correctly ? (keyboard plugged via usb ?)

when you have installed ubuntu, did you select the good keyboard model ?

my way to install:


September 20th, 2011, 03:02 PM
Thanks Dino99, my reply:

1) I am currently using a laptop, naturally, i am using the laptop keyboard and have been using this laptop for more than 2 years without any problem. Would this still be bios problem?

2) I was installing from CD, it didn't prompt me to select my keyboard type. after launching Wubi, the whole process was like this:

- in the first page:
- Demo and full installation
- Install inside windows: selected this.
- learn more

In the 2nd page:
- installation drive: C:
- installation size: 10GB
- desktop environment: Ubuntu
- language: English (US)
- Username: xxxxxxxxx
- Password: xxxx

Then i i clicked "install" at the bottom of 2nd page. The whole installation then went auto-pilot without needing me to input anything until the installation completed. Then the CD automatically ejected out. and was prompted to reboot the computer.