View Full Version : [ubuntu] Centrino Wireless-N 1030 slow and buggy on Ubuntu 11.4 64 bits

September 18th, 2011, 11:03 AM

I’ve got a Dell XPS 17 (L702X) shipped with a “Intel Centrino Wireless-N 1030”, it supports BGN. I installed Ubuntu Desktop 11.4 64 bits with latest updates but wifi is not working fine. It works really slowly, below the 10% of it’s capabilities (tested booting on the OEM Windoze it still has). I use just WEP, no WPA. ifconfig tells that there are no errors in the interface. Sometimes, just sometimes, once rebooted it works fine, but if you reboot again then it goes slow again.

Each 10 minutes (aprox) you get lines like this in “dmesg”, looks like a re-link :
[ 3614.922677] cfg80211: All devices are disconnected, going to restore regulatory settings
[ 3614.922692] cfg80211: Restoring regulatory settings
[ 3614.922704] cfg80211: Calling CRDA to update world regulatory domain
[ 3614.929453] cfg80211: Ignoring regulatory request Set by core since the driver uses its own custom regulatory domain
[ 3614.929464] cfg80211: World regulatory domain updated:
[ 3614.929469] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 3614.929476] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 3614.929482] cfg80211: (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 3614.929488] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 3614.929493] cfg80211: (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 3614.929499] cfg80211: (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 3615.656438] wlan0: authenticate with 00:24:d1:29:b5:c3 (try 1)
[ 3615.854144] wlan0: authenticate with 00:24:d1:29:b5:c3 (try 2)
[ 3615.856736] wlan0: authenticated
[ 3615.857085] wlan0: associate with 00:24:d1:29:b5:c3 (try 1)
[ 3615.859432] wlan0: RX AssocResp from 00:24:d1:29:b5:c3 (capab=0x411 status=0 aid=2)
[ 3615.859441] wlan0: associated

I tried to disable the “wireless N” mode, this way, with same results :
# sudo vi /etc/modprobe.d/iwlagn.conf
options iwlagn 11n_disable50=1 11n_disable=1

I can’t find this device as explicitly supported on https (https://help.ubuntu.com/community/HardwareSupportComponentsWirelessNetworkCardsIntel ):// (https://help.ubuntu.com/community/HardwareSupportComponentsWirelessNetworkCardsIntel )help (https://help.ubuntu.com/community/HardwareSupportComponentsWirelessNetworkCardsIntel ). (https://help.ubuntu.com/community/HardwareSupportComponentsWirelessNetworkCardsIntel )ubuntu (https://help.ubuntu.com/community/HardwareSupportComponentsWirelessNetworkCardsIntel ). (https://help.ubuntu.com/community/HardwareSupportComponentsWirelessNetworkCardsIntel )com (https://help.ubuntu.com/community/HardwareSupportComponentsWirelessNetworkCardsIntel )/ (https://help.ubuntu.com/community/HardwareSupportComponentsWirelessNetworkCardsIntel )community (https://help.ubuntu.com/community/HardwareSupportComponentsWirelessNetworkCardsIntel )/ (https://help.ubuntu.com/community/HardwareSupportComponentsWirelessNetworkCardsIntel )HardwareSupportComponentsWirelessNetworkCardsInte l (https://help.ubuntu.com/community/HardwareSupportComponentsWirelessNetworkCardsIntel )

Can you help me, please? Maybe some idea about what to do? or some extra info to give you?
Best regards,

Some data:

$ lspci
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation 2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series Chipset Family MEI Controller #1 (rev 04)
03:00.0 Network controller: Intel Corporation Centrino Wireless-N 1030 (rev 34)

$ lspci -nn

03:00.0 Network controller [0280]: Intel Corporation Centrino Wireless-N 1030 [8086:008a] (rev 34)

$ uname -mr
2.6.38-11-generic x86_64

$ ifconfig wlan0
wlan0 Link encap:Ethernet direcciónHW ac:72:89:73:d6:3d
Direc. inet: Difus.: Másc:
Dirección inet6: fe80::ae72:89ff:fe73:d63d/64 Alcance:Enlace
Paquetes RX:61996 errores:0 perdidos:0 overruns:0 frame:0
Paquetes TX:46802 errores:0 perdidos:0 overruns:0 carrier:0
colisiones:0 long.colaTX:1000
Bytes RX:85832997 (85.8 MB) TX bytes:5593452 (5.5 MB)

$ iwconfig wlan0
wlan0 IEEE 802.11bg ESSID:"MY_ESSID"
Mode:Managed Frequency:2.462 GHz Access Point: 00:24:D1:29:B5:C3
Bit Rate=5.5 Mb/s Tx-Power=15 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:off
Link Quality=30/70 Signal level=-80 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
(as you can see I have already disabled the Wireless-N)

$ lsmod

iwlagn 333716 0
iwlcore 167502 1 iwlagn
mac80211 294370 2 iwlagn,iwlcore
cfg80211 178528 3 iwlagn,iwlcore,mac80211

(to disable Wireless-N , for testing)

$ cat /etc/modprobe.d/iwlagn.conf
options iwlagn 11n_disable50=1 11n_disable=1

$ sudo lshw -C network
PCI (sysfs)
description: Wireless interface
product: Centrino Wireless-N 1030
vendor: Intel Corporation
physical id: 0
bus info: pci@0000:03:00.0
logical name: wlan0
version: 34
serial: ac:72:89:73:d6:3d
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=iwlagn driverversion=2.6.38-11-generic firmware= build 35905 ip= latency=0 link=yes multicast=yes wireless=IEEE 802.11bg
resources: irq:51 memory:f3b00000-f3b01fff
description: Ethernet interface
product: RTL8111/8168B PCI Express Gigabit Ethernet controller
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:0a:00.0
logical name: eth0
version: 06
serial: 14:fe:b5:c6:55:da
size: 100Mbit/s
capacity: 1Gbit/s
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full ip= latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
resources: irq:41 ioport:2000(size=256) memory:f3004000-f3004fff memory:f3000000-f3003fff

Thanks a lot!

/ Angel Galindo Muñoz

September 20th, 2011, 07:48 PM

I’ve solved it. Nothing was wrong. When the system detects that the laptop is on battery mode (AC is not plugged in) it sets the wlan interface in “power off” mode.

It can be easily tested. To know the running power mode just have to do :

$ iwconfig wlan0 | grep "Power Management"
Power Management:off

If it’s set to “on” then there become my performance problems.
To change it on runtime you just have to do :

$ sudo iwconfig wlan0 power off

If you, like me, want to set it always off then you can for example modify the script /usr/lib/pm-utils/power.d/wireless . I simply set this on line 39 (it's iwlagn) :
iwconfig_batt="power off"

There should be some more elegant way to do it ... but it works. There’s more info in these two links about power management, but by now I’ve got enough:
https://help.ubuntu.com/community/PowerManagement/ReducedPower (https://help.ubuntu.com/community/PowerManagement/ReducedPower)
https://wiki.ubuntu.com/PowerManagement (https://wiki.ubuntu.com/PowerManagement)

Best regards!

/ Angel

Wild Man
September 20th, 2011, 08:17 PM
Hi, glad you got it working, and thank you for posting your results for other people to use when they need it.

September 29th, 2011, 06:15 PM
some one asked me for a beginer guide to disable the power management of the wireless NIC.

First of all: this problem will probably affect to lots of wireless cards, overall on laptops and probably on all GNU/Linux distributions . But probably there will be lots of problems on wireless cards on Linux laptops that nothing have to do with this. So, this may not be the solution to your problem.

1) open a terminal to run subsequent commands (in unity, do Ctrl+Alt+t or look for "terminal" in the menu)
sudo iwconfig wlan0 power off3) Run
iwconfig and take a loot at its output. There will appear a list of network interfaces. Look for the lines regarding your wireless card, most probably "wlan0", like this:

wlan0 IEEE 802.11bgn ESSID:"YOUR_ESSID"
Mode:Managed Frequency:2.462 GHz Access Point: 00:11:22:33:44:55
Bit Rate=36 Mb/s Tx-Power=15 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:offVerify if "Power Management" appears "off", if not then maybe did something wrong or on the wrong interface. Well, you could have used this command before the 2nd step to verify if it was "on" before. It if were "on" before then your problem will not be solved this way.

4) Verify if now your network works as expected. If so, then you solved the problem, like me. Now you must set this configuration for future system boots, this way:
sudo gedit /usr/lib/pm-utils/power.d/wirelessnow substitute each "power off" by "power on" (a straight way, you could improve it, obviously). Save it. On other GNU/Linux distributions the power management transition scripts could be in other location.

Can't wait to see if the final release of Ubuntu 11.10 running on my XPS
Best regards,
/ Angel

November 9th, 2011, 01:16 AM
Just a quick question with this card (centrino 1030)

Since power management is off and I have a 25mbps connection and my bit rate is only 11mbps(sometimes I get 1 or 5mbps), what else can be done that's preventing this card from going to full output?

Wild Man
November 9th, 2011, 05:26 PM
Hi, that bit rate is always constantly changing it has a lot to do with signal strength, so you can get closer to your router, but it is not a good way to determine your internet speed.
Thank you

March 30th, 2012, 05:51 PM
Great info, help me, linux mint 12 lisa, dell inspirion n411z. My problem was that after hibernation wireless can't connect to any wireless network. I try to reinstall network manager and to install wicd. But only after this fix my wireless working.