PDA

View Full Version : [ubuntu] Wired network Disconnected - you are now offline



Erica42
September 17th, 2011, 09:49 AM
Hi,

I've recently installed Ubuntu 11.04 on an otherwise empty Dell Latitude D630. The wireless (once configured) works fine. However, I am having quite a bit of difficulty with the wired networking. Both wireless and wired networking are connecting to the same router (it is a Dynalink combined adsl modem/router).

When I plug in the network cable, I get some activity from the router - it blinks, indicating that there is communication occurring. The network icon on the top right hand corner of the laptop's screen (using Classic, not Unity) animates, showing that it is trying to establish a connection. However, after about 30 seconds, I get the message "Wired network Disconnected - you are now offline". As far as I can tell, I never successfully connect

I logged onto the router's web admin console, and I can see that when I instruct Ubuntu to connect to the wired network, it is contacting the router. However, it is only acquiring a <60s lease on the connection, which is then never renewed. I get the message that I have been disconnected before the lease expires. If a connection is made through wireless, it acquires a more reasonable lease of 24 hours.

I confirmed that the router and the network cable are both working as expected, by plugging in a different (Windows XP) laptop. It had no difficulty connecting.

I connected temporarily to the wireless network to download all the updates, so the OS should be fully patched. Unfortunately, I cannot continue to use the wireless as the sole means of connecting as I am installing and configuring these machines for a group which will be using wired networking exclusively.

Outputs from some commonly requested commands follow:

> lspci -nn | grep -i eth
09:00.0 Ethernet controller [0200]: Broadcom Corporation NetXtreme BCM5755M Gigabit Ethernet PCI Express [14e4:1673] (rev 2)

> sudo dhclient
>
[Nothing happens]

> cat /etc/network/interfaces
auto lo
iface lo inet loopback

> cat /etc/resolv.conf
# Generated by NetworkManager
domain home
search home
nameserver 192.168.1.1

Thanks and regards,
Erica

praseodym
September 17th, 2011, 10:14 AM
Hi,

please show:


ifconfig -a
lspci -nnk | grep -iA2 net
lsmod
dmesg | egrep 'eth0|b44'

Erica42
September 17th, 2011, 10:21 AM
Note that these are taken while the wireless was on (so that I could connect to the forum)


> ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:1c:23:2b:46:fb
inet6 addr: fe80::21c:23ff:fe2b:46fb/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:1124 dropped:0 overruns:0 frame:2727
TX packets:40 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:12003 (12.0 KB)
Interrupt:17

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:52 errors:0 dropped:0 overruns:0 frame:0
TX packets:52 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3792 (3.7 KB) TX bytes:3792 (3.7 KB)

wlan0 Link encap:Ethernet HWaddr 00:1d:e0:73:26:87
inet addr:192.168.1.6 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::21d:e0ff:fe73:2687/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1251 errors:0 dropped:0 overruns:0 frame:0
TX packets:1237 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1098327 (1.0 MB) TX bytes:286260 (286.2 KB)

> lspci -nnk | grep -iA2 net
09:00.0 Ethernet controller [0200]: Broadcom Corporation NetXtreme BCM5755M Gigabit Ethernet PCI Express [14e4:1673] (rev 02)
Subsystem: Dell Device [1028:01f9]
Kernel driver in use: tg3
--
0c:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 4965 AG or AGN [Kedron] Network Connection [8086:4229] (rev 61)
Subsystem: Intel Corporation Device [8086:1120]
Kernel driver in use: iwlagn
lsmod
Module Size Used by
cryptd 19801 0
aes_i586 16956 2
aes_generic 38023 1 aes_i586
nls_utf8 12493 1
isofs 39571 1
binfmt_misc 13213 1
parport_pc 32111 0
ppdev 12849 0
arc4 12473 2
iwlagn 284745 0
snd_hda_codec_idt 60537 1
snd_hda_intel 24113 2
snd_hda_codec 90901 2 snd_hda_codec_idt,snd_hda_intel
snd_hwdep 13274 1 snd_hda_codec
iwlcore 148964 1 iwlagn
snd_pcm 80042 2 snd_hda_intel,snd_hda_codec
nouveau 621970 2
snd_seq_midi 13132 0
joydev 17322 0
snd_rawmidi 25269 1 snd_seq_midi
snd_seq_midi_event 14475 1 snd_seq_midi
ttm 65184 1 nouveau
drm_kms_helper 40745 1 nouveau
mac80211 257001 2 iwlagn,iwlcore
psmouse 73312 0
pcmcia 39671 0
drm 184164 4 nouveau,ttm,drm_kms_helper
snd_seq 51291 2 snd_seq_midi,snd_seq_midi_event
snd_timer 28659 2 snd_pcm,snd_seq
yenta_socket 27230 0
i2c_algo_bit 13184 1 nouveau
pcmcia_rsrc 18292 1 yenta_socket
pcmcia_core 21505 3 pcmcia,yenta_socket,pcmcia_rsrc
dell_laptop 13515 0
dell_wmi 12601 0
lp 13349 0
snd_seq_device 14110 3 snd_seq_midi,snd_rawmidi,snd_seq
serio_raw 12990 0
dcdbas 14054 1 dell_laptop
video 18951 1 nouveau
cfg80211 156212 3 iwlagn,iwlcore,mac80211
sparse_keymap 13666 1 dell_wmi
snd 55295 13 snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_ hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_se q_device
parport 36746 3 parport_pc,ppdev,lp
soundcore 12600 1 snd
snd_page_alloc 14073 2 snd_hda_intel,snd_pcm
usbhid 41704 0
hid 77084 1 usbhid
firewire_ohci 31504 0
firewire_core 56138 1 firewire_ohci
crc_itu_t 12627 1 firewire_core
tg3 131476 0

>dmesg | egrep 'eth0|b44'
[ 2.758102] tg3 0000:09:00.0: eth0: Tigon3 [partno(BCM95755m) rev a002] (PCI Express) MAC address 00:1c:23:2b:46:fb
[ 2.758107] tg3 0000:09:00.0: eth0: attached PHY is 5755 (10/100/1000Base-T Ethernet) (WireSpeed[1])
[ 2.758111] tg3 0000:09:00.0: eth0: RXcsums[1] LinkChgREG[0] MIirq[0] ASF[0] TSOcap[1]
[ 2.758115] tg3 0000:09:00.0: eth0: dma_rwctrl[76180000] dma_mask[64-bit]
[ 21.193291] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 22.804832] tg3 0000:09:00.0: eth0: Link is up at 100 Mbps, full duplex
[ 22.804837] tg3 0000:09:00.0: eth0: Flow control is on for TX and on for RX
[ 22.805093] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 33.192072] eth0: no IPv6 routers present

praseodym
September 17th, 2011, 11:01 AM
Checkbox all user rights in "Users&Groups", login again for the changes to take effect, remove your wired profiles under "cable" and "DSL", and reboot your system.

The "Rx-Packages-errors" shown in "ifconfig" mean you are not receiving packages. Check the mtu-value of your ISP and add the number instead of "Automatically" into the network-manager applet.

Additionally you can add the nameservers of your ISP (or the google public NSs 8.8.8.8 and 8.8.4.4) in the network-manager applet. Choose "IPv4-settings" and "Automatic (DHCP), addresses only" in the pull-down-menu; add the NM in "DNS-servers", separated by comma.

Erica42
September 17th, 2011, 11:51 AM
Hi phraseodym,

Thanks for the very prompt responses. I added all roles to all users, removed all saved network profiles in all menus, and restarted. This does not seem to have helped.

I tried setting the mtu manually (initially to 1464, which is the correct value according to my tests from other machines, but I also tried as low as 16 bytes) with no success. All the RX packets are still erroring.

I also tried adding the Google DNS servers, and setting the type to Automatic DHCP (Addresses Only). No luck. I believe the issue is occurring before I'm hitting DNS though, because I cannot get a connection to my network at all (internet or no), not even to ping another local PC.

bkratz
September 17th, 2011, 12:05 PM
@praseodym (http://ubuntuforums.org/member.php?u=1411497)
Regarding your earlier response
I have looked and looked and don't see b44 module in the lsmod above. Isn't the op actually using tg3?

bkratz
September 17th, 2011, 01:27 PM
Since praseodym (http://ubuntuforums.org/member.php?u=1411497) has not yet returned, here are a couple of threads where the user seemed to have the same situation.

http://ubuntuforums.org/showthread.php?p=11242619

posts 66 thru 71

http://ubuntuforums.org/showthread.php?p=11219319

posts 35 thru the end


Good luck hope you find something useful!

praseodym
September 17th, 2011, 02:30 PM
[Austrian (not Australian :P ) accent]
I'll be back
[/Austrian accent]

Your router firmware is up-to-date? MAC-Filter allows new clients?

You may want to try: Unplug all components (router, modem, splitter, PC, notebook-battery, whatever) completely from any current for about 10 minutes. After that replug everything and try again, maybe some firmware is 'stuck' somewhere.

Erica42
September 18th, 2011, 02:59 AM
No MAC filtering on my network (if there were, the wi-fi wouldn't have worked either). I updated the firmware on the router to the latest, restarted, then disconnected everything from everything else for 20 minutes (just to be safe), then plugged everything back in.

Same symptoms.

I tried installing on another laptop from the same batch (same make and model). It's experiencing exactly the same symptoms. It feels like an OS/hardware mismatch.

I've been able to connect to this network with XP, Vista and OSX devices before, and none of the hardware involved is exactly cutting edge new... On any other OS, I'd swear that this was an ethernet driver issue. Is there a list somewhere of all of the supported devices in Ubuntu? Just so I can confirm that my ethernet card is definitely on it?

@bkratz, Thanks, I'll read through those threads. Here's hoping!

randyg271
December 1st, 2012, 07:13 AM
Hi Erica42,

Since installing Ubuntu 12.04 I too have noticed the network disconnected message appearing, whereas my access to my internal network and the Internet seemed fine. So... I did this:

sudo su -
cd /var/log
tail -f syslog

It was then that I saw DHCP message regarding...

Nov 30 22:45:30 hostname NetworkManager[962]: <info> (usb0): deactivating device (reason 'connection-removed') [38]
Nov 30 22:45:30 hostname NetworkManager[962]: <info> (usb0): canceled DHCP transaction, DHCP client pid 3266

This was the clue I needed to fix the issue, since I have no network connection on usb0. My wired connection is on eth0. I clicked on the Network icon, selected Edit Connections and deleted my Wired connections, then added back just one. When adding the one back I was careful to select (Eth0) in the Device MAC Address drop down (which also showed (Usb0).

This fixed my problem. Best of luck to you.

Cheers,
-Randy

wildmanne39
December 1st, 2012, 05:28 PM
Thanks for sharing and please do not post in threads that have not had activity for a year or longer, since this is an old thread it has been closed.