PDA

View Full Version : [SOLVED] Accessing shared folders in Virtualbox



rmcellig
September 17th, 2011, 12:52 AM
I have Virtualbox installed on my Mac and am accessing as guest Ubuntu 11.04. I have the guest additions installed with two shared folders that show up in the Devices/Shared Folders pull down menu. How can I access these folders in Ubuntu?

varunendra
September 17th, 2011, 05:34 PM
"Network" in nautilus?

Morbius1
September 17th, 2011, 05:39 PM
The shared folders on the Ubuntu guest should be mounted automatically to:

/media/sf_share-name

rmcellig
September 17th, 2011, 07:10 PM
I can see them but for some reason I can't access them.

Morbius1
September 17th, 2011, 07:25 PM
Perhaps you didn't automatically get added to the right group.

In the Ubuntu guest:

sudo gpasswd -a morbius vboxsf
Change morbius you your own Ubuntu user name.

You will have to logout ( of the guest - not the host ) and login again for the group membership to take affect.

rmcellig
September 17th, 2011, 07:38 PM
home@home-VirtualBox:~$ sudo gpasswd -a home
Usage: gpasswd [option] GROUP

Options:
-a, --add USER add USER to GROUP
-d, --delete USER remove USER from GROUP
-h, --help display this help message and exit
-r, --remove-password remove the GROUP's password
-R, --restrict restrict access to GROUP to its members
-M, --members USER,... set the list of members of GROUP
-A, --administrators ADMIN,...
set the list of administrators for GROUP
Except for the -A and -M options, the options cannot be combined.
home@home-VirtualBox:~$


Does this look right? If so, I restart my gust session to invoke the correct permissions?

Morbius1
September 17th, 2011, 08:06 PM
The group you need to add yourself to is vboxsf so the command is:

sudo gpasswd -a home vboxsf

haqking
September 17th, 2011, 08:18 PM
See here if you still have problems.

https://help.ubuntu.com/community/VirtualBox/SharedFolders

rmcellig
September 17th, 2011, 08:59 PM
That worked thanks!!!