View Full Version : Crysis2, Mafia2 not working on Wine 1.3.27

September 14th, 2011, 03:29 PM
I'm trying to run three games on both stable and unstable version of Wine of which I've found two of them been confirmed working by others on Ubuntu 11.04 Natty:

Crysis2: http://appdb.winehq.org/objectManager.php?sClass=version&iId=23103&iTestingId=63335

http://s3.postimage.org/96ucl6ro/Crysis2.jpg (http://postimage.org/image/96ucl6ro/)
http://s3.postimage.org/970yqkqs/Crysis2_2.jpg (http://postimage.org/image/970yqkqs/)

Mafia II: http://appdb.winehq.org/objectManager.php?sClass=version&iId=21257

http://s3.postimage.org/9798fb7o/Mafia_II.jpg (http://postimage.org/image/9798fb7o/)

MX vs ATV Reflex

http://s3.postimage.org/97j5ne6c/MXvs_ATVReflex.jpg (http://postimage.org/image/97j5ne6c/)

I've tried this tutor: http://www.wine-reviews.net/microsoft/directx-90c-march-2008-redistributable-on-linux-with-wine.html , installing DirectX9 but when I run the .exe (after this mod) nothing happens.

After trying the tutor above, I found out that the WineHQ states that DX9.0c is bundled with Wine by default, and that NO attempts should be made to install DX9.0c manually. Despite of this, it doesn't work. It's weird because, I'm running the same game on the same OS-version with the same Wine-version with the same wine config :confused:

I've also tried to update my current driver for my GPU (nVidia GeForce GT540M, 2GB).