View Full Version : [ubuntu] issues connecting to some websites on TEW-652BRP router

September 13th, 2011, 02:58 AM

I recently got a TEW-652BRP router and I'm having an issue connecting to specific websites. I can connect to google, facebook, hotmail, gmail and most other pages fine, but when I try to go to my bank's webpage, actually any bank's page, or to sites like hiphopdx or wordpress.org, the connection hangs or I get a 400 error.

My computer is a Dell Optiplex with Ubuntu 11.04.

I have the router set up on WPA-Auto PSK, AES, but I've tried every setting including disabling router security to no avail.

My ISP is a DSL provider.

I have no problem connecting directly through my modem and after some fiddling with the other two computers on the network, one uses vista and the other uses XPSP2, I managed to get them to work perfectly although they initially had the same problem.

I had no problems on my old dlink router, which unfortunately was taken when a roommate moved out. The old network had a Mac, a vista machine, and comp with XPSP2.

My computer uses a wired connection. The other computers use wireless.

When I ping these websites from either the router or network tools the test fails.

I've tried using Opera instead of Firefox with no success.

I've reset the router to factory settings multiple times and upgraded firmware.

I've checked all of the boxes in user privileges, deleted the connection, rebooted etc.

I'm a total linux noob so...

Thanks for the help in advance!