PDA

View Full Version : [SOLVED] Samba share on mdadm RAID5 array not working



PsyWolf
September 11th, 2011, 04:48 AM
So I finally decided to protect my data with a RAID5 array. I created the array using the disk utility in ubuntu 11.04 (which uses mdadm)

everything went smoothly, until I tried to share some folders on my new raid array. The all the folders that I've shared can be seen from other computers, but if they try to dive into a folder that is on the raid array, they can't access it (an error message).

Here are all the relevant config files that I can think of.
I've colored the lines that I added to these files in red, everything else was autogenerated

/etc/mdadm/mdadm.conf


# mdadm.conf
#
# Please refer to mdadm.conf(5) for information about this file.
#

# by default, scan all partitions (/proc/partitions) for MD superblocks.
# alternatively, specify devices to scan, using wildcards if desired.
DEVICE partitions

# auto-create devices with Debian standard permissions
CREATE owner=root group=disk mode=0660 auto=yes

# automatically tag new arrays as belonging to the local system
HOMEHOST <system>

# instruct the monitoring daemon where to send mail alerts
MAILADDR root

# definitions of existing MD arrays
ARRAY /dev/md0 UUID=ddbb56ca:19f293fe:6389b985:d34776a0

# This file was auto-generated on Sun, 04 Sep 2011 13:58:46 -0400
# by mkconf $Id$


/etc/fstab


# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc nodev,noexec,nosuid 0 0
# / was on /dev/sda1 during installation
UUID=42255048-1ba3-4d85-894d-a9152b2d9e90 / ext4 errors=remount-ro 0 1
# swap was on /dev/sda5 during installation
UUID=e77516f9-eaa1-4f38-8801-bc5ac28cbd3b none swap sw 0 0

#raid array
UUID=e5d6f1ab-e480-41b2-a151-bf2b7ccaa8ac /media/storage ext4 defaults 0 2


/var/lib/samba/usershares/music


#VERSION 2
path=/media/storage/Music
comment=
usershare_acl=S-1-1-0:R,S-1-5-21-3391782369-3425552386-2711179393-3000:F
guest_ok=y


Any suggestions would be really helpful.

PsyWolf
September 25th, 2011, 02:44 AM
bump?
(I really hate bumping threads, but I could really use some help here.)