View Full Version : [SOLVED] Internet Issues with Aspire one 722

September 10th, 2011, 01:55 AM
I have a new Aspire one 722 netbook. Loaded Ubuntu 10.04 onto it and all network detection stopped.

Turns out I have a Broadcom 4727 wireless chipset and and Atheros wired chipset. Both unsupported by Ubuntu drivers I need to know how to upload the Broadcom drivers via usb drive so I can get online to fix other issues. I am not very familiar with terminal comands so kind of need them spelled out.

September 10th, 2011, 03:40 AM
Can you even get online with an ethernet cable hardwired directly to the router/modem?

September 10th, 2011, 12:43 PM

for this wireless device you need the Broadcom-STA-driver. You can install it from installation CD/DVD. Add the medium to your software sources and install the packages dkms, patch, fakeroot, and bcmwl-kernel-source from CD. After that:

sudo depmod -a
Now you should be able to activate the driver in System->Settings->Hardware drivers.

For wired:

please show the outputs of

lspci -nnk | grep -iA2 net

September 11th, 2011, 02:30 AM
No have no ethernet because of the Atheros chipset also have no way to use CD I installed by usb because its a netbook and has no cd drive
Am having to use school computers to use the net and I don't live on Campus so sorry for late replies
Atheros chipset is AR8152 if that helps. Alternatly if you know and Linux installs availabe for usb, compatible with either chipset I could try a different OS

September 11th, 2011, 12:04 PM
32 bit:




64 bit:




For both additionally:


Save them on your Desktop and install via:

sudo dpkg -i ~/Desktop/*.deb
sudo depmod -a
Then activate the driver via System->Settings->Hardware drivers

You may reboot, too.

September 12th, 2011, 01:15 AM
That worked with the 32 bit files after reboot! Thank you so much I was beginning to consider going back to Windows I was getting so frustrated. That would have sucked because I really do love Ubuntu.