PDA

View Full Version : [SOLVED] Having display issues Please help



Evonus
September 1st, 2011, 05:29 PM
Hello,

I have a Lenovo W520 thinkpad.

I'm trying to run dual monitors and I've read these two threads:

http://ubuntuforums.org/showthread.php?t=221174

http://ubuntuforums.org/showthread.php?p=1773584

But after running this command "sudo apt-get --purge remove xserver-xorg-video-nouveau" now I no longer even have a display when I boot up normally.

I'm running in low graphics recovery mode right now.

Using the additional drivers menu, I did install the Nvidia accelerated graphics driver, but its telling me that the driver is installed but not currently in use.

When I try to open Nvidia Xserver settings, I get this error message :

"You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server."

I googled it and got this: http://blog.musicvm.com/solved-you-do-not-appear-be-using-nvidia-x-driver-linux-ubuntu

but after running through the steps I find that it doesn't help me.

Can someone please help me!

realzippy
September 1st, 2011, 05:38 PM
Isn't that an Optimus laptop?

Evonus
September 1st, 2011, 06:07 PM
Isn't that an Optimus laptop?

I'm honestly not sure.

How would I find that out, and what would that change?

realzippy
September 1st, 2011, 06:19 PM
I am too lazy to tell,since there are a bunch of threads about nvidia
optimus technology related not-working-nvidia-linux-drivers....

Run this:


lspci |grep VGA

if you see 2 devices (intel and nvidia),you very likely have an optimus laptop.Then read this:
http://ubuntuforums.org/showthread.php?t=1657660

Evonus
September 1st, 2011, 07:11 PM
I am too lazy to tell,since there are a bunch of threads about nvidia
optimus technology related not-working-nvidia-linux-drivers....

Run this:


lspci |grep VGA

if you see 2 devices (intel and nvidia),you very likely have an optimus laptop.Then read this:
http://ubuntuforums.org/showthread.php?t=1657660

You were right. I went into the bios and killed that option so now I'm just running off of the nvidia card.

Thanks a lot for you help!

realzippy
September 1st, 2011, 08:02 PM
Luck you have a switch in the BIOS.I don't...
Set thread as solved please (ThreadTools)
Have fun
zippy