PDA

View Full Version : [xubuntu] Audio CDs do not work



medevacs
August 31st, 2011, 11:13 AM
My DVD drive does not play audio CDs. I have all codecs/restricted codecs, normal (with files) CDs and DVDs as well as DVDs with movies work great but after inserting audio CD nothing happens. If i start VLC (or Parole) and choose to play content from disc -> audio CD nothing happens. File manager sees "Audio Disc" in the drive but clicking on it returns "Failed to mount "Audio Disc". Drive /dev/sr0 does not contain audio files.". I am sure it does contain audio files as I tried 3 different legit audio CDs. Does DVD drive have to be declared in /etc/fstab? This file is pretty much empty in my system, there are only lines regarding hard drive partitions. But as I already said, other CDs or DVDs work without any trouble, it is just Audio CDs that don't work. How to fix it?

edwardoclese
November 21st, 2011, 02:13 AM
Same here! Mal-function, exactly as you describe, yet the drive operates perfectly under other OS's.

I am a Panasonic CF-52 running Ubuntu Studio 11.10 Oneiric.

andrew.46
November 21st, 2011, 10:25 PM
This problem has popped up quite often with not much resolution. Oddly enough many can still play their audio cds with MPlayer:



mplayer -cache 2048 cdda://


or even:



mplayer -cache 2048 -cache-min 80 cddb://


Not sure how to resolve the underlying issue though...

edwardoclese
November 22nd, 2011, 01:34 AM
I installed gvfs-backends and my problems seem to be solved.

lekremyelsew
December 1st, 2011, 11:31 AM
Same here! Mal-function, exactly as you describe, yet the drive operates perfectly under other OS's.

I am a Panasonic CF-52 running Ubuntu Studio 11.10 Oneiric.

That's because the problem is related to Thunar (which isn't there in the other OS's). In the Removable Drives and Media settings window turn off the mount and browse removable media check boxes and that should do the trick.

mikrowelle
December 13th, 2011, 10:21 PM
I installed gvfs-backends and my problems seem to be solved.

Thanks, this worked for me! Changing the settings for removable drives as suggested in the above post didn't do anything for me.

carreiro
December 14th, 2011, 09:57 PM
Thanks after that I installed gvfs-backends pack cdrom works very well.